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About This Guide

The Kablink Vibe OnPrem 3.1 Advanced User Guide explains how to use advanced features of the
Vibe product.

+ Chapter 1, “Are You an Advanced Vibe User?,” on page 11

+ Chapter 2, “Creating and Managing Workspaces,” on page 15

+ Chapter 3, “Managing Folders,” on page 25

+ Chapter 4, “Controlling Access,” on page 37

+ Chapter 5, “Branding a Folder or Workspace,” on page 47

+ Chapter 6, “Creating and Managing Landing Pages,” on page 49

+ Chapter 7, “Creating Custom Workspace Views,” on page 77

+ Chapter 8, “Creating Custom Folder Views,” on page 87

+ Chapter 9, “Designing Custom Folder Entry Forms,” on page 97

+ Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 109

+ Chapter 11, “Creating and Managing Workflows,” on page 113

+ Chapter 12, “Managing Remote Applications,” on page 151

+ Chapter 13, “Managing Your Data Quota,” on page 157

+ Chapter 14, “Restoring Deleted Items,” on page 163

+ Chapter 15, “Using Vibe on Your Mabile Phone,” on page 165

+ Appendix A, “What's New in Vibe 3x,” on page 175

+ Appendix B, “Using HTML Markup in Vibe OnPrem,” on page 179

Audience

This guideisintended for all new Kablink Vibe users who want more information about advanced
Vibe functionality.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comments feature at the bottom of each page of the
online documentation, or go to www.novell.com/documentati on/feedback.html and enter your
comments there.

Documentation Updates

For the most recent version of this manual, visit the Kablink Vibe OnPrem 3.1 Documentation Web
site (http://www.novell.com/documentation/kablinkvibe_onprem31).

About This Guide
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Additional Documentation

You can find more information in the Kablink Vibe documentation, which is accessible from the
Kablink Vibe OnPrem 3.1 Documentation Web site (http://www.novell.com/documentation/
kablinkvibe_onprem31).

To access the Kablink Vibe OnPrem 3.1 User Guide from within Vibe, click the Help icon (question
mark).
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Are You an Advanced Vibe User?

Kablink Vibe OnPrem is an enterprise collaboration tool designed to increase individual
productivity, team effectiveness, and organizational success by providing the right set of toolsto the
right people. Key Vibe features include Team workspaces, calendars, task lists, document
management, discussion threads, wikis, blogs, RSS feeds, and workflows.

Vibe enables ordinary users to perform content-management functions. Because all Vibe users need
to manage a personal workspace, and can a so create team workspaces, all users have the potential to
become “advanced Vibe users.”

Although al Vibe users have the ability to become advanced users, many users never have the need
to progress beyond the basic Vibe functionality. Thisis because Vibe lends itself to two main
groups: content consumers and content providers.

+ Section 1.1, “Content Consumers,” on page 11
* Section 1.2, “Content Providers,” on page 11

1.1 Content Consumers

Content consumers use Kablink Vibe to get important information that pertains to them. They
participate in team workspacesin order to better collaborate with colleagues and facilitate their work
assignments. They identify subject-matter experts and search for important information.

Content consumers can learn how to accomplish these and other important tasksin the Kablink Vibe
OnPrem 3.1 User Guide

1.2 Content Providers

Content providers use Kablink Vibe to manage teams by creating team workspaces and making
information easily accessible through landing pages and other advanced Vibe features.

Advanced Vibe users might perform any of the following functions:

+ Create or manage workspaces and folders: When you create your own workspace or folder,
you are the owner of that workspace or folder. By default, you are aso the owner of al sub-
workspaces and sub-folders.

For example, suppose that your manager assigns you to lead an advertising campaign for a new
product. Because accomplishing this assignment involves the combined efforts of various
members of your team, you decide to create a new workspace dedicated to the new campaign.

For in-depth information, see Chapter 2, “ Creating and Managing Workspaces,” on page 15
and Chapter 3, “Managing Folders,” on page 25.
+ Control user accessto workspaces and folders. Asthe owner of aworkspace or folder, you

are responsible for controlling which users have access rights, and deciding which rights are
appropriate for which people.

For example, as the advertising campaign manager for a new product, you need to decide if
Vibe users who are not members of your team are allowed to create entries in your team
workspace, or whether non-team members should even be allowed to view the workspace.

Are You an Advanced Vibe User? 11
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Also, when new users join the team, it is your responsibility to grant them appropriate rights.
For in-depth information, see Chapter 4, “Controlling Access,” on page 37.

Create unique brandsfor workspaces and folders. Asthe owner of aworkspace or folder,
you are responsible for creating a unique and attractive brand. Creating a unique brand isa
good way to differentiate your workspace or folder from other placesin the Vibe site.

For example, as the advertising campaign manager for anew product, you brand your team
workspace with a graphic of the product logo, along with the new marketing slogan.

For in-depth information, see Chapter 5, “Branding a Folder or Workspace,” on page 47.

Create landing pages: Asthe owner of aworkspace, you can present the most important
information on the home page of the workspace. At the sametime, you can change the look and
feel of the home page. (You cannot create landing pagesin personal workspaces.)

For example, as the advertising campaign manager for a new product, you create alanding
page in the team workspace. In the landing page you display the current product shipment
schedule, the latest news concerning the product, open tasks as they relate to your team
members, and so forth.

For in-depth information, see Chapter 6, “ Creating and Managing Landing Pages,” on page 49.

Create custom wor kspace and folder views: Asthe owner of aworkspace or folder, you can
create custom views that modify what is displayed on the home page of your workspace or
folder. You can display uploaded files, remote applications, pictures, and more.

For example, as the advertising campaign manager for a new product, you can customize the
home page of your team workspace to display pictures of the various marketing logo options
for the product, as well as uploaded notes from team meetings.

For in-depth information, see Chapter 7, “ Creating Custom Workspace Views,” on page 77 and
Chapter 8, “Creating Custom Folder Views,” on page 87.

Create custom folder entry forms: Asthe owner of aworkspace or folder, you can create
custom folder entry forms that users can fill in when they are making entriesin the workspace
or folder.

For example, as the advertising campaign manager for anew product, you decide to create a
new folder called “ Slogans.” Inside this folder, you create a new entry form that enables team
members to easily submit their ideas for catchy slogans for the new product. The entry form
contains afield for the team member to type his or her name, a field where they can type the
slogan, afield where they can upload pertinent pictures, and so on.

For in-depth information, see Chapter 9, “Designing Custom Folder Entry Forms,” on page 97.

Create and manage wor kflows: Asthe owner of aworkspace or folder, you can create
workflows that automate otherwise time-consuming manual processes.

For example, as the advertising campaign manager for a new product, you natice that expense
reporting is taking more time than you want. The current processis for members of your team
to request an expense reimbursement from you, then for you to send the request to HR, who
then transfers the request to Finance. To automate this process, you implement aworkflow that
sends you an e-mail notification requesting your approval when the request is submitted. When
you give your approval, the workflow is automatically transferred to HR. If HR approvesthe
reguest, then the workflow is transferred to Finance, where the reimbursement is addressed.

For in-depth information, see Chapter 11, “ Creating and Managing Workflows,” on page 113.
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+ Manage remote applications: Asthe owner of aworkspace or folder, you can enable remote
applications that have been set up by your Vibe administrator.

For in-depth information, see Chapter 12, “Managing Remote Applications,” on page 151.

Are You an Advanced Vibe User? 13
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Creating and Managing
Workspaces

Kablink Vibe OnPrem enables you to create and manage your workspaces in the following ways:

+ Section 2.1, “Creating and Managing a Team Workspace,” on page 15

* Section 2.2, “Creating and Managing a Discussions Workspace,” on page 16

+ Section 2.3, “Creating and Managing a Basic Workspace,” on page 17

+ Section 2.4, “Creating and Managing a Project Management Workspace,” on page 17

+ Section 2.5, “Creating and Managing a Team Workspace Root Workspace,” on page 20
+ Section 2.6, “Using Globa Workspaces,” on page 21

+ Section 2.7, “ Creating Workspace Hierarchies,” on page 21

+ Section 2.8, “Creating Custom Workspace Views,” on page 22

+ Section 2.9, “Genera Workspace Management,” on page 23

2.1 Creating and Managing a Team Workspace

Team workspaces are the key to helping you and your team accomplish tasks and meet objectives,
together.

Asthe owner of aworkspace, you are primarily responsible for workspace administration. You can
create other containers for information (sub-workspaces and folders), adjust access control to
determine who can do what in the workspace, and provide some initial content to assist team
members with getting started.

For information about how to perform basic management tasks on a team workspace, such as
creating the workspace, adding team members, and sending e-mail to team members, see“Managing
a Team Workspace” in the Kablink Vibe OnPrem 3.1 User Guide.

+ Section 2.1.1, “Allowing Visitors to Your Team Workspace,” on page 15

+ Section 2.1.2, “Using Team Workspaces to Create Hierarchies,” on page 16

2.1.1 Allowing Visitors to Your Team Workspace

By default, only team members can view and participate in the workspaces and folders contained in
the team workspace. There might be times when you want to alow other people to visit your team
workspace (which, by default, means that they can read entries and comment on them, but they
cannot create entries).

To alow visitors to your team workspace:

1 Navigate to the team workspace where you want to alow visitors.
2 Click Workspace > Access Control.
Kablink Vibe displays the Configure Access Control page for the team workspace.
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3 Ensure that the workspace is not inheriting its access control settings. Select the no radio
button, then click Apply.

4 (Conditional) If Visitor isnot aready acolumn in the provided table, click Add a Role > Visitor:

5 Ontheleft side of the table, click Add a User, then use the type-to-find functionality to select
the name of the person you want to add as a visitor to the team workspace.

6 Inthat new user’s row, select the check box in the Visitor column.
7 Repeat Step 5 and Step 6 until you have added all your visitors.
8 Click Save Changes > Close.

The people who now have the Misitor role can view your team workspace and add comments to
existing entries. They cannot create new entries.

For more information on managing access control, see Section 4.2, “Managing Access Control for
Users and Groups,” on page 39.

2.1.2 Using Team Workspaces to Create Hierarchies

Team workspaces in Vibe can be used to organize information inside of existing workspaces,
creating different levels of hierarchy within a workspace.

You can also use other types of workspaces to create hierarchies. For information explaining the
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating
Workspace Hierarchies,” on page 21.

2.2 Creating and Managing a Discussions
Workspace

The Discussions workspace can be the home page for a set of discussion forums. You can aso use
the Discussions workspace to house other types of folders.

Discussions workspaces can be particularly useful for site administrators, or other Kablink Vibe
users who are responsible for creating the overall structure of the Vibe site. For example, you can
use a Discussions workspace to organize a set of company-wide discussions on various topics. This
can help organize your Vibe site, so users know where they should go if they are looking for a
particular discussion forum.

+ Section 2.2.1, “Creating a Discussions Workspace,” on page 16

+ Section 2.2.2, “Using Discussions Workspaces to Create Hierarchies,” on page 17

2.2.1 Creating a Discussions Workspace

1 Navigate to the place in Vibe where you want to create the Discussions workspace.

Depending on your rights, you might create this workspace at the Global level, if you are
creating a company-wide Discussions workspace; or you might create this workspacein a
lower-level workspace, if the Discussions workspace isintended for a smaller number of Vibe
users.

2 Click Workspace > New Workspace in the Action tool bar.
The New Workspace page is displayed.
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3 Inthe Workspace Title field, specify a name for the Discussions workspace.
4 In the Workspace section, select Discussions Workspace.
5 Inthe Workspace Folders section, select Discussion.
You can add additional Discussion folders after the workspace has been created.
6 Click OK.

2.2.2 Using Discussions Workspaces to Create Hierarchies

Discussions workspaces in Kablink Vibe can be used to organize information inside of existing
workspaces, creating different levels of hierarchy within aworkspace.

You can also use other types of workspaces to create hierarchies. For information explaining the
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating
Workspace Hierarchies,” on page 21.

2.3 Creating and Managing a Basic Workspace

Basic workspaces in Kablink Vibe can be used to organize information inside of existing
workspaces, creating different levels of hierarchy within aworkspace.

You can also use other types of workspaces to create hierarchies. For information explaining the
advantages and disadvantages of using each type of workspace, see Section 2.7, “Creating
Workspace Hierarchies,” on page 21.

To create a basic workspace:

1 Navigate to the place in Vibe where you want to create the basic workspace.
2 Click Workspace > New Workspace in the Action tool bar.
The New Workspace page is displayed.
3 Inthe Workspace Title field, specify a name for the basic workspace.
4 Inthe Workspace section, select Workspace.

5 Inthe Workspace Folders section, select the folders that you want the new workspace to
contain.

You can add additional folders after the workspace has been created.
6 Click OK.

2.4 Creating and Managing a Project
Management Workspace

Project Management workspaces include special accessories that help leaders track the progress of
task completion for potentially large projects. Although Project Management workspaces can

contain any type of folder, they are specifically designed to work in conjunction with Tasks and
Milestones folders.

+ Section 2.4.1, “ Creating a Project Management Workspace,” on page 18
+ Section 2.4.2, “Managing a Project Management Workspace,” on page 18
+ Section 2.4.3, “Understanding Tasks and Milestones,” on page 18
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2.4.1 Creating a Project Management Workspace

1 Navigate to the place in Kablink Vibe where you want to create the Project Management
Workspace.

2 Click Workspace > New Workspace in the Action tool bar.
The New Workspace page is displayed.

3 Inthe Workspace Title field, specify a name for the Project Management workspace.

4 In the Workspace section, select Project Management Workspace.

5 Click OK.

2.4.2 Managing a Project Management Workspace

After you create the Project Management workspace, notice that the workspace contains key fol ders,
such as a Tasks folder, Milestones folder, Files folder, and so forth.

The home page of the Project Management workspace provides the following features that enable
you to better manage your project:

Task Summary Accessory: Thisaccessory listsall of the tasksthat exist in the Tasks folder of your
Project Management workspace.

To modify theinformation in this accessory, navigate to the Tasks folder of this Project Management
workspace. For information about Tasks folders, see “Working with Tasks Folders™ in the Kablink
Vibe OnPrem 3.1 User Guide.

Project Information Box: Displays the Status, Manager, and Due Date of the project.
To modify thisinformation:

1 Click Workspace > Edit Workspace in the Action toolbar.

2 Inthe Project Information Box section, modify the Manager, Satus, and Due Date fields as
needed.

3 Click OK.
Project Satistics: Displays the current task and milestone statistics that are associated with the
project.

2.4.3 Understanding Tasks and Milestones

Because tasks and milestones contribute important information to your Project Management
workspace, it isimportant that you understand how they work.

+ “Understanding Tasks’ on page 18
+ “Understanding Milestones’ on page 19

Understanding Tasks

Tasks folders keep track of the progress made in completing work assignments. For information
about Tasks folders, see “Working with Tasks Folders” in the Kablink Vibe OnPrem 3.1 User Guide.
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Understanding Milestones

The Milestones folder contains the various milestones for a project. Each milestone entry has
specific Tasks folders that are associated with the milestone. When al of the tasksin the Tasks
folders are complete, you can mark the milestone that is associated with those tasks as completed.

+ “Creating aMilestone” on page 19

+ “Using the Milestones Folder” on page 19

+ “Modifying aMilestone” on page 20

Creating a Milestone

1 Navigate to the Milestones folder in your Project Management workspace.
2 Click Add Milestone.
The Milestone page is displayed.
3 Specify the following information:
Title: Provide atitle for the milestone.
Description: Describe the milestone.
Due Date: Specify when the milestone is due.
Responsible: Specify the users who are responsible for completing the milestone.
Responsible Groups: Specify the groups who are responsible for completing the milestone.
Responsible Teams: Specify the teams who are responsible for completing the milestone.

Send an E-Mail Natification to Responsibles: Select this option if you want Vibe to send an
e-mail notification and iCal task/appointment to all of the users, groups, or teams that you
associate with the entry.

For moreinformation oniCal functionality in Vibe, see “ Synchronizing Tasks and Calendarsto
aDesktop Application” in the Kablink Vibe OnPrem 3.1 User Guide.

Satus: Use the drop-down list to specify a status for the milestone (Open, Reopen,
Completed).

Task Folders: Usethetreeto navigate to and select the Tasks foldersthat you want to associate
with the milestone.

The tasks in these Tasks folders must be completed before the milestone can be marked as
Completed.

Attachments. Attach any appropriate files.

Subscribeto This Entry: You can configure Vibe to send you natifications when activity
takes place in this entry. For more information, see “ Subscribing to a Folder or Entry” in the
Kablink Vibe OnPrem 3.1 User Guide.

Send E-Mail When Entry is Submitted: To ensure that certain co-workers are aware of your
entry, you can send them an e-mail directly from Vibe, notifying them that an entry has been
created. For more information, see “Filling Out the Send E-Mail Page” in the Kablink Vibe
OnPrem 3.1 User Guide.

Using the Milestones Folder

The Milestones folder contains the following columns that contain information about each
milestone:
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Name: Displays the name of the milestone.
Responsible: Displays the people who are responsible for the milestone.
Tasks: Displaysthe Tasks folders that are associated with the milestone.

Mouse over the colorsin the bar chart, and Vibe explains the value (needs action, in process,
completed).

Satus: Displays the status of the milestone.

Duedate: Displays the due date of the milestone.

Modifying a Milestone

1 Inthe Milestones folder, click the milestone name in the Name column.
The milestone entry is displayed.

2 Inthe Entry toolbar, click Modify.
The Milestone page is displayed.

3 Make any modifications, then click OK.
You might need to refresh the page for your changes to be displayed.

2.5 Creating and Managing a Team Workspace
Root Workspace

A Team Workspace Root workspace is designed to contain multiple team workspaces. Use this type
of workspace if you want to create additional team workspaces as sub-workspaces to this
workspace. When users with appropriate rights view this workspace, they can easily create a new
team workspace by clicking the Add a Team Workspace button, as described in “ Creating a Highly

Visible Team Workspace” in the Kablink Vibe OnPrem 3.1 User Guide. The Add a Team Workspace
button is not displayed in regular team workspaces.

You can control who has access to create workspaces in Team Workspace Root workspaces by
modifying the access controls, as described in Chapter 4, “ Controlling Access,” on page 37.

For more information on organizing team workspaces for aKablink Vibe site, see “Organizing Team
Workspaces® in the Kablink Vibe OnPrem 3.1 Administration Guide.

To create a Team Workspace Root workspace:

1 Navigate to the location where you want to create the Team Workspace Root workspace.

2 Create aregular team workspace, as described in “ Creating a Team Workspace inside of an
Existing Team Workspace” in the Kablink Vibe OnPrem 3.1 User Guide.

3 Navigate to the workspace that you just created in Step 2.
4 Click Workspace > Configure in the Action tool bar.

The Configure Default Settings page is displayed.
5 Inthe Default View section, select Team Workspace Root.
6 Click Apply > Close.
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2.6 Using Global Workspaces

Global workspaces contain information beyond the scope of teamwork that might be of interest
broadly across your organization.

Global workspaces can be created only by Kablink Vibe administrators. For more information on
Global workspaces, see “ Creating Global Workspaces® in the Kablink Vibe OnPrem 3.1
Administration Guide.

2.7 Creating Workspace Hierarchies

Creating hierarchiesin Kablink Vibeisapowerful way to organize workspacesin a meaningful way.
Hierarchies can make information easier to find and increase effectiveness across the Vibe site.

Vibe provides three types of workspaces that you can use to create hierarchies within existing
workspaces. Each type of workspace has its advantages and disadvantages for creating workspace
hierarchies. Depending on your objectives and your environment, you might want to use any of the
following types of workspaces:

+ Section 2.7.1, “Discussions Workspaces,” on page 21
* Section 2.7.2, “Basic Workspaces,” on page 22
¢ Section 2.7.3, “ Team Workspaces,” on page 22

2.7.1 Discussions Workspaces

If you don’t anticipate your workspace having hundreds or thousands of sub-folders, Discussions
workspaces are recommended over basic workspaces and team workspaces.

Thefollowing sections describe the advantages and disadvantages of using a Discussions workspace
to create hierarchies within existing workspaces:

+ “Advantages’ on page 21
+ “Disadvantages’ on page 21
Advantages

+ Retainsthe access control rights of higher-level (parent) workspaces by default

+ Lists sub-folders and sub-workspaces on the workspace home page (and displays how many
items are in each folder)

Disadvantages

+ Does not scale well (if you have hundreds or thousands of sub-folders, you should use abasic
workspace to improve performance)
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2.7.2 Basic Workspaces

The following sections describe the advantages and disadvantages of using a basic workspace to
create hierarchies within existing workspaces:

+ “Advantages’ on page 22
+ “Disadvantages’ on page 22
Advantages

+ Retainsthe access control rights of higher-level (parent) workspaces by default

+ Scaleswell (because basic workspaces do not list sub-folders and sub-workspaces on the
workspace home page)

Disadvantages

+ Doesnot list sub-folders and sub-workspaces on the workspace home page

2.7.3 Team Workspaces

The following sections describe the advantages and disadvantages of using a Team workspace to
create hierarchies within existing workspaces:

+ “Advantages’ on page 22
+ “Disadvantages’ on page 22
Advantages

+ Lists sub-folders and sub-workspaces on the workspace home page (and displays how many
items are in each folder)

Disadvantages

+ Does not retain the access control rights of higher-level (parent) workspaces by default

+ Doesnot scale well (if you have hundreds or thousands of sub-folders, you should use a basic
workspace to improve performance)

2.8 Creating Custom Workspace Views

Kablink Vibe enables you to create custom workspace views. Workspace views define what is
displayed on the main page of your workspace. When you create custom workspace views, you can
configure workspaces to display optional features such as remote applications, attachments, and
more.

For information on how to create custom workspace views, see Chapter 7, “ Creating Custom
Workspace Views,” on page 77.
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2.9 General Workspace Management

If you have appropriate rights, you can perform various types of management functionson a
workspace, such as copying the workspace to another location, moving the workspace, adding
foldersto the workspace, deleting the workspace, and so forth.

For information on how to perform these and other types of management tasks, see “General
Workspace Management” in the Kablink Vibe OnPrem 3.1 User Guide.
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Managing Folders

Kablink Vibe OnPrem enables you to manage your foldersin the following ways:

+ Section 3.1, “Managing Folder Views,” on page 25

+ Section 3.2, “Working with Folder Entry Types,” on page 26

+ Section 3.3, “Enabling Folders to Receive Entries through E-Mail,” on page 28

+ Section 3.4, “Setting Up a Folder or External E-Mail Addressto Receive All Sent E-Mail
Messages,” on page 30

+ Section 3.5, “Configuring Foldersto Send E-Mail Natifications to Other Users,” on page 31

+ Section 3.6, “ Setting Up and Using WebDAV,” on page 32

+ Section 3.7, “Viewing Vibe Folders as RSS or Atom Feeds,” on page 35

+ Section 3.8, “Applying Landing Page Elements to a Folder,” on page 35

3.1 Managing Folder Views

Kablink Vibe enables you to change the way you and other users view your folder. You can change
the default view, or alow multiple views.

For example, you might have a Tasks folder where the start date and end date are particularly
important. You can configure your Tasks folder to be displayed in a Calendar folder view to place
emphasis on the start and end dates of tasks. You can make this view the default view, or allow users
to toggle between alternate folder views that you pre-enable.

+ Section 3.1.1, “Changing the Default Folder View,” on page 25

* Section 3.1.2, “Enabling Alternate Folder Views,” on page 26

3.1.1 Changing the Default Folder View

Vibe enables you to change the default view of folders for which you have appropriate rights. This
can be an existing folder view or a custom folder view that you created. For information about how
to create a custom folder view, see Chapter 8, “Creating Custom Folder Views,” on page 87.

+ “Enabling Viewsto Be Used as the Default View” on page 25

+ “Selecting a New Default Folder View” on page 26

Enabling Views to Be Used as the Default View
Before you can set aview as the default folder view, you need to enable that view.

1 Navigate to the folder where you want to change the default view.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is launched.

3 Inthe Allowed Views section, select the view whose ook best presents your folder list or
workspace.
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4 Click Apply.

The folder view has now been added to the Default View section, and can be chosen as the
default view, as described in “ Selecting a New Default Folder View” on page 26.

Selecting a New Default Folder View
1 Inthe Configure Default Settings page, in the Default View section, select the folder view that
you enabled in “Enabling Views to Be Used as the Default View” on page 25.
2 Click Apply > Close.

3.1.2 Enabling Alternate Folder Views

Because only folder owners have rights to set the default view of afolder, Vibe enables folder
ownersto select alternate views that external users of the folder are allowed to use, if they are not
satisfied with the default view, or fedl more comfortable using another view.
1 Navigate to the folder where you want to enable alternate views.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Allowed Views section, select all of the views that you want to enable as alternate folder
views.

4 Click Apply > Close.

Users can now view the folder in an aternate view.

1 Click Folder > Folder Optionsin the Action toolbar.
The Folder Options dialog box is displayed.
2 Inthe View Options section, select the desired aternate view, then click OK.

3.2 Working with Folder Entry Types

+ Section 3.2.1, “Enabling Alternate Folder Entry Types,” on page 26
* Section 3.2.2, “ Changing the Definitions for Existing Folders and Folder Entries,” on page 27

3.2.1 Enabling Alternate Folder Entry Types

You can select the types of entries that you want to allow usersto create in a certain folder. You can
configure your folder to allow alternate entry types, or you can change the current default entry type.
If you enable multiple entry types, users who submit entries into this folder can choose which type
of entry they want to add, such as atask entry, calendar entry, and so forth.
1 Navigate to the folder where you want to enable alternate entry types.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Default Entry Types section, select the entry types that you want to allow usersto create
in the folder.

4 Click Apply > Close.
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If you enable additional entry types, users who submit entries into this folder can click New in the
Folder Entry toolbar, then use the drop-down list to choose the type of entry they want to add,
depending on which types of entries you enabled on the folder.

Site administrators and folder owners can use the Form and View Designers functionality to create
new entry types (custom forms), which then appear in thislist. (When folder owners create new
entry types, those entry types are listed in the Local Definitions section of thislist.)

For more information on how to create custom entry types, see Chapter 9, “ Designing Custom
Folder Entry Forms,” on page 97.

3.2.2 Changing the Definitions for Existing Folders and Folder
Entries

You can simultaneously change the definitions for folders and folder entries that have already been
created. You can change all sub-folders to match the parent folder, and you can change all entries
within agiven folder to be of a specific entry type.

This feature must first be enabled by your Kablink Vibe administrator. If it is not enabled, it is not
visible. For information on how to enable thisfeature, see“Enabling Folder Administratorsto Apply
Definition Settings to Sub-Folders and Entries’ in the Kablink Vibe OnPrem 3.1 Administration
Guide.

+ “Applying Definition Settings to All Sub-Folders’ on page 27

+ “Applying Definition Settings to Existing Entries’ on page 27

Applying Definition Settings to All Sub-Folders

You can apply the folder definition settings of a parent folder to all sub-folders. For example, if you
have a Discussions folder that contains sub-folders, but not all of the sub-folders are Discussions
folders, you can simultaneously convert all the sub-folders to be displayed as Discussions folders.

1 Navigate to the folder where you want to apply entry definition types to folders or entries that
have aready been created.

2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Recursively apply section, select Change contained foldersto inherit this folder’s
definitions.

4 Click Apply > Close.

All definition settings on the Configure Default Settings page are applied to all sub-folders.

Applying Definition Settings to Existing Entries

You can convert al the entries that are contained within a specific folder to be of asingle entry type.
For example, auser might begin a discussion entry in a Discussion folder, then move the entry to the
Tasks folder after it is decided that something needs to be done in order to resolve the discussion.
After the discussion entry is added to the Tasks folder, the entry can be converted to atask entry.
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IMPORTANT: Changing entry definition settings as described in this section changes al entries
within the folder and all sub-folders to be the same entry type. You should not perform the stepsin
this section if you want your folder and sub-folders to contain multiple types of folder entries, as
described in Section 3.2.1, “Enabling Alternate Folder Entry Types,” on page 26.

To make all folder entries the same within a specific folder:
1 Navigate to the folder where you want to apply entry definition types to folders or entries that
have already been created.
2 Click Folder > Configure in the action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Recursively apply section, select Change contained foldersto inherit thisfolder’s
definitions, then select Change contained entries to be of the following entry type.

4 Inthedrop-down list, select the entry type that you want to apply to all existing entriesin the
folder.

To add entry types to this drop-down list, select the entry typesin the Default Entry Types
section, then click Apply.

5 Click Apply > Close.

3.3 Enabling Folders to Receive Entries through
E-Mail

Kablink Vibe enables you to e-mail entriesinto folders. Thisisuseful if you don’t have accessto the
Vibe site and still want to create an entry. You can also send text messages into folders, so, you can

till capture thoughts and contribute to conversations when you don’t have access to a computer or
the Internet.

To enable folders to receive entries via e-mail, complete the following sections:

+ Section 3.3.1, “Enabling and Configuring the Inbound E-Mail Server,” on page 28
¢ Section 3.3.2, “Enabling Incoming E-Mail for the Vibe Site,” on page 28

* Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 29

+ Section 3.3.4, “Defining Who Has Accessto E-Mail Entries,” on page 29

3.3.1 Enabling and Configuring the Inbound E-Mail Server

The Vibe administrator should have enabled and configured the inbound e-mail server during the
Vibe installation, as described in “Enabling Inbound E-Mail” in the Kablink Vibe OnPrem 3.1
Installation Guide.

For information about enabling and configuring inbound e-mail after the Vibe installation, see
“Reconfiguring the Vibe Site” in the Kablink Vibe OnPrem 3.1 Administration Guide.

3.3.2 Enabling Incoming E-Mail for the Vibe Site

For foldersto be able to receive entries via e-mail, Vibe administrators need to enable the Vibe site
to allow incoming e-mail.
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For information on how to enable Vibe to allow incoming e-mail, see “ Disabling/Enabling Inbound
E-Mail Postings’ in the Kablink Vibe OnPrem 3.1 Administration Guide.

3.3.3 Enabling E-Mail Posting with a Simple URL

When you define asimple URL for afolder, Vibe creates a URL that enables you to quickly
navigate to the folder, and also creates a corresponding e-mail address that users of the folder can e-
mail to.

1 Navigate to the folder where you want to define the URL.

2 Click Folder > Configure in the Action toolbar.

3 Inthe Definea simple URL for thisfolder or workspace section, specify the URL that you want
to useto reference the folder in the Define URL field.

4 Click Add.
5 Select Allow e-mail poststo this folder via the following addresses.
6 Click Apply, then click Close.
You can now make entries to the folder by e-mail or by text-messaging your entry to the e-mail

address that you created, as described in “Adding Entries to a Folder ViaE-Mail” in the Kablink
Vibe OnPrem 3.1 User Guide.

3.3.4 Defining Who Has Access to E-Mail Entries

By default, only users with rights to create entriesin a particular folder can e-mail entries into that
folder.

Vibe enables you to view who hasrightsto create entriesin afolder, grant rights to other Vibe users,
or configure the folder to allow all usersto create entries by e-mailing into it.

+ “Viewing Who Has Rights’ on page 29
+ “Granting Rights to Other Vibe Users’ on page 29
* “Setting Up aFolder That All Users Can Send E-Mail To” on page 30

Viewing Who Has Rights

1 Navigate to the folder where you want to view who currently has rights to create entries in the
folder.
2 Click View > Who Has Access in the Action toolbar.

3 Inthe provided table, the Create Entries section lists all of the users who have rights to create
entriesin the folder.

These are the users who have rights to e-mail entriesinto the folder.
Granting Rights to Other Vibe Users
You can grant other Vibe usersrightsto create entriesin afolder.

For information on how to do this, see Section 4.2, “Managing Access Control for Users and
Groups,” on page 39.
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Setting Up a Folder That All Users Can Send E-Mail To

You can enable your Vibe folder to receive e-mail entries from al users, regardless of whether they
have access to create entriesin the folder or not.

This enables e-mail entries to be submitted by anybody, inside or outside of the Vibe system. If you
are worried about receiving spam messages in your folder, do not set up your folder to accept e-mail
entries in the way described in this section.

1 Navigate to the folder where you want to enable all users to create entries via e-mail.
Click Folder > Access Contral in the Action toolbar.
Ensure that No is selected in the Inherit Role Member ship section, then click Apply.
Inthetable, click Add a User.
In the provided field, use the type-to-find functionality and specify E-mail Posting Agent.
In the E-mail Posting Agent row, select the check box in the Participant column.

N O o WN

Click Save Changes > Close.

Now al users can create entriesin this folder via e-mail, using the e-mail address that you
created in Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 29.

3.4 Setting Up a Folder or External E-Mail
Address to Receive All Sent E-Mail Messages

Like a persona e-mail Outbox for the Vibe site, you can configure afolder or any e-mail address to
receive all e-mail messages that you personally send from the Vibe site. This can help you better
track your activity.

Vibe administrators might need to enable this functionality, as described in “Enabling Users to
Configure a Folder or External E-Mail Address to Receive Sent E-Mails” in “Managing E-Mail
Configuration” in the Kablink Vibe OnPrem 3.1 Administration Guide.

Actions that cause e-mail messages to be sent from the Vibe site and to be saved in the Vibe folder
that you designate are:

+ Using the E-Mail Team and E-Mail Contributors options, as described in “Informing Others
about a Folder or Workspace” in the Kablink Vibe OnPrem 3.1 User Guide.

+ Using the Share this Entry option, as described in “ Sharing an Entry” in the Kablink Vibe
OnPrem 3.1 User Guide.

+ Using the Send E-Mail When Entry is Submitted option, as described in the * Sending an E-Mail
about an Entry” in the Kablink Vibe OnPrem 3.1 User Guide.

+ Filling in the Announcement field when creating or editing a team workspace, as described in
“Creating a New Workspace” and “ Sending E-Mail to Team Members and Announcing the
Workspace after Its Creation” in the in the Kablink Vibe OnPrem 3.1 User Guide.

NOTE: Certain types of e-mail messages that do not require you to personally add text, such as
setting digest notifications or workflow notifications, are not saved to the folder that you designate.
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To set up afolder or external e-mail address to receive all e-mail messages that you send from the
Vibe site:
1 Create anew folder in the workspace where you want the folder to reside.

For information on how to create afolder, see” Creating a New Folder” in the Kablink Vibe
OnPrem 3.1 User Guide.

2 Defineasimple URL for the folder, and allow e-mails to be sent to the folder.

For information on how to define a URL for afolder and allow e-mailing into it, see
Section 3.3.3, “Enabling E-Mail Posting with a Simple URL,” on page 29.

3 Navigate to your user profile page by clicking My Workspace > Prdfile.
The Profile pageis displayed.
4 Click Edit.

5 Inthe BCC Email Addressfield, specify the e-mail address of the folder or external e-mail
address.

If the BCC Email Address field does not exist, contact your Vibe administrator.

The folder e-mail address was created when you defined a simple URL for the folder and
alowed e-mail posting into the folder, as described in Step 2. It is displayed on the Configure
Default Settings page.

6 Click OK.

3.5 Configuring Folders to Send E-Mail
Notifications to Other Users

Asafolder owner, you can configure Kablink Vibe to send other users e-mail natifications, in order
to inform them of any activity in the folder and any sub-folders of the folder. However, auser’s
individual settings override or cancel notifications established by folder owners.

You cannot directly configure a sub-folder to send e-mail notifications; instead, you must configure
the parent folder.
1 Navigate to the folder from where you want to send the e-mail notifications.
2 Click Folder > E-Mail Settingsin the Action toolbar.
The E-Mail Settings page is displayed.
3 Inthe Select the Type of E-Mail Notification section, select the type of e-mail notification that
you want to send.

+ Digest: Vibe sends one message that summarizes all of the activity in the folder and its
sub-folders (available for folders only). Vibe sends digest notifications at a schedule
established by your site administrator.

As afolder owner, you can set your own schedule for digest naotifications. For more
information, see Step 5.

+ Individual Messages (with Attachments): Vibe sends one message for every new or
changed entry, and messages include attached files. Vibe sends all types of individual
notifications every five minutes.

+ Individual M essages without Attachments: Vibe sends one message for every new or
changed entry. The e-mail messages do not include files that might be attached to the new
or changed entries. Vibe sends all types of individual notifications every five minutes.
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+ Message Suitable for Text Messaging: Vibe sends a message suitable for viewing as a
text message. The content of the message includes only the entry title and alink to the new
or changed entry. Vibe sends all types of individual notifications every five minutes.

4 Specify the users who you want to receive the e-mail notifications.

You can specify specific e-mail addresses, users, groups, or send the notificationsto all team
members.

5 (Optional) Click Set a Different Schedule for This Folder if you want to set adigest schedule
for the folder that is different from the digest schedule set by the site administrator.

6 Click Apply > Close.

3.6 Setting Up and Using WebDAV

WebDAV is astandard collaborative editing and file management protocol. Kablink Vibe supports
the use of WebDAV tools, and enables you to manage your Vibe files through WebDAV. Vibe
utilizes WebDAV when editing attached files, and you can also set up WebDAV to view documents
in aVibe folder.

If you are using WebDAV on Windows 7, you or your Vibe administrator must ensure that your
workstation meets all the necessary prerequisitesin order to support WebDAV, as described in
“Configuring Vibe to Support WebDAV on Windows 7” in the Kablink Vibe OnPrem 3.1
Administration Guide.

If you cannot use WebDAV as described in the following sections, consult your Vibe administrator.

+ Section 3.6.1, “Using WebDAV to Edit Individual Files,” on page 32
+ Section 3.6.2, “Using WebDAV on a Vibe Folder,” on page 33

3.6.1 Using WebDAV to Edit Individual Files

You can use either of the following methods to edit files through WebDAV:

+ “Editing aFile Directly from the Vibe Interface” on page 32
+ “Using the WebDAV URL to Open the Filein a Document Editor” on page 32

Editing a File Directly from the Vibe Interface

When you use the Edit-in-Place functionality to edit a Vibe file, as described in “Editing Files’ in
the Kablink Vibe OnPrem 3.1 User Guide, Vibe uses WebDAV to retrieve, lock, modify, and unlock
thefile. No special setup or configuration is needed in Vibe to use WebDAV in this way.

NOTE: Edit-in-Place functionality is not supported on Mac when you use Microsoft Office as your
document editor. To use Edit-in-Place functionality on Mac, you must use OpenOffice as your
document editor.

Using the WebDAYV URL to Open the File in a Document Editor

You can obtain the WebDAV URL for individual files within Vibe, as described in “ Obtaining the
WebDAV URL for aFile” in the Kablink Vibe OnPrem 3.1 User Guide.
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After you have obtained the WebDAV URL for the file, you can specify the URL in a document
editor such as Microsoft Office to open the file. Refer to the documentation for your specific
document editor for instructions on how to accomplish this.

3.6.2 Using WebDAYV on a Vibe Folder

When you use WebDAV on a Vibe folder, you can create a mapped drive to a Vibe folder, enabling
users to browse and navigate the Vibe folder in a WebDAYV interface. To manage your Vibe folders
through a WebDAYV interface, you must first configure the Vibe folder to support WebDAYV, then
create a mapped drive to the Vibe folder.

NOTE: Because of limitations with WebDAV on Mac, you cannot use WebDAV to view a Vibe
folder in a Mac environment.

* “Prereguisite for Windows XP and Windows Vista” on page 33

+ “Configuring a Folder to Support WebDAV” on page 33

+ “Viewing the Vibe Folder in Your Windows Environment” on page 34
+ “Viewing the Vibe Folder in Your Linux Environment” on page 34

Prerequisite for Windows XP and Windows Vista

When you use WebDAV on a Vibe folder on Windows XP or Windows Vista, you must first install
the Software Update for Web Folders (KB907306). For information on how to perform this
installation, see “ Software Update for Web Folders’ (http://www.microsoft.com/downloads/
details.aspx?familyid=17c36612-632e-4c04-9382-987622ed1d64& displaylang=en), and follow the
provided instructions.

Configuring a Folder to Support WebDAV

In most types of Vibe folders, Vibe allows you to add multiple files with the same nameto asingle
folder, if each fileis added as a separate entry. (Files folders, however, require each file to have a
unique name.)

When afolder is configured to support WebDAYV, Vibe requires that each file added to the folder
have a unique name. Thisis because when you view afolder through WebDAV, you see only the
files that are within the folder and not the entries that contain each file.

To configure afolder to support WebDAV by requiring that all files uploaded to the folder have a
unique name;

1 Navigate to the folder that you want to configure to support WebDAV.

2 Click Folder > Edit Folder in the Action toolbar.

3 Toward the bottom of the page, select Require that all files uploaded into this folder have a
unique name.

4 Click OK.

For information about what users experience when they try to add afile to a WebDAV-enabled
folder when the file has the same name as afile that has already been added to the folder, see
“Adding Filesto a Files Folder and Other WebDAV-Enabled Folders’ in the.
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Viewing the Vibe Folder in Your Windows Environment

After your Vibe folder has been configured to support WebDAV, as described in “ Configuring a
Folder to Support WebDAV” on page 33, you can view the Vibe folder in your Windows
environment in either of the following ways:

+ “Creating a Mapped Drive to the Vibe Folder” on page 34

+ “Adding aVibe Folder as a Network Place” on page 34

Creating a Mapped Drive to the Vibe Folder

If you are using Windows XP as your client operating system, creating a mapped drive to the Vibe
folder as described in this section does not work. Instead, add the Vibe folder as a network place, as
described in “ Adding a Vibe Folder as a Network Place” on page 34.

1 Navigate to the folder where you want to create the mapped drive.

2 Click thelink in the footer.

3 Inthe provided table, copy the WebDAV URL.

4 Map adriveto the folder.

You accomplish this by using the Map Network Drive feature for Windows.
5 Specify your Vibe credentials, then complete the setup process.

Adding a Vibe Folder as a Network Place

If you are using Windows Vista as your client operating system, adding a Vibe folder as a network
place as described in this section does not work. I nstead, create a mapped drive to the Vibe folder, as
described in “ Creating a Mapped Drive to the Vibe Folder” on page 34.

1 Navigate to the folder where you want to create the mapped drive.

2 Click thelink in the footer.

3 Inthe provided table, copy the WebDAV URL.

4 Add thefolder as a network place.

You accomplish this by using the My Network Places feature for Windows.

Viewing the Vibe Folder in Your Linux Environment

After your Vibe folder has been configured to support WebDAV, as described in “ Configuring a
Folder to Support WebDAV” on page 33, you can view the Vibe folder in your Linux environment.
1 Navigate to the folder where you want to create the mapped drive.
2 Click thelink in the footer.
3 Inthe provided table, copy the WebDAV URL.
4 Use either Nautilus or Konqueror to access the Vibe folder.

For specific information on how to use Nautilus or Kongueror, consult your Linux
documentation.

5 Specify your Vibe credentials, then complete the setup process.
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3.7 Viewing Vibe Folders as RSS or Atom Feeds

RSS and Atom are Web formats used to publish frequently updated content such as blog entries,
news headlines, or podcasts. RSS and Atom documents, which are often called feeds, contain either
asummary or full content from an associated Web site. RSS and Atom make it possible for peopleto
keep up with their favorite Web sites in an automated manner that's easier than checking the sites
manually. RSS and Atom enable you to set up feeds to Kablink Vibe folders and view those feedsin
one convenient location.

You can set up a Vibe folder to be accessed by an RSS or Atom reader. When you do this, the Vibe
folder sends new or modified folder entriesto your RSS or Atom reader. Thisis an easy way to stay
informed on activity in a certain folder.

To set up a Vibe folder as an RSS or Atom feed:

1 Navigate to the folder that you want to set up as an RSS or Atom feed.
2 Click the Footer toolbar, located at the bottom of the folder page.

3 If you are setting up an RSS feed, select and copy the RSS URL in the RSSURL section in the
provided table.

or

If you are setting up an Atom feed, select and copy the Atom URL inthe ATOM URL sectionin
the provided table.

4 Inyour RSSreader or Atom reader, create a new RSS or Atom feed, and paste the RSS URL or
the Atom URL that you copied in Step 3.

The folder is now set up as an RSS or Atom feed, and entries that are created in the folder
appear in your RSS or Atom reader.

For information on using your Novell GroupWise client as an RSS reader, see “RSS Feeds’ in the
GroupWse 8 Windows Client User GuideGroupWse 8 Windows Client Help. Or, see “RSS Feeds’
in the GroupWse 8 Linux/Mac Client User GuideGroupWse 8 Linux Client HelpGroupWse 8 Mac
Client Help.

3.8 Applying Landing Page Elements to a Folder

Landing pages and landing page elements can enhance the presentation and utility of your Kablink
Vibe folders. You can set up alanding page on your folder, or you can simply apply some key
landing page elements to the folder, such as hiding the Vibe masthead, the Navigation panel, and so
forth.

+ Section 3.8.1, “Displaying a Landing Page on a Folder,” on page 35
+ Section 3.8.2, “Applying Specific Landing Page Elements to a Folder,” on page 36

3.8.1 Displaying a Landing Page on a Folder

Just as landing pages can enhance the presentation and utility of your Vibe workspaces, they can
also enhance your Vibe folders.

For information on how you can create alanding page for afolder, see Section 6.12, “Creating a
Landing Page for a Folder,” on page 76.
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3.8.2 Applying Specific Landing Page Elements to a Folder

You can leverage certain landing page elementsin your Vibe folder without implementing an actua
landing page.

For example, you might want to hide the Navigation panel from your folder in order to create more
viewing room for users who view the folder.

You can apply the following landing page elements to a folder, without implementing an actual
landing page:

+ Hidethe Vibe Masthead

+ Hide the Navigation panel

+ Hide the Footer toolbar
To make these modifications to your folder without implementing an actual landing page, you need
to add the Landing Page element to your folder Form definition. For information on how to add the

Landing Page element to your folder Form definition, see Chapter 8, “ Creating Custom Folder
Views,” on page 87.
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Controlling Access

If you are aKablink Vibe OnPrem site administrator or aworkspace and folder owner, it is your
responsibility to keep your content safe and your content consumers happy, by making sure they
have accessto the files and folders they depend on. Access control in Vibe is how you accomplish
this.

Workspace and folder owners are responsible for controlling user access in their workspaces or
folders. Site administrators are responsible for controlling user access across the entire site.

+ Section 4.1, “Understanding Access Control,” on page 37

+ Section 4.2, “Managing Access Control for Users and Groups,” on page 39

+ Section 4.3, “Managing Access Control for Remote Applications,” on page 46

4.1 Understanding Access Control

Access control is how you specify which users have the right to perform which tasks in which
places.

Kablink Vibe uses role-based access control. By default, there are seven roles, and each role
contains specific rights. If you want a particular user to have certain rights, you can assign that user
to the appropriate role.

For example, a user who has been assigned to the Participant role in aworkspace or folder can add
comments or replies, create entries, delete his or her own entries, modify his or her own entries, and
read entries in that folder or workspace.

The following sections help you better understand how access control worksin Vibe.

+ Section 4.1.1, “Default Access Control Behavior in Workspaces,” on page 37
+ Section 4.1.2, “Default User Rights,” on page 38

+ Section 4.1.3, “Default Roles,” on page 38

+ Section 4.1.4, “Default Users and Groups,” on page 39

4.1.1 Default Access Control Behavior in Workspaces

By default, most places inherit the access settings of their parent. When you establish settings for a
primary space, al sub-places automatically apply the same settings, saving administration time.
However, unlike other types of workspaces, Team workspaces do not retain the access control
settings of higher-level (parent) workspaces by default.

You can change the access control settings of alower-level workspace and folder to be different
from its parent workspace or folder. For information on how to do this, see Section 4.2, “Managing
Access Control for Users and Groups,” on page 39.
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4.1.2 Default User Rights

By default, al Vibe users have rights to perform the following actions:

+ Participate in any team workspaces in which they are a member (create folders and entries,
make comments, etc.)

+ Create team workspaces (by default, only members of ateam can view and participate in team
workspaces)

+ Visit al personal workspaces (read entries and comment on them)
+ Participate in al globa workspaces and folders

4.1.3 Default Roles

Vibe includes default roles that you can assign to users and groups. The default roles for workspaces
and folders are described in “ Understanding Default Roles for Workspaces and Folders’ on page 38,
and the default roles for entries are described in “ Understanding Default Roles for Entries’” on

page 39. These sections describe the function of each default role, but do not describe al of the
rights associated with each role. For acomplete list of rights, click the name of the role in the table
on the Configure Access Control page. (In the Action toolbar, click Workspace > Access Control or
Folder > Access Control.)

For acomplete list of roles that site administrators can add, see “ Controlling User Access
throughout the Vibe Site” in the Kablink Vibe OnPrem 3.1 Administration Guide. For a detailed
description of each right that can be associated with a given role, see “Understanding the Various
Rights for Roles” in the Kablink Vibe OnPrem 3.1 Administration Guide.

Vibe enables site administrators to create their own custom roles, as described in “ Defining a New
Role” in the Kablink Vibe OnPrem 3.1 Administration Guide. If you have aneed for a custom role,
consult your Vibe administrator.

By default, you can assign users to various roles in workspaces and folders, aswell asin entries.

+ “Understanding Default Roles for Workspaces and Folders’ on page 38
+ “Understanding Default Rolesfor Entries’ on page 39

Understanding Default Roles for Workspaces and Folders

Role Description
Visitor Has read-only and comment-only access.
Participant Can create entries and modify those entries, plus perform tasks associated

with the Visitor role.
Guest Participant Can read entries, create entries, and add comments.

Team Member Has all the rights of a Participant. In addition, can generate reports and
manage global tags.

Workspace and Folder  Can create, modify, or delete workspaces or folders; moderate participation

Administrator (modify or delete the entries of others); design entries and workflows; set
entry-level access controls on entries of others; and can perform tasks
associated with the Participant and Team Member role.
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Role Description

Workspace Creator Can create sub-workspaces. In Team Workspace Root workspaces, this role
allows users to create their own team workspaces.

Site Administrator Has all rights associated with access control. Available only to Vibe
administrators.

Understanding Default Roles for Entries

Role Description

Read Can read the entry.

Read and Reply Can read the entry and add comments or replies to the entry.

Write Can read the entry, add comments or replies, and modify the entry.

Delete Can read the entry, add comments or replies, modify, and delete the entry.
Change Access Can read the entry, add comments or replies, modify, and delete the entry.
Controls Can also modify the access control settings of the entry.

4.1.4 Default Users and Groups

Asyou create users and groups in your Vibe site, you can assign default or custom access control
roles to them. In addition to the users and groups that you create, Vibe includes four default users
and groups to which you can assign roles. For information on how to do this, see Section 4.2,
“Managing Access Control for Users and Groups,” on page 39.

Default User and Group Description

Owner of a Workspace or The person who created the workspace, or the person assigned to be the
Folder owner of the workspace.

Team Members The individuals who are designated as team members in a given place.

For information about how to add team members, see “Adding Additional
Team Members to Your Workspace” in the Kablink Vibe OnPrem 3.1 User

Guide.
All Users Every person registered within the Vibe site.
Site Administrator The person who has rights to perform any task in any workspace or folder.

Available only to Vibe administrators.

4.2 Managing Access Control for Users and
Groups

When you have appropriate rights, you can control which users have access to workspaces, folders,
and entries. Furthermore, you can regulate what actions they are allowed to perform. For example,

you can allow a specific team to view aworkspace, but only allow certain members of that team to
create entries in the workspace.
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You can control access to workspaces, folders, and entries.

+ Section 4.2.1, “Controlling Access to Workspaces and Folders,” on page 40
+ Section 4.2.2, “Controlling Access to Entries,” on page 44

4.2.1 Controlling Access to Workspaces and Folders

+ “Accessing the Configure Access Control Page” on page 40

+ “Activating the Table” on page 41

+ “Adding Roles to the Access Control Table” on page 42

+ “Adding Usersto the Access Control Table” on page 42

+ “Adding Groups to the Access Control Table” on page 43

+ “Assigning Rolesto Users and Groups’ on page 43

+ “Adjusting Access Controlsin Another Place” on page 43

+ “Creating Access Controls for Remote Applications’ on page 44

Accessing the Configure Access Control Page

Kablink Vibe provides atable on the Configure Access Control page that enables you to make all of
your needed access control modifications. You must use this table to perform any access control
modificationsin Vibe.

1 Navigate to the workspace or folder where you want to modify user access rights.

2 Click Workspace > Access Control in the Action toolbar if you want to change the access
control settings for aworkspace.

or

Click Folder > Access Control in the Action toolbar if you want to change the access control
settings for afolder.
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The Configure Access Control page is displayed.

Configure Access Control

Configure Access Cclntrnlo
Current Workspace: Marketing
Workspace Owner: Anita Olivos (solivos) [edit]
[F-Home Workspace / [-TeamWorkspaces 4 [-Marketing

This folder inherits its access control settings from its parent.

Inherit role membership from the parent folder or workspace?

@ yes @ no
Roles
Creator Team Member and Folder
Owner of Workspace or Folder
Team Members
Groups Group Title Group Name Creator F Team Member and Folder
All Users allusers
Users User Title User Id space Creator F Team Member and Folder
—No Users—
Application Groups  Application Group Title ion Group Name Creator F Team Member and Folder
—no application groups—
Applications ication Title Hame Creator F Team Member and Folder

—no applications—

[Mote: admin (admin) has been designated as the default site administrator with privileges to perforrm any task on any workspace or folder]

Activating the Table

Before you can make modifications to the table on the Configure Access Control page, you need to
ensure that the folder or workspace does not inherit its access control settings from its parent folder

or workspace:

1 Inthe Folder Inheritance section, select no, then click Apply.

This folder inherits its access control settings from its parent.

Inherit rale membership from the parent folder or workspace?

D yes @ po P

You can now make modifications to the table.
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v designates the access control selting of the parent workspace

Add User Hames from Clipboard

Add a Role =
Workspace Creator Participant Team Member Workspace and Folder Administrator
owner of Workspace or Folder = = = v
Team Members =1 =1 v =
Add a Group = Group Title Group Hame Workspace Creator  Participant Team Member Workspace and Folder Administrator
All Users allUsers v v = =
Add a User = User Title User Id Workspace Creator  Participant Team Member Workspace and Folder Administrator
—No Users—
Add an Application Group = Application Group Title  Application Group Name Workspace Creator Participant Team Member Workspace and Folder Administrator
—no application groups—
Add an Application = Application Title Application Name Workspace Creator Participant Team Member Workspace and Folder Administrator

—no applications—

[Note: admin (admin) has been designated as the default site administrator with privileges to perform any task on any workspace or folder ]

Adding Roles to the Access Control Table
1 Click the Add a Rolelink at the top of the table.

2 From the drop-down list, select the role that you want to add.

Vibe adds a new column to the table for the new role.

3 Assign the appropriate user or group to this role by selecting the check box in the user’s or
group’s row, as described in “ Assigning Roles to Users and Groups’ on page 43.

For information on how to add a new user to the access control table, see “Adding Usersto the

Access Control Table” on page 42.

For information on how to add a new group to the access control table, see “Adding Groupsto

the Access Control Table” on page 43.
4 Click Save Changes.

Adding Users to the Access Control Table

You can individually add users to the Access Control table, or you can add them by using the Vibe

clipboard.

+ “Adding Individual Users’ on page 42
+ “Adding Usersfrom the Clipboard” on page 43

Adding Individual Users

1 Click the Add a User link in the left column of the table.

2 Inthe Add a User field, begin typing the name of the user that you want to add, then select that

user from the provided list.
Vibe adds a new row to the table for the new user.
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3 Assign the user to the appropriate role by selecting the check box in the column of the user’s
row, as described in “ Assigning Roles to Users and Groups’ on page 43.

4 Click Save Changes.

Adding Users from the Clipboard

1 Inthe upper left corner of the Access Control table, click Add User Names from Clipboard.
All of the users who are currently on your clipboard are added to the Access Control table.

For more information on how to use the Vibe clipboard, see “Using the Vibe Clipboard” in the
Kablink Vibe OnPrem 3.1 User Guide.

2 Assign the usersto the appropriate role by selecting the check box in the column of each user’s
row, as described in “ Assigning Roles to Users and Groups’ on page 43.

3 Click Save Changes.

Adding Groups to the Access Control Table

1 Click the Add a Group link in the left column of the table.

2 Inthe Add a Group field, begin typing the name of the group that you want to add, then select
that group from the provided list.

Vibe adds anew row to the table for the new group.

3 Assign the group to the appropriate role by selecting the check box in the column of the group’s
row, as described in “ Assigning Roles to Users and Groups” on page 43.

4 Click Save Changes.

Assigning Roles to Users and Groups

A roleisaset of privileges. When you assign a user or group to arole, that user or group
automatically has all the rights associated with that role.

1 Ensurethat the user or group and the role that you want to associate with the user or group are
visible in the Access Control table.

For information on how to add arole or a user or group to the table, see “Adding Rolesto the
Access Control Table” on page 42, “ Adding Users to the Access Control Table” on page 42,
and “Adding Groups to the Access Control Table” on page 43.

2 Intherow of the user or group, select the check box that is located in the role column that you
want to assign to the user or group.

3 Click Save Changes.
If you want to unassign arole:

1 Deselect the appropriate check box, then click Save Changes.

Adjusting Access Controls in Another Place

Vibe enables you to adjust the access control settings of any workspace or folder, directly from the
Configure Access Control page.

1 Inthe workspace tree at the top of the Configure Access Control page, navigate to the place
where you want to adjust the access controls.
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2 Click thelinked title of the place where you want to adjust the access controls.
Vibe displays the Configure Access Control page for the page that you specified.

Creating Access Controls for Remote Applications

Because not all remote applications can be completely trusted, it is often a good ideato limit the
privileges of the remote application.

For information on how to do this by using access controls, see Section 12.4, “Managing Access
Controls for Remote Applications,” on page 155.

4.2.2 Controlling Access to Entries

Vibe enables you to set access controls for an entry that differ from the access controls of the parent
folder. You might want to do thisif you have granted a group of users access to afolder, but only
want asubset of that group to have access to see certain entries within the folder. Or, you might want
to set access controls on a particular entry to make that entry visible to users who don’t have access
to the folder where the entry resides, as described in “Exposing a Vibe Entry to a Wider Audience
Than the Folder Access Controls Allow” on page 46.

Before you can modify access controlsfor an entry, you need to ensure that the entry does not inherit
its access control settings from the parent folder:

To set access controls on an entry:

1 Navigate to the entry where you want to modify user access rights.
2 Click Actions > Access Control in the Entry toolbar.
The Configure Access Control page is displayed.

Configure Access Control

o

Current Entry:  Complete Product Analysis for Product X
Entry Owner.  Julio Chavez (jchavez)

This entry uses the parent folder access controls. [View who has access to the folder...]

@ Use the parent folder access controls
@ Specify the access controls for this entry

3 To set access controls that differ from the access controls of the parent folder, select Specify the
access controls for this entry, then click Apply.
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Configure Access Control

(7]

Current Entry.  Complete Product Analysis for Product X
Entry Owner:  Julio Chavez (jchavez)

This entry uses entry specific access controls.

(0 Use the parent folder access controls
@ Specify the access controls for this entry

Add User Mames from Clipboard

Read Read and Reply Wirite: Delete Change Access Controls
Owner of Entry & & & & Il
Team Members ] ] | ] ]
Add a Group ¥ GroupTitle  Group Name Read Read and Reply Write Delete  Change Access Controls
N0 groups—
Add a User ¥ User Title User Id Read  Read and Reply  Write Delete  Change Access Controls

—Nousers—

[¥] Include the Folder Access Controls [View who has access to the folder.. ]

[Note: admin (admin) has been designated as the default site administrator with privileges to perform any task on any
workspace or folder ]

4 Usethe table to modify user access to the entry.
You can assign various roles to team members, groups, or individual users.

For information about the roles that you can assign, see “Understanding Default Roles for
Entries’ on page 39.

For information about how to add users and groups to the access control table, see “Adding
Usersto the Access Control Table” on page 42 and “Adding Groups to the Access Control
Table” on page 43.

5 (Optional) Select Include the Folder Access Controlsif you want to extend the new entry-level
access controls to include the access controls that are already in place for the folder. Selecting
this option automatically grants users with the same access rights to the entry that they haveto
the folder.

Deselect Include the Folder Access Controlsif you want the new entry-level access controlsto
override the folder-level access controls. If you deselect this option, you must use the entry-
level access controls to specify each user or group that you want to have access to the entry.
Users who have access to the folder that contains the entry but have not been granted access
rights to the entry itself do not have access to the entry.

6 Click Save Changes > Close.
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Exposing a Vibe Entry to a Wider Audience Than the Folder Access Controls Allow

You can expose a Vibe entry to make it visible to awider audience than the folder where the entry
resides. For example, if your folder isvisible only to team members, the default access controls
allow only team membersto see all entriesthat are created in the folder. However, by deselecting
Include the Folder Access Controls, you can enable awider audience to view a specific entry. You
might want to do thisif the majority of content in afolder is sensitive and should be restricted to a
limited audience, but you want to expose a specific entry to alarger audience.

For example, suppose that you are amember of afinance team that is responsible for the accounting
of your company’s quarterly earnings. All the information in your team’s workspace is confidential.
However, when it istime to announce the company’s quarterly earnings, you create a Vibe entry that
contains the earning results, and you modify the access controls of this specific entry to make the
entry visible to all company employees.

To expose a Vibe entry to awider audience than is currently allowed in the folder:

1 Modify the entry access controls as described in Section 4.2.2, “ Controlling Accessto Entries,”
on page 44.

Ensure that you deselect Include the Folder Access Controls, as described in Step 5 of this
section.

NOTE: When you expose a Vibe entry to awider audience than is currently allowed in the folder,
users must perform a search in order to locate the entry, or they must have the entry shared with
them. Users cannot locate the entry by navigating the Workspace tree as described in *“ Navigating
the Workspace Tree” in the Kablink Vibe OnPrem 3.1 User Guide.

4.3 Managing Access Control for Remote
Applications

Because not all remote applications can be completely trusted, it is often a good ideato limit the
privileges of the remote application.

For information on how to do this by using access controls, see Section 12.4, “Managing Access
Controls for Remote Applications,” on page 155.
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Branding a Folder or Workspace

Branding a folder or workspace is a good way to make the folder or workspace more unique and
identifiable. When you brand a folder or workspace, the brand is applied to all sub-workspaces and
sub-folders. However, folder and workspace ownersin lower-level folders and workspaces can
override the higher-level brand settings by adding aworkspace brand of their own. For example, the
Global Workspaces folder can be branded with the company logo and slogan, while ateam
workspace at alower level in the workspace tree can be branded with alogo for the product that the
team is responsible for. Members of that team can then override the team brand by branding
individual folders within the team workspace that they are responsible for.

Kablink Vibe OnPrem administrators can disable this functionality when they create a site-wide
brand, as discussed in “ Creating a Site-Wide Brand” in the Kablink Vibe OnPrem 3.1 Administration
Guide.

If you are unable to brand a folder or workspace as discussed in this section, contact your Vibe
administrator.

To brand afolder or workspace:

1 Navigate to the folder or workspace where you want to create the brand.
2 Click Workspace > Brand Workspace if you are branding a workspace.
or
Click Folder > Brand Folder if you are branding a folder.

The Workspace/Folder Branding dialog box is displayed.

) Use Branding Image: Novell Vibe |Z| B

@ Use Advanced Branding:  Advanced

Background Image: None lz‘ (=]
[T stretch image

Background Colar- (white, rgb(255,255,255), #Tfff)

Tent Color: (white, rgb(255.255,255), #ff)
Sample text

Clear branding

3 Specify the following information to create your desired brand:

Use Branding Image: Select this option if you want to use the drop-down list to select an
existing image, or click the Browseicon & | to browse to an image on your computer’sfile
system.

Use Advanced Branding: Select thisoption, then click Advanced if you want to create a brand
that includes advanced features, such as linking to another Vibe page or displaying a YouTube
video.
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You can add a YouTube video in your branding section by clicking the Video icon E|.

For more information about displaying YouTube videosin Vibe, see “Displaying YouTube
Videosin aFolder Entry” in the Kablink Vibe OnPrem 3.1 User Guide.

For more information about linking to another Vibe page, see “Linking to a Folder or Folder
Entry” in the Kablink Vibe OnPrem 3.1 User Guide.

If you add a URL to the advanced branding, the URL cannot contain the following parameter:
url created by teaming. If thisparameter does exist, delete it before saving your brand.

Background Image: Click the Browseicon & | to browse to an image on your computer’sfile
system. If you are branding ateam workspace, you can use the provided drop-down list to
select an image that is already attached to the workspace. (For information on how to attach an
image to ateam workspace, see “Modifying a Workspace” in the Kablink Vibe OnPrem 3.1
User Guide)

This background image is displayed behind your regular branding.
Sretch Image: Stretches the image to occupy the entire branding area.

If you stretch your background image, the image overrides any background color that you have
Set.

Background Color: Adds a background color that occupies the entire branding area. To
change the background color, click the color nameto the right of thisfield, select the new color,
then click OK.

If you added a background image and stretched the image, the background color is not
displayed.
Text Color: Changes the text color of the workspace name in the upper-right corner of the

branding area. To change the text color, click the color nameto the right of thisfield, select the
new color, then click OK.

Clear branding: Clearsal your current branding selections.
4 Click OK.
The folder or workspace now displays the brand that you created.
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Creating and Managing Landing
Pages

Landing pages in Kablink Vibe OnPrem can benefit your workspaces and folders in two key ways:

+ Improved Customization: Landing pages provide an excellent opportunity to put a custom,
personal face on workspaces and folders in your Vibe site, while still providing the team-
focused, collaborative functionality that Vibe affords.

+ Increased Retrievability: Landing pages increase the accessibility and visibility of the
information that is most critical to your team or organization. You can bring important entries
or entire folders to the forefront of workspaces, ensuring that users access the information they
need in aquick, efficient manner.
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For example, alanding page for acity’s public sector might look something like this:

Welcome to the City of Plattsburg

Employee Portal

Information

Jobs

006

Message from the Mayor

Iwish | could personally thank every one of you
forthe work you do! Our beautiful Gity has never
been as great of a place to live in all the years |
have lived here as itis right now. This is a direct
result of all the hard work you put into making
Plattsburg the best City to live in. Thank you!

Itis an exciting time to be living in the City of
Plattsburg. Our economy and population have
been growing at a steady rate over the last few
years and we expect it to continue. Crime rates
and accident rates have never been lower!
Businesses are thriving and housing prices are
steadily increasing. The future looks bright for
our City!

Sincerely,

Mayor Dan Johnson

Welcome to the Public Portal

We customized this 1anding page using the landing page editor to make it have a user-friendly look
and feel. Click on the links on the left and right navigation areas to find out how they could be utilized
in a real government public portal. Also, refer to the Public Portal portion of the walkthrough to find out
mare about this public portal. Once you are ready, click Infranet on the lefi fo continue this demo.

-Teaming Library

Flower Princess from Last Year's Spring

@ First Aid Certification
Neighborhood Walch Network

@ Zoning Approval
@ Small Business Licenses

0 Plattsburg Going Green

9 Report a Problem

First Aid Certification

We are offering a free first aid certification
course at our local fire stafion

Spring Festival

Help us bring in the Spring season by
participating in our Spring Festival. We will
have plenty of activities for kids and adults!

Clean the City Day

Please participate in our city-wide "Clean the
City Day" event. All you have to do is go
outside and do something to make our
beautiful City a litle more beautiful

+ Section 6.1, “Enabling the Landing Page View for a Workspace,” on page 51

+ Section 6.2, “ Setting Up Your Landing Page,” on page 52
+ Section 6.3, “Publishing Your Landing Page,” on page 67
+ Section 6.4, “Modifying the Contents of Your Landing Page,” on page 67

+ Section 6.5, “Reordering the Content of Your Landing Page,” on page 68

+ Section 6.6, “Deleting Content from Your Landing Page,” on page 68

+ Section 6.7, “Automatically Displaying the Newest Folder Entries on Your Landing Page,” on
page 69
+ Section 6.8, “Adding Accessoriesto Your Landing Page,” on page 71

+ Section 6.9, “Enabling Graphicsto Be Used on aLanding Page,” on page 73

+ Section 6.10, “Displaying YouTube Videos on a Landing Page,” on page 74

+ Section 6.11, “Creating a Landing Page for a Personal Workspace,” on page 75
+ Section 6.12, “Creating a Landing Page for a Folder,” on page 76

+ Section 6.13, “Downloading Existing Landing Pages,” on page 76
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6.1 Enabling the Landing Page View for a
Workspace

Before you can create the landing page, you need to enable the landing page view for the workspace.

Kablink Vibe includes a default workspace landing page view. The default landing page view
contains a Landing Page Layout section, a Description section, a Branding section, an | con section,
and an Attachments section.

Or, you can create a custom landing page view for a workspace that contains only the sections that
you choose. For information on how to create a custom landing page view for aworkspace, see
Chapter 7, “ Creating Custom Workspace Views,” on page 77.

You can enable the landing page view on an existing workspace, or when you are creating a
workspace.
+ Section 6.1.1, “Enabling the Landing Page View on an Existing Workspace,” on page 51

+ Section 6.1.2, “Enabling the Landing Page View on a Workspace You Are Creating,” on
page 51

6.1.1 Enabling the Landing Page View on an EXxisting
Workspace

1 Navigate to the workspace where you want to create the landing page.

You can create alanding page for a personal workspace only if your Vibe administrator has
enabled you to do so. For more information, see Section 6.11, “Creating a Landing Page for a
Personal Workspace,” on page 75.

2 Click Workspace > Configure in the Action toolbar.
The Configure Default Settings page is displayed

3 Inthe Default View section, select Landing Page.

4 Click Apply > Close.

What was previously displayed on the main page of the workspace is no longer displayed and
the main page of the workspace is blank.

5 Continue with Section 6.2, “ Setting Up Your Landing Page,” on page 52.

6.1.2 Enabling the Landing Page View on a Workspace You Are
Creating

1 Navigate to the workspace where you want to create the new workspace.
2 Click Workspace > New Workspace.
The New Workspace page is displayed.
3 IntheWorkspace Title field, specify atitle for the workspace.
4 Inthe Workspace section, select Landing Page.
5 Finish creating the workspace, then click OK.
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For more information on creating aworkspace, see “ Creating a New Workspace” in “ General
Workspace Management” in the Kablink Vibe OnPrem 3.1 User Guide.

6 Continue with Section 6.2, “ Setting Up Your Landing Page,” on page 52.

6.2 Setting Up Your Landing Page

After you enable alanding page as described in Section 6.1, “ Enabling the Landing Page View for a
Workspace,” on page 51, you need to set it up to display the desired layout options and content, as
described in the following sections:

+ Section 6.2.1, “Choosing Layout Options for Your Landing Page,” on page 52

+ Section 6.2.2, “Adding Content to Your Landing Page,” on page 53

+ Section 6.2.3, “Configuring Landing Page Elements,” on page 55

6.2.1 Choosing Layout Options for Your Landing Page

1 Navigate to the landing page that you created in Section 6.1, “ Enabling the Landing Page View
for aWorkspace,” on page 51.

2 Click Workspace > Edit Workspace in the Action tool bar.

or
If you are creating a landing page for afolder, click Folder > Edit Folder.

Title
Marketing
Landing Page Layout Landing Page Style
[T Hide the Masthead @ Light
[ Hide the Navigation Panel @ Dark

[T] Hide the Footer

Drag and drop any of the elements onto the workspace layout area to design the landing page. Hover over each element for a description.
. [] Table |

E List

—| Entry

[ Folder

3| Enhanced View

4. ¥ Graphic

3 Inthe Landing Page Layout section, below the workspace Title field, you can select from the
following options to modify the display of your landing page:

+ Hidethe Masthead: Select this option to hide the masthead (Navigation toolbar). This
hides everything above the Action toolbar.

+ Hidethe Navigation Panel: Select this option to hide the Navigation panel.
+ Hidethe Footer: Select this option to hide the Footer toolbar.

4 Inthe Landing Page Syle section you can select from the following options to modify the style
of your landing page:

+ Light: No background shading is displayed on landing page el ements.
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+ Dark: (Default) Displays adark background on each element to provide contrast between
the landing page elements.

5 Click OK to save the layout and style changes.

6.2.2 Adding Content to Your Landing Page

1 Navigate to the landing page that you created in Section 6.1, “ Enabling the Landing Page View
for a Workspace,” on page 51.

2 Click Workspace > Edit Workspace in the Action tool bar.

or
If you are creating a landing page for afolder, click Folder > Edit Folder.

Marketing
Title
Marketing
Landing Page Layout Landing Page Style
[T] Hide the Masthead © Light
[T Hide the Navigation Panel @ Dark

[T] Hide the Footer

Drag and drop any of the elements onto the workspace layout area to design the landing page. Hover over each element for a description.

I Fatder

|5 Enhanced view

§.,% Graphic

3 Inthe Landing Page Layout section, in the content editor, use the element palette to select the
landing page element that you want to display on your landing page.

[i] Table

E List

= Entry

Tl Folder

[&| Enhanced View
§.4 Graphic

D Link (URL)

o Link to FoldenWorspace
) Link to Entry
{5 Utility Element
Tl custom 5P
HTML

Embedded Web Page
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You can add the following elements:

*

Table: Creates atable with the number of columns that you specify. You can add other
elementsinside this table.

List: Creates alist where you can add other elements.

Entry: Enables you to reference an entry that has previously been created in Kablink
Vibe.

The actual content of your landing page is created in entries. The landing page simply
references entries that have already been created within Vibe.

When you add an entry to the landing page by using the Entry element, only the entry title
and description can be displayed. If you want to display entry comments, add the
Enhanced View element to the landing page.

Folder: Enables you to reference afolder that has previously been created in Vibe. You
can choose how many entries from the folder that you want to display on your landing
page at any onetime.

Enhanced View: Enables you to display entries and folders in enhanced ways. The
following options are available:

+ Display an entry: Displaysthe entry title, description, author, date, and the 10 most
recent comments.

+ Display afull entry: Displays the entry with the full entry view, which includes the
title, description, author, date, tabs (Comments, Attachments, Entry History, Tags),
ratings, and so forth.

+ Display recent entries: Displays the most recent entries from the specified folder.
Displaysthetitle, description, author, date, and the 10 most recent commentsfor each
entry.

+ Display alist of recent entries. Displaysalist of the most recent entries from the
specified folder. Displays thetitle, author, and date of the entry.

+ Display a sorted list of recent entries: Displaysalist in aphabetical order of the
most recent entries from the specified folder. Displays the title, author, and date of
the entry.

+ Display a sorted list of files: Displaysalist in aphabetical order of the files that
were most recently added to the folder. Thisincludesfilesthat are attached to entries.

+ Display calendar: Displays the specified calendar with the full calendar view.

+ Display task folder: Displays the specified task folder with information about each
task, such as thetitle, due date, priority, and so forth.

+ Display survey: Displaysthe specified survey in afull, interactive view. Users can
participate in the survey directly from the landing page.

Graphic: Enables you to reference a graphic that has previously been added to the
workspace.

Link (URL): Enablesyouto create alink to aWeb URL.
Link to Folder/Workspace: Enables you to add alink to a Vibe folder or workspace.
Link to Entry: Enablesyou to add alink to a Vibe entry.
Utility Element: Enables you to add various utilities, such as the My Workspace link.

Custom JSP: Enables you to reference acustom JSP file that has previously been created
by a Vibe administrator.
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+ HTML: Displaysan HTML editor where you can compose messages, create links, upload
pictures, and more. The information that you createin thisHTML editor is displayed on
your landing page.

+ Embedded Web Page: Enables you to reference any Web site and display it on your
landing page.

4 Dragthe element that you want to display on your landing page and drop it onto the landing
page canvas.

[ Table

E List

—! Entry []Table

rolger

5| Enhanced View

%.# Graphic

U3 Link {URL)

E‘] Link to FolderWorkspace
5 Link to Entry

{5 Utility Element

E Custom JSP

HTML

Embedded Web Page

After you drop the element onto the landing page canvas, you are prompted to configureit.
The way you configure alanding page element depends on the type of element that you add.

5 Configure the landing page element as described in Section 6.2.3, “ Configuring Landing Page
Elements,” on page 55.

6.2.3 Configuring Landing Page Elements

You need to configure the elements of your landing page when you are first creating them, as
described in Section 6.2.2, “Adding Content to Your Landing Page,” on page 53.

You can aso reconfigure the elements of your landing page at any time, as described in Section 6.4,
“Modifying the Contents of Your Landing Page,” on page 67.

After you have added and configured the elements of your landing page, you are ready to publish the
landing page. For information on how to do this, see Section 6.3, “Publishing Your Landing Page,”
on page 67.

+ “Adding aTable” on page 56

+ “Adding aList” on page 56

+ “Adding an Entry” on page 57

+ “Adding a Folder” on page 58

+ “Adding an Enhanced View Element” on page 59

+ “Adding a Graphic” on page 60

+ “AddingalLink (URL)” on page 61
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+ “Adding aLink to a Folder/Workspace”’ on page 61
+ “Adding aLink to an Entry” on page 62

+ “Adding a Utility Element” on page 63

+ “Adding a Custom JSP” on page 64

+ “Adding an HTML Editor” on page 66

+ “Adding an Embedded Web Page” on page 66

Adding a Table

To add atable to the landing page:

1 Inthe Landing Page Layout section, in the content editor, click Table in the element palette,
then drag it and drop the table into the desired area of the landing page canvas.

“Table Properties

[“] show barder

Number of columns: __
Column 1 width:

Column 2 width:

2 Set the following configuration options to finish setting up the table:
+ Show border: Select thisoption if you want the border of the table to be visible.

+ Number of columns: Specify the number of columnsthat you want thetable to have. You
can have up to five columns.

+ Column 1 width: Specify the width that you want the first column to have.
If your table has multiple columns, you can specify the width for each column.
3 Click OK.

After you add atable to alanding page, you can add content within the table.

1 Select an element from the element palette and drag and drop it into the location of the table
where you want to add the content.

Adding a List
To add alist to the landing page:

1 Inthe Landing Page Layout section, in the content editor, click List in the element pal ette, then
drag it and drop it into the desired area of the landing page canvas.
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List Properties

Title |

[Tl show border

2 Set the following configuration optionsto finish setting up the list:

+ Title: Specify atitlefor thelist.

+ Show border: Select this option if you want the border of the list to be visible.
3 Click OK.

After you add alist to alanding page, you can add content within the list.

1 Select an element from the element palette and drag and drop it into the location of the list
where you want to add the content.

Adding an Entry

The actual content of your landing page is created in entries. The landing page simply references
entries that have already been created within Vibe.

When you add an entry to the landing page by using the Entry element, only the entry title and
description can be displayed. If you want to display entry comments, add the Enhanced View
element to the landing page, as described in “ Adding an Enhanced View Element” on page 59.

To add an entry to the landing page:

1 Inthe Landing Page Layout section, in the content editor, click Entry in the element pal ette,
then drag it and drop it into the desired area of the landing page canvas.
2 Click Edit next to the Entry field.

Thisfield is populated only if you have already configured this element, as described in this
section. When you are reconfiguring the element the entry that is being referenced is shown
here.
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Entry Properties

Entry: Mo entry selected

() Search entire site
Find- @ search current folderworks pace

[T] show Title Bar

3 Set the following configuration options to finish setting up the entry:

+ Find: Select whether you want to search the entire site for the entry or only within the
current folder or workspace, then in the provided field specify the entry that you want to
display on the landing page.

Thisfield uses type-to-find functionality, so Vibe displays the available options as you
type. Click in the field and press the Spacebar to list al the available options.

+ Show Title Bar: Select thisoption if you want the title bar of the entry to be visible.
4 Click OK.

Adding a Folder
1 Inthe Landing Page Layout section, in the content editor, click Folder in the element palette,
then drag it and drop it into the desired area of the landing page canvas.
2 Click Edit next to the Folder field.

Thisfield is populated only if you have already configured this element, as described in this
section. After you have configured this element as described in this section, the folder that is
being referenced is shown here.

Folder Properties

Folder: Mo folder selected

(7) search entire site
Find- @ search current folderiworkspace

MNumber of entries to show: | 0

[Tl show Title Bar
[T show Folder Description
] show Entries opened
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3 Set the following configuration options to finish setting up the folder:

+ Find: Select whether you want to search the entire site for the folder or only within the
current folder or workspace, then in the provided field specify the folder that you want to
display on the landing page.

Thisfield uses type-to-find functionality, so Vibe displays the available options as you
type. Click in the field and press the Spacebar to list all the available options.

+ Number of entriesto show: Specify the number of folder entries that you want to be
displayed at any onetime.

+ Show Title Bar: Select thisoption if you want the folder title bar to be displayed.

+ Show Folder Description: Select thisoption if you want the folder description to be
displayed.
+ Show Entries Opened: Select this option if you want opened entries to be displayed.
4 Click OK.

Adding an Enhanced View Element

1 Inthe Landing Page Layout section, in the content editor, click Enhanced View in the element
palette, then drag it and drop it into the desired area of the landing page canvas.

'Enhanced View Properties

Enhanced View: E.Display an entry EE

Dizplay the selected entry. The entry's author, date and the 10 most
recent replies to the entry will be displayed.

Entry: Mo entry selected

2 Inthe Enhanced View drop-down list, select one of the available options.
For more information about each option, see Enhanced View.

3 Set the configuration options that apply to the enhanced view element that you are adding.
Depending on the option that you selected in Step 2, the following configuration options are
available:

+ Entry: Click Edit. Thisfield is populated only if you have already configured this
element, as described in this section. After you have configured this element as described
in this section, the folder that is being referenced is shown here.

+ Folder: Click Edit. Thisfield is populated only if you have already configured this
element, as described in this section. After you have configured this element as described
in this section, the folder that is being referenced is shown here.
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+ Find: Select whether you want to search the entire site for the folder or entry, or only
within the current folder or workspace, then in the provided field specify the folder or
entry that you want to display on the landing page.

+ Number of entriesto show: (Conditional) Specify the number of folder entries that you
want to be displayed at any onetime.

This option is displayed only when referencing afolder.

+ Width: (Conditional) Specify the width that you want the calendar to be displayed on the
landing page, either by percent or pixels.

This option is displayed only when displaying a calendar.

+ Height: (Conditional) Specify the height that you want the calendar to be displayed on the
landing page, either by percent or pixels.

This option is displayed only when displaying a calendar.
+ Show Title Bar: Select thisoption if you want the title bar to be displayed.

This option is not aways displayed, depending on what you select in the Enhanced View
drop-down list.

4 Click OK.

Adding a Graphic

Before you can add a graphic to your landing page, you need to attach the graphic to the landing
page, as described in Section 6.9, “Enabling Graphics to Be Used on a Landing Page,” on page 73.

1 Inthe Landing Page Layout section, in the content editor, click Graphic in the element palette,
then drag it and drop it into the desired area of the landing page canvas.

'Graphic Properties

Graphic:

[Tl show barder

[ o ] cancel ]

2 Set the following configuration options to finish setting up the graphic:
+ Graphic: Inthe Graphic drop-down list, select the graphic that you want to display.

All attachments that are attached to the landing page workspace are displayed in this list.
Attachments are also displayed in the Current Attached Files section at the bottom of the

page.
+ Show border: Select this option if you want the border of the graphic to be visible.

3 Click OK.
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Adding a Link (URL)

1 Inthe Landing Page Layout section, in the content editor, click Link (URL) in the element
palette, then drag it and drop it into the desired area of the landing page canvas.

'Link To Url Properties

Title

URL (e.g., http:/fwww.naovell.com)

] Openthe URL in a new window

2 Set the following configuration options to finish setting up the URL link:
+ Title: Specify the title that you want to be displayed.
+ URL: Specify the URL that you want to link to.
Tolink to a URL outside of Vibe, you must include http:// at the beginning of the URL.

To link to a page within Vibe, the best method isto use the Link to Folder/Workspace
element or the Link to Entry element.

An dternative is to paste a Vibe permalink into thisfield. To get the permalink URL of a
Vibe page, simply navigate to the page that you want to link to, click Permalink in the
footer toolbar, then copy the permalink URL from the Permalink field.

+ Open URL in a new window: Select this option if you want to open the URL in a new
browser window.

3 Click OK.

Adding a Link to a Folder/Workspace
You can create alink to any folder or workspace for which you have appropriate rights.

1 Inthe Landing Page Layout section, in the content editor, click Link to Folder/Wbrkspace in
the element palette, then drag it and drop it into the desired area of the landing page canvas.
2 Click Edit next to the Folder/\Wbrkspace field.

Thisfield is populated only if you have already configured this element, as described in this
section. When you are reconfiguring the element, the folder or workspace that is being
referenced is shown here.
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Link to Folder/Workspace Properties

Folder\Workspace: Mo folder selected

() Search entire site
Find- @ Search current folderiworkspace

Title: |

] Open the folderfiworkspace in a new window

3 Set the following configuration options to finish setting up the link:

+ Find: Select whether you want to search the entire site for the folder or only within the
current folder or workspace, then in the provided field specify the folder or workspace that
you want to link to.

Thisfield uses type-to-find functionality, so Vibe displays the available options as you
type.
+ Title: Specify atitle for the link.

+ Open thefolder/workspace in a new window: Select this option if you want to open the
folder or workspace in a new browser window.

Adding a Link to an Entry
Enables you to create alink to any entry for which you have appropriate rights.
1 Inthe Landing Page Layout section, in the content editor, click Link to Entry in the element
palette, then drag it and drop it into the desired area of the landing page canvas.
2 Click Edit next to the Entry field.

Thisfield is populated only if you have already configured this element, as described in this
section. When you are reconfiguring the element, the entry or workspace that is being
referenced is shown here.
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Link to Entry Properties

Entry: No entry selected (EIP

(7) Search entire site
Find: @ Search current folderiworkspace

Title: i

[ Open the entry in a new window

3 Set the following configuration options to finish setting up the link:

+ Find: Select whether you want to search the entire site for the entry or only within the
current folder or workspace, then in the provided field specify the entry that you want to
link to.

Thisfield uses type-to-find functionality, so Vibe displays the available options as you
type.

+ Title: Specify atitlefor thelink.

+ Open theentry in a new window: Select this option if you want to open theentry in a
new browser window.

Adding a Utility Element

Most utility elements are options that are normally displayed either in the Vibe masthead or
Navigation panel; however, because it is often desirable to hide the masthead and Navigation panel
in order to make more room for information on your landing page, utility elements enable you to
display important features in a more concise view.

1 Inthe Landing Page Layout section, in the content editor, click Utility Element in the element
palette, then drag it and drop it into the desired area of the landing page canvas.
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utility Element Properties

@ Link to "Follow this folder or workspace™
(2 Link to "My Workspace™

() Link to "Share this folder or workspace”
() Link to "Vibe administration page”

() Sign-in form

2 Select from the following utility elements:

Link to “Follow thisfolder or workspace”: Displays a Follow This Workspace or Follow
This Folder link.

Link to“My Workspace’: Displays alink to your personal workspace.

Link to“Sharethisfolder or workspace”: Displays a Share This Workspace or Share This
Folder link.

Link to“Vibeadministration page”: Providesalink to the Vibe Administration page.
Thislink isvisible only to Vibe users who have administrative rights.
Sign-in form: Displays a Sign In form when users are not logged in to Vibe.

3 Click OK.

Adding a Custom JSP

Custom JSP files are stored in the WweEB- INF\ jsp\custom_jsps directory. If you want to include a
custom JSP file in your landing page, you must store the filein this directory in order to reference it
from Vibe.

Typically, only Vibe administrators have access to this directory. If you want to create a custom JSP
file, consult your Vibe administrator.

After the custom JSP file has been placed in the WEB- INF\jsp\custom jsps directory:

1 Inthe Landing Page Layout section, in the content editor, click Custom JSP in the element
palette, then drag it and drop it into the desired area of the landing page canvas.
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Custom JSP Properties

Custom JSP name

[T Associate a folder with this custom jsp

[ Associate an entry with this custom jsp

2 Inthe Custom JSP name field, type the name of the custom JSP file that you want to reference.
You must obtain this filename from your Vibe administrator. Only your Vibe administrator can
enable JSP files to be used in the Vibe site.

3 Depending on how you want to use this custom JSP file, select either Associate a folder with
this custom jsp, or Associate an entry with this custom jsp.

For example, if your administrator has enabled a custom JSP file that enhances the way entries
are displayed on the landing page, and you want to utilize this JSP file for a specific folder, you
would select Associate a folder with this custom jsp.

4 Click Edit next to the Folder field.

Thisfield is populated only if you have already configured this element, as described in this
section. When you are reconfiguring the element, the field displays the folder that the custom
JSPfileis currently associated with. If you are creating a new element, thisfield is blank.

Custom JSP Properties

Custom JSP name

¥ Associate afolder with this custom jsp

Folder: Mo folder selected

() Search entire site

Find: @ Search current folderiworkspace

Number of entries to show: | |

[T] show Title Bar

[l associate an entry with this custom jsp

5 Set the appropriate configuration options to finish setting up the custom JSP:

Find: Select whether you want to search the entire site for the folder or only within the current
folder or workspace, then in the provided field specify the folder that you want to associate the
JSP file with.
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Thisfield uses type-to-find functionality, so Vibe displays the available options as you type.

Number of entriesto show: Specify how many folder entries you want to be displayed on the
landing page at any onetime.

Show Title Bar: Select this option if you want the title bar of the entry to be visible.
6 Click OK.

Adding an HTML Editor

To add content (such as text, links, pictures, and videos) to your landing page by using an HTML
editor:

1 Inthe Landing Page Layout section, in the content editor, click HTML in the element palette,
then drag it and drop it into the desired area of the landing page canvas.

Fontfamiy = Fontsize + | Format

2 Specify content into the HTML editor that you want to be displayed on the landing page. Click
the Show/Hideicon * to show and hide additional options.

3 Click OK.

Adding an Embedded Web Page

1 Inthe Landing Page Layout section, in the content editor, click Embedded Web Page in the
element palette, then drag it and drop it into the desired area of the landing page canvas.
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'Embedded Web Page Properties

URL (e.g., http:/fwww.novell.com):
http/f

Name:

Height: 200

Width: 400 |px
Margin height: 0 |px

Margin width: 0 Ipx

Show scrollbars: | Auto E|

[Tl show border

2 Set the following configuration options to finish setting up the embedded Web page:

*

*

URL : Specify the URL for the embedded Web page that you want to display.

Name: Specify a name that you want to call the page. This name is displayed on the
landing page above the embedded Web page.

Height: Specify the height (in pixels) of how much of the page you want to display.
Width: Specify the width (in pixels) of how much of the page you want to display.
Margin height: Adds margin height around the embedded Web page.

Thisfunction is not supported on all browsers.

Margin width: Adds margin width around the embedded Web page.

This function is not supported on all browsers.

Show scrollbars: Select whether you want to display scroll bars. Keep the default of Auto
if you want Vibe to auto detect whether scroll bars are needed.

Show border: Select whether you want to display a border around the embedded Web
page.

3 Click OK.

6.3 Publishing Your Landing Page

After you have added elements to your landing page and configured them, you can publish the
contents of the landing page.

1 Scroll to the bottom of the page that contains the landing page editor.
2 Click OK.
The landing page is displayed with all of the content that you previously added.

6.4 Modifying the Contents of Your Landing Page

Kablink Vibe enables you to modify the elements that have been previously added to your landing

page.

1 Navigate to the landing that contains the elements that you want to modify.
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For information about each type of element that you can modify, see Section 6.2.3,
“Configuring Landing Page Elements,” on page 55.

2 Click Workspace > Edit Workspace in the Action toolbar.
or
If your landing pageis on afolder, click Folder > Edit Folder.

3 Inthe Landing Page Layout section, in the content editor, click the edit icon .»| located in the
upper right corner of the landing page element that you want to modify.

The properties dialog box of the element that you are modifying is displayed.

Folder: Blog

L/ Search entire site 4]
Find: '@ Search current folderiwarkspace

MNumber of entries to show: |0

[Tl Show Title Bar
[T show Folder Description

[C] Show Entries opened

4 Modify the properties of the element, then click OK.

6.5 Reordering the Content of Your Landing
Page

Kablink Vibe enables you to change the order of elements that have been previously added to your
landing page.

1 Navigate to the landing that contains the elements that you want to reorder.

For information about each type of element, see Section 6.2.3, “ Configuring Landing Page
Elements,” on page 55.

2 Click Workspace > Edit Workspace in the Action tool bar.
or
If your landing page is on afolder, click Folder > Edit Folder.

3 Inthe Landing Page Layout section, in the content editor, click the Move icon + located in the
upper right corner of the landing page element that you want to move, then drag the element to
the desired location on the landing page canvas.

6.6 Deleting Content from Your Landing Page

Kablink Vibe enables you to delete elements that have previously been added to your landing page.

1 Navigate to the landing page that contains the element that you want to delete.
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2 Click Workspace > Edit Workspace in the Action toolbar.
or
If your landing pageis on afolder, click Folder > Edit Folder.

3 Inthe Landing Page Layout section, in the content editor, click the delete & icon located in the
upper right corner of the landing page element that you want to delete.

4 Click OK to delete the element.

6.7 Automatically Displaying the Newest Folder
Entries on Your Landing Page

You do not need to manually modify your landing page every time you want to replace an entry.
Because it can be tedious to delete an entry and then add another one from the Add/Delete form in
the Edit Workspace page, Kablink Vibe enables you to leverage the power of workflowsto help
keep your landing page up-to-date, with minimal manual effort.

For example, suppose that you are the manager of a particular product, and you want to use your
team landing page to display the product’s earnings for the most recent quarter. You could reference
aparticular entry in the Quarterly Earningsfolder, where all of the quarterly earnings for the product
are stored; however, this would mean that at the end of each quarter you would need to manually
delete the old entry from your landing page, and then add the new entry for the new quarter. Vibe
provides an easier way: simply reference the Quarterly Earnings folder from your landing page, and
at the end of each quarter start the Publish workflow (as described in Section 11.6.1, “ Available
Workflows,” on page 145) on the entry that contains the earning for that quarter. This displays the
entry that contains the updated quarterly earnings.

+ Section 6.7.1, “Pointing to the Folder Where the Entry Resides,” on page 69

+ Section 6.7.2, “Using the Publish Workflow to Publish Entries to Your Landing Page,” on
page 70

6.7.1 Pointing to the Folder Where the Entry Resides

When you are adding content to your landing page (as described in Section 6.2.2, “Adding Content
to Your Landing Page,” on page 53), if you display an entry that you might want to replace in the
future, reference the folder where the entry resides instead of referencing the entry directly.
1 Navigate to your landing page.
2 Click Workspace > Edit Workspace.
or
If your landing page is on afolder, click Folder > Edit Folder.

3 Inthe Landing Page Layout section, in the content editor, click Folder in the element palette,
then drag it and drop it into the desired area of the landing page canvas.
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‘Folder Properties
Folder: Mo folder selected (@08

) search entire site
Find- '@ Search current folder/workspace

Number of entries to show: .[]

[C] show Title Bar
[ show Folder Description
[ show Entries opened

4 Set the following configuration options to finish setting up the folder:

*

*

Folder: Thisfield is populated only if you have already configured this element, as
described in this section. After you have configured this element as described in this
section, the folder that is being referenced is shown here.

Find: Specify the folder where the entry that you want to display resides.

Thisfield uses type-to-find functionality, so Vibe displays the available options as you
type.

Number of entriesto show: Specify the number of folder entries that you want to be
displayed at any onetime.

Show Title Bar: Select this option if you want the folder title bar to be displayed.
Show Folder Description: Select thisoption if you want the folder description to be
displayed.

Show Entries opened: Select thisoption if you want opened entries to be displayed.

5 Click OK.

6.7.2 Using the Publish Workflow to Publish Entries to Your
Landing Page

By default, Vibe includes a workflow called Publish. Thisworkflow can help you more easily
manage what is displayed on your landing page.

If you are referencing afolder from your landing page (as described in Section 6.7.1, “ Pointing to
the Folder Where the Entry Resides,” on page 69), and you have configured the landing page to
display just one entry from the folder, you can use the Publish workflow to decide which entry you
want to display on your landing page.

The most recent entry that you publish isthe entry that is displayed on the landing page (published
to the landing page).

+ “Enabling the Publish Workflow on Your Folder” on page 71
+ “Publishing a New Entry to Your Landing Page” on page 71
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Enabling the Publish Workflow on Your Folder

1 Navigate to the folder where you want to enable the Publish workflow.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.
3 Inthe Allowed Workflows section, select Publish Workflow.
4 Click Apply > Close.

Publishing a New Entry to Your Landing Page

1 Open the entry that you want to display on your landing page.
2 Inthe Entry toolbar, click Workflow > Start Workflow: Publish Workflow.

The entry where you most recently started the Publish workflow is now displayed on your
landing page, replacing the entry that was previously displayed.

6.8 Adding Accessories to Your Landing Page

You can add accessoriesto alanding page by modifying the view of the standard landing page, or by
creating a new landing page view. You must be the Vibe administrator to modify the view of the
standard landing page. If you are not the Vibe administrator, you must create a new landing page
view.

+ Section 6.8.1, “Modifying the Default Landing Page,” on page 71

+ Section 6.8.2, “Creating a New Landing Page View,” on page 72

6.8.1 Modifying the Default Landing Page

You can add the Accessory Panel to the default Landing Page view. This meansthat al landing
pages that are created in the Vibe site will contain the Accessory Panel.

You must be the Kablink Vibe administrator or have administrative rights to modify the default
Landing Page view.
1 Click the Administration icon E located in the upper right corner of the Vibe page.
The administration page is displayed.
2 Under System, click Form/View Designers.
The Form and View Designers page is launched.
3 Expand Workspace view, then click Landing Page.
4 Click Workspace view > Add.
5 Inthe Sandard Form Elements section, click Accessory Panel, then click OK.

The Accessory Panel has now been added to the standard Landing Page view, so users can add
accessories to their landing pages.
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6.8.2 Creating a New Landing Page View

You can create your own Landing Page view, then add the Accessory Panel element to the view. You
do not need to be the Vibe administrator to create a new landing page view.

+ “Creating the New Landing Page Definition” on page 72

+ “Adding the Landing Page Layout Option” on page 72

+ “Enabling the New Landing Page” on page 73

+ “Modifying the Landing Page After You Have Created It” on page 73

Creating the New Landing Page Definition

1 Navigate to the workspace where you want to create the new Landing Page view.
2 Click Workspace > Form/View Designersin the Action tool bar.
The Form and View Designers page is displayed.
3 Click New > Workspace views.
4 Specify the following information:
Caption: Specify aname for the new landing page.

Thisis the name that appearsin the Vibe interface for users to see when they use this
workspace. (For example, Custom Landing Page.)

Name: Specify the internal name for the landing page.

The name that you enter in thisfield is not visible to users who use this workspace. (For
example, custom landing page.)

Family: Select the workspace type that this view is most closely associated with.
Workspace | cons. Select the workspace icon that you want to represent the landing page.
5 Click OK.
The Designer page is launched.
6 Continue with “Adding the Landing Page Layout Option” on page 72.

Adding the Landing Page Layout Option

1 Inthe Designer page, click Workspace Add/Modify Form > Add.

2 Inthe Layout Options section, click Landing Page Layout.

3 Specify the following information:

Caption: Specify aname for the Landing Page Layout, or keep the default.
Name: Specify the internal name for the Landing Page Layout.

Click OK.

Click Workspace view > Add.

In the Sandard Form Elements section, click Landing Page Layout.

For the Caption and Data item name fields, retain the same information that you specified in
Step 3.

8 Click OK > Close> Close.
9 Continue with “Enabling the New Landing Page” on page 73.

~N o o1 b~
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Enabling the New Landing Page
After you have created the new landing page view, you need to enable it on the workspace.

1 From the workspace where you want to enable the landing page, click Workspace > Configure.
The Configure Default Settings page is displayed.

2 Inthe Default View section, go to the Local Definitions subsection and select the landing page
that you created.

3 Click Apply > Close.
The landing page is now displayed when you access the workspace.
4 Continue with “Modifying the Landing Page After You Have Created It” on page 73.

Modifying the Landing Page After You Have Created It

Now that you have created and enabled the new landing page, you can configure the landing page
layout options, such as hiding the Navigation panel. This can give your landing page a more
traditional landing page feel.

For information about how to modify the landing page layout options, see Section 6.2.1, “Choosing
Layout Options for Your Landing Page,” on page 52.

6.9 Enabling Graphics to Be Used on a Landing
Page
Before you can add a graphic to alanding page, as described in “ Adding a Graphic” on page 60, you

need to attach the graphic to the workspace or folder, depending on whether your landing pageison
aworkspace or folder.

+ Section 6.9.1, “Enabling Graphics to Be Used on a Workspace Landing Page,” on page 73
+ Section 6.9.2, “Enabling Graphics to Be Used on a Folder Landing Page,” on page 74

6.9.1 Enabling Graphics to Be Used on a Workspace Landing
Page
1 Navigate to the landing page where you want to attach the graphic.

2 Click Workspace > Edit Workspace.

3 Inthe Attachments section, click Browse, then browse to and select the graphic that you want to
add.

4 After thefileis selected and is displayed in the Attachments field, click OK.
To delete afile from the workspace:

1 Inthe Current Attached Files section, select the file that you want to delete.
2 Click OK.
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6.9.2 Enabling Graphics to Be Used on a Folder Landing Page

+ “Adding the Attachment Element to the Folder Form™ on page 74
+ “Attaching the Graphic to the Folder” on page 74

Adding the Attachment Element to the Folder Form

You should have already added the Landing Page element to both the folder Form and View in order
to create alanding page for afolder. (For moreinformation, see Section 6.12, “Creating a Landing
Page for a Folder,” on page 76.)

To enable graphics to be used on your folder landing page:

1 Add the Attachments element to the folder Form, as described in Section 8.2, “Modifying an
Existing Folder View,” on page 92.

You do not need to add the Attachments element to the folder View, because this element
should only be displayed on the folder Form.

2 Continue with “ Attaching the Graphic to the Folder” on page 74.

Attaching the Graphic to the Folder

1 Navigate to the landing page where you want to attach the graphic.
2 Click Folder > Edit Folder.

3 Inthe Attachments section, click Browse, then browse to and select the graphic that you want to
add.

4 After thefileis selected and is displayed in the Attachments field, click OK.
To delete afile from the folder:

1 Inthe Current Attached Files section, select the file that you want to delete.
2 Click OK.

6.10 Displaying YouTube Videos on a Landing
Page
Kablink Vibe enables you to display YouTube videos in various sections of alanding page.

+ Section 6.10.1, “Displaying Videosin the Branding Section of a Landing Page,” on page 74
+ Section 6.10.2, “Displaying Videosin the Main Landing Page Area,” on page 75

6.10.1 Displaying Videos in the Branding Section of a Landing
Page

You can add a YouTube video to the Branding section of alanding page, as described in Chapter 5,
“Branding a Folder or Workspace,” on page 47.
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6.10.2 Displaying Videos in the Main Landing Page Area

You can display YouTube videos on alanding page in the following ways:
+ By adding an HTML editor, as described in “Adding an HTML Editor” on page 66. Click the
Expand icon * , then click the Videoicon H|.

+ By referencing afolder or folder entry that contains a YouTube video, as described in
Section 6.2.2, “ Adding Content to Your Landing Page,” on page 53.

For information on how to create afolder entry that contains a YouTube video, see” Displaying
YouTube Videos in a Folder Entry” in the Kablink Vibe OnPrem 3.1 User Guide.

6.11 Creating a Landing Page for a Personal
Workspace

You can create alanding page in a personal workspace only if your Kablink Vibe administrator has
enabled you to do so. If you are unable to create alanding page on your personal workspace as
described in this section, consult your Vibe administrator.

If you are a Vibe administrator and you want to enable landing page creation for persond
workspaces, see “Enabling Users to Create Landing Pages on Personal Workspaces® in the Kablink
Vibe OnPrem 3.1 Administration Guide.

1 Inyour personal workspace, click Workspace > Configure in the Action toolbar.

The Configure Default Settings page is displayed.

Current Workspace: Anita Olivos (aolivos)

Define URL
nttp:fipenroddivibe! | L = ]

Default View @

@ UserLanding Page (user_landing_page)
@ UserWorkspace (_userWorkspace)

T,

2 Inthe Default View section, select the landing page option that your administrator added.
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Default View @
User Landing Page (user_landing_page)
@ UserWorkspace (_useriWorkspace)

3 Click Apply > Close.

4 Continue with Section 6.2, “ Setting Up Your Landing Page,” on page 52 to complete the
creation of your landing page.

6.12 Creating a Landing Page for a Folder

Displaying landing pages at the workspace level makes the workspace home page a quick portal to
the most important information contained throughout the workspace. In addition to displaying
landing pages at the workspace level, Kablink Vibe also enables you to display landing pages at the
folder level.

You might want to create alanding page for afolder if your folder contains many sub-folders, is
frequently visited, and contains alot of information. Because workspace landing pages are more
common than folder landing pages, the process for creating alanding page on the folder is more
complex than creating a landing page for a workspace.

By default, in order to create alanding page for afolder in Vibe, you need to create a new folder
view. (For example, you might name your folder view “Landing Page.”) You need to populate this
folder view with the Landing Page Layout layout option in the Folder Form, and the Landing Page
Layout element in the Folder View. For information on how to create alanding page by creating a
new folder view, see Chapter 8, “ Creating Custom Folder Views,” on page 87.

After you create the new landing page folder view, continue setting up your landing page by
following the information in Section 6.2, “ Setting Up Your Landing Page,” on page 52.

6.13 Downloading Existing Landing Pages

The Novell Vibe Resource Library provides a collection of existing Vibe folder entry forms,
workflows, and landing pages that have been designed to solve specific business problems. You can
easily download the custom forms and workflows, then import them into your Vibe environment.
You can further customize these forms and workflows to suit your individual business needs.

1 Navigate to the Novell Vibe Resource Library Web site (http://www.novell.com/products/vibe-
onprem/resource-library/).

Click the Workspaces tab.

Select the custom workspace that you want to use in your Vibe environment.

In the Attachment section, click the zip file to download it.

ga b~ W N

Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Resource Library Deployment
Instructions (http://www.novell.com/communities/node/8359/depl oyment-instructions).
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Creating Custom Workspace
Views

Kablink Vibe OnPrem enables you to create custom workspace views and to customize existing
views. Workspace views define what is displayed on the home page of your workspace. When you
create custom workspace views, you can configure workspaces to display optional features such as
remote applications, attachments, and more. You can even create a custom workspace landing page.

To create a custom workspace view, you must complete the following sections:

+ Section 7.1, “Creating a New Custom Workspace View,” on page 77
Section 7.2, “Modifying an Existing Workspace View,” on page 82
Section 7.3, “Enabling the Workspace View,” on page 82

Section 7.4, “Populating Elements in the Workspace View,” on page 83
Section 7.5, “Understanding Elements,” on page 83

Section 7.6, “Understanding Layout Options,” on page 85

*

*

*

*

*

7.1 Creating a New Custom Workspace View

To create a new custom workspace, you use the Form and View Desiner to create a view, then you
create a form with the elements and layout options that you want to display in the view. After the
formisin place, you add the same elements and layout options to the view, then you can add
optional view elements to create the final view.

You must have both aform and aview in order to display all the elements that you want in a
workspace. The form and the view must have a common set of elements and layout options, but the
view can have some additional elements that are not in the form.

Marketing
Designer >> Custom Workspace (custom_workspace)

Wiorkspace Addhdodity Form
Wiorkspace view

+ Section 7.1.1, “Creating the View,” on page 78
+ Section 7.1.2, “Adding Elements to the Workspace Add/Modify Form,” on page 78
+ Section 7.1.3, “Adding Elements to the Workspace View,” on page 80
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7.1.1 Creating the View

1 Navigate to the workspace where you want to create the new view.
2 Click Workspace > Form/View Designersin the Action tool bar.
The Form and View Designers page is launched.
3 Click New > Workspace Views.
The Add aNew Definition form is displayed.
4 Specify the following information in the Add a New Definition section:

Caption: Specify the name of the workspace view that you want to appear in the Kablink Vibe
interface. (For example, “ Custom Workspace.”)

Name: Specify the internal name of the workspace view. This name is not visible to regular
Vibe users. (For example, “custom_workspace.”)

Family: Select the workspace type that this view is most closely associated with.

Workspace | cons. Select theicon that you want to represent the workspace. Theicon that you
select is displayed with the name of the workspace in the Navigation panel.

5 Click OK.

6 Continue with Section 7.1.2, “ Adding Elements to the Workspace Add/Modify Form,” on
page 78.

7.1.2 Adding Elements to the Workspace Add/Modify Form

Theworkspace add/modify form isthe form you see when you are creating or modifying the content
of your workspace home page. This form needs to contain the elements and layout options that you
want to display in your workspace home page. For example, you might want to display multiple
remote applications and a two-column table.

After you add elements and layout options to the workspace form, you must then add those same
elements and layout options to the workspace view in order for the elements and options to be
displayed in your workspace. For information on how to add features to the workspace view, see
Section 7.1.3, “ Adding Elements to the Workspace View,” on page 80.

1 Under the custom workspace form that you created, expand Workspace Add/Modify Form.

If you are modifying an existing form, all of the elements and layout options that are currently
applied to your form are displayed.

or
If you are creating a new form, only the default options are displayed.
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*

*

Marketing
Designer >> Custom Workspace (custom_workspace)

EI--- Cuztom Workzpace (custom_workspace)

E|--- Wiorkzpace view

Add and modify the desired elements and layout options, as described in the following
sections:

“Adding Elements to a Form” on page 79

“Modifying Elementsin a Form” on page 79

“Deleting Elementsin a Form” on page 80

“Adding Layout Optionsto a Form” on page 80

Based on the modifications that you make to aform element or option, you might need to make the
same modifications to the corresponding view element or option.

Adding Elements to a Form

1
2
3

Click Workspace Add/Modify Form.
In the Workspace Add/Modify Form window, on the right side of the page, click Add.
In the Sandard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 7.5.1, “Workspace Form
Elements,” on page 83.

4 Specify the appropriate information.

5

Click OK.

Modifying Elements in a Form

If you are modifying an existing form, you can modify existing elements.

1
2
3

Expand Workspace Add/Modify Form, then click the element that you want to modify.
In the window on the right side of the page, click Modify.
Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Form
If you are modifying an existing form, you can del ete existing elements.

1 Expand Workspace Add/Modify Form, then click the element that you want to delete.
2 Inthewindow on theright side of the page, click Delete.
3 Click OK.

Adding Layout Options to a Form

1 Click Workspace Add/Modify Form.
2 Inthe Workspace Add/Modify Form window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 7.6,
“Understanding Layout Options,” on page 85.

4 Specify the appropriate information.
5 Click OK.

7.1.3 Adding Elements to the Workspace View

The workspace view is how the information from your workspace add/modify formis displayed to
users who view your workspace. Every form must have a corresponding view. This view needs to
contain all of the elements and layout options that you want to display in your workspace home
page; it is made up of elements from the form.

Vibe provides you with all of the tools necessary to create a workspace view that suits any of the
purposes that you want to accomplish with your workspace.

Before you can add elements and layout options to the workspace view, you must first add the
elements and layout options to the workspace form in order for them to be displayed in your
workspace. (For information on how to add features to the workspace form, see Section 7.1.2,
“ Adding Elements to the Workspace Add/Maodify Form,” on page 78.)

To add elements to the views

1 Under the custom entry form that you created, expand Workspace view.

If you are modifying an existing view, al of the elements and layout options that are currently
applied to your view are displayed.

or
If you are creating a new view, only the default options are displayed.
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2 Add the desired elements and layout options, as described in the following sections:

*

“Adding Elementsto aView” on page 81

*

“Modifying Elementsin aView” on page 81

*

“Deleting Elementsin aView” on page 81

*

“Adding Layout Optionsto aView” on page 82

Adding Elements to a View

1 Click Workspace view.
2 Inthe Workspace View window, on the right side of the page, click Add.
3 Inthe Sandard Form Elements section, click the element that you want to add.

When you add elements to a view, you add elements that have already been added to the form;
any form element that you create can be added as a view element.

For information on the types of elements that you can add that are specific to views, see
Section 7.5.2, “Workspace View Elements,” on page 85.

4 Specify the appropriate information.
5 Click OK.
Modifying Elements in a View
If you are modifying an existing view, you can modify existing elements.

1 Expand Workspace view, then click the element that you want to modify.
2 Inthewindow on theright side of the page, click Modify.
3 Make the desired modifications, such as changing the caption or data name, then click OK.

Deleting Elements in a View
If you are modifying an existing view, you can del ete existing elements.

1 Expand Workspace view, then click the element that you want to delete.
2 Inthewindow on theright side of the page, click Delete.
3 Click OK.
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Adding Layout Options to a View

1 Click Workspace view.
2 Inthe Workspace view window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 7.6,
“Understanding Layout Options,” on page 85.

4 Specify the appropriate information.
5 Click OK.

7.2 Modifying an Existing Workspace View
You can also createa custom workspaceby modifying an existing workspace view.

1 Inthefolder or workspace where the custom workspace view was created, click Workspace >
Form/View Designers.

The Form and View Designers page is launched.

Form and View Designers

Form and View definitions for 'Marketing'

F-Home Workspace i F-Team Workspaces  H-Marketing

E o

Formfiew Designers
- @ Entry Definitions

- @ Wiorkflowy Processes

- @ Workspace view

2 Expand Workspace view, then click the custom workspace view that you want to modify.

3 Continue with Section 7.1.2, “ Adding Elements to the Workspace Add/Modify Form,” on
page 78.

7.3 Enabling the Workspace View

After you have created the workspace view, you need to enable it as the default view for the
workspace.

1 Navigate to the workspace where you want to enable your custom view as the default view.
2 Click Workspace > Configure in the Action toolbar.
The Configure Default Settings page is displayed.
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3 Inthe Default View section, select the custom view that you created.
4 Click Apply > Close.

7.4 Populating Elements in the Workspace View

After you create aworkspace view, you need to populate and customize some of the elements that
you included in the view.

For example, if you added a Branding element, you need to create your brand to display in the
workspace; if you added a Description element, you need to popul ate the element with a description
of the workspace; if you added an Attachment element, you need to attach any files that you want to
display in the workspace, and so forth.

1 After the workspace view has been created and enabled as the default workspace view, as
described in Section 7.3, “ Enabling the Workspace View,” on page 82, navigate to the
workspace.

2 Click Workspace > Edit Workspace.

A page with all of the form elements that you added to the workspace view add/modify formis
displayed. (If you want these elements to be displayed in the workspace, ensure that you have
also added them to the view form of the workspace view.)

3 Populate the elements with the desired information.
For example, create your workspace brand, add a workspace description, and attach any files.
4 Click OK.

7.5 Understanding Elements

Elements make up the content of your workspace forms and views.

When you are adding elements to a form, remember that you need to add that same element to the
view in order for it to be displayed in the workspace.

You can add the following elements:

+ Section 7.5.1, “Workspace Form Elements,” on page 83
+ Section 7.5.2, “Workspace View Elements,” on page 85

7.5.1 Workspace Form Elements

Attachment(s): Adds afield that enables you to browse for and upload files, making them
accessible to those who view the workspace.

Thefilesthat you upload are displayed in the workspace home page.

Branding: Addsan HTML text editor that enables you to create a brand for the workspace.
This brand is displayed in the upper left corner of the workspace.

Checkbox: Adds a check box that can be selected or desel ected.

Date: Adds afield that launches a calendar applet when users click insideiit.
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Dateand Time: Addstwo fields. The first field launches a calendar applet, and the second field
launches a time-sel ection applet when users click inside.

E-Mail AddressList: Addsafield that enables you to specify e-mail addresses.

Description: Adds an HTML text editor that enables you to specify a description of the workspace.
File Upload: Adds afield that enables users to browse for and upload files.

Group List: Adds an element that enables users to add groups.

Hidden Field: Addsahidden element. When you design the custom form, you can use this element
to add boilerplate text to every entry that is created. Thistext is“hidden” because it does not appear
on the entry form when users are creating an entry; however, the text does appear on the entry view
after the entry is created.

HTML Editor Text Area: Addsan HTML text area where you can compose messages, create
links, upload pictures, and more. The information that you create in thisHTML editor is displayed
in your folder.

| con: Enables the workspace owner to choose from a selection of icons to represent the workspace.
Number: Adds afield that requires users to enter anumber. Alphabetic characters are rejected.
Picture: Adds afield that enables you to browse for and upload pictures.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enablesyou to display certain applicationsthat have been configured by your
Vibe administrator.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on
page 151.

Selectbox: Enables you to display options that users can select.

Team List: Adds afield that enables usersto specify teams.

Text: Adds afield where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds afield that enables you to specify atitle for the workspace.
URL: Add afield that converts any text into a hyperlink.

User List: Addsafield that enablesyou to specify other Vibe users, using type-to-find functionality.
When you specify a user’s name when you modify the workspace, as described in Section 8.4,
“Populating Elementsin the Folder View,” on page 93, Vibe displays the user’s name on the folder
home page, with links to his or her personal workspaces.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to
another application through iCal. You should not manually add this element to any form or view.

For more information about iCal in Vibe, see “ Synchronizing Tasks and Calendars to a Desktop
Application” in the Kablink Vibe OnPrem 3.1 User Guide.
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7.5.2 Workspace View Elements

Any form element that you create can be added as aview element, if you want it to appear in the
view.

The following elements are specific to views; they cannot be added to aform.

Accessory Panel: Displays the Accessory Panel on the workspace home page. Users can use this
panel to add community or personal accessories, depending on their individual rights.

For more information on accessories, see “Managing Accessories’ in the Kablink Vibe OnPrem 3.1
User Guide.

Attachments. Displays all attachments.

Branding: Displays the workspace branding.

Entry Creation Date: Displaysthe date that the entry was created.

Entry Creator: Displays who created the entry.

Entry Creator and Creation Date: Displays who created the entry and when they created it.

Landing Page L ayout: Adds alanding page creation form that enables you to create landing page
elements to display in your workspace.

You must add the Landing Page Layout layout option in the workspace add/modify form before you
can add it asaview element.

Title: On the workspace home page, displays the title that you specified for the workspace.

Workspace and Folder List: Displays aworkspace tree that contains the workspace and all sub-
workspaces and sub-folders.

7.6 Understanding Layout Options

Layout options can enhance the presentation of your workspace forms and views.

When you are adding layout options to aform, remember that you need to add that same layout
options to the view in order for it to be displayed in the workspace.

You can add the following form layout options:
Box: Places abox around the specified elements.
Custom JSP: Enables you to reference a custom JSP from the Vibe directory.

Custom JSPs must be created by Vibe administrators before you can reference them, as described in
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 109.

Divider: Displays ahorizontal line between elements.
Expandable Area: Displays an expandable tree element.
Fieldset: Addsabox that can contain other elements.

Use this option if your form is exceptionally long.
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HTML: Adds HTML formatting.

Landing Page L ayout: (For the View Definition, the Landing Page Layout isin the Elements
section) Adds alanding page creation form that enables you to create landing page elementsthat you
can populate when you modify your workspace.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.

86 Kablink Vibe OnPrem 3.1 Advanced User Guide



Creating Custom Folder Views

Kablink Vibe OnPrem enables you to design custom folder views. Folder views define what is
displayed on the home page of your folder. When you design custom folder views, you can
configure folders to display optional features such as remote applications, attachments, and more.
You can even create afolder landing page.

To create a custom folder view, you must compl ete the following sections:
+ Section 8.1, “Creating a New Custom Folder View,” on page 87

Section 8.2, “Moadifying an Existing Folder View,” on page 92

Section 8.3, “Enabling the Folder View,” on page 93

Section 8.4, “Populating Elements in the Folder View,” on page 93

*

*

*

*

Section 8.5, “Understanding Elements,” on page 93

*

Section 8.6, “Understanding Layout Options,” on page 95

8.1 Creating a New Custom Folder View

To create a new custom folder, you use the Form and View Designer to create a view, then you
create a form with the elements and layout options that you want to display in the view. After the
formisin place, you add the same elements and layout options to the view, then you can add
optional view elements to create the final view.

You must have both aform and aview in order to display all the elements that you want in afolder.
The form and the view must have a common set of elements and layout options, but the view can
have some additional elements that are not in the form.

+ Section 8.1.1, “Creating the View,” on page 87

+ Section 8.1.2, “Adding Elements to the Folder Add/Modify Form,” on page 88

+ Section 8.1.3, “Adding Elements to the Folder View,” on page 90

8.1.1 Creating the View

1 Navigate to the folder or workspace where you want to create the new view.

If you create anew folder view at the workspace level, the folder view can be enabled on any
folder within the workspace. If you create the folder view at the folder level, the folder view
can be enabled only on that folder where the view was created.

2 If you are creating the new folder view at the folder level, click Folder > FornvVView Designers
in the Action toolbar.

or

If you are creating the new folder view at the workspace level, click Workspace > Form/Miew
Designersin the Action toolbar.

The Form and View Designers page is displayed.
3 Click New > Folder Views.
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The Add aNew Definition form is displayed.
4 Specify the following information in the Add a New Definition section:;

Caption: Specify the name of the folder view that you want to appear in the Kablink Vibe
interface. (For example, “ Custom Blog.”)

Name: Specify the internal name of the folder view. This nameis not visible to regular Vibe
users. (For example, “custom_blog.”)

Family: Select the folder type that this view is most closely associated with.

Createa File Entry on filedrag/drop: Select thisoptionif you want Vibe to create anew file
entry when you drag and drop afile into the folder by using the Add Files to Folder feature, as
described in “Adding a File by Dragging and Dropping” in the Kablink Vibe OnPrem 3.1 User
Guide.

If you do not select this option, the default entry type for the folder is created when you drag
and drop afileinto the folder using the Add Files to Folder feature, as described in “Dragging
and Dropping Files’ in the Kablink Vibe OnPrem 3.1 User Guide. For example, in aBlog
folder, ablog entry is created, and the file is added as an entry attachment.

If you are creating anew view for aFiles folder, this option has no effect.

Folder Icons: Select the icon that you want to represent the folder. The icon that you select is
displayed with the name of the folder in the Navigation panel.

5 Click OK.
6 Continue with Section 8.1.2, “ Adding Elements to the Folder Add/Modify Form,” on page 88.

8.1.2 Adding Elements to the Folder Add/Modify Form

The Folder Form section in the Form and View Designerstool lets you choose the features you want
to include in your folder.

After you add elements and layout options to the folder form, you must then add those same
elements and layout options to the folder view in order for them to be displayed in your folder. For
information on how to add features to the folder view, see “ Adding Elements to a Folder Form” on

page 89.

Vibe provides you with all of the tools necessary to create afolder form that suits any purpose that
you want to accomplish with your folder.

1 Expand the custom folder form that you previously defined.
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Add, modify, and delete elements and layout options, as described in the following sections:

“Adding Elements to a Folder Form” on page 89
“Modifying Elementsin aFolder Form” on page 89
“Deleting Elements in a Folder Form” on page 90
“Adding Layout Optionsto a Form” on page 90

Based on the maodifications that you make to aform element or option, you might need to make the
same modifications to the corresponding view element or option.

Adding Elements to a Folder Form

1
2
3

Click Folder Form.
In the Folder Form window, on the right side of the page, click Add.
In the Sandard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 8.5.1, “Folder Form
Elements,” on page 93.

4 Specify the appropriate information to configure the element.

5

Click OK.

Modifying Elements in a Folder Form

If you are modifying an existing form, you can modify existing elements.

1
2
3

Expand Folder Form, then click the element that you want to modify.
In the window on the right side of the page, click Modify.
Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Folder Form
If you are modifying an existing form, you can del ete existing elements.

1 Expand Folder Form, then click the element that you want to delete.
2 Inthewindow on theright side of the page, click Delete.
3 Click OK.

Adding Layout Options to a Form

1 Click Folder Form.
2 Inthe Folder Form window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 8.6,
“Understanding Layout Options,” on page 95.

4 Specify the appropriate information to configure the layout option.
5 Click OK.

8.1.3 Adding Elements to the Folder View

The folder view is how your folder form is displayed to other users. Every folder form must have a
view associated with it. This view needs to contain all of the elements that you want to display in
your folder.

Vibe provides you with all of the tools necessary to create afolder view that suits any purpose that
you want to accomplish with your folder.
1 Expand the custom folder view that you previoudly defined, then expand Folder View.

If you are modifying an existing view, al of the elements and layout options that are currently
applied to the view are displayed.

or
If you are creating a new view, only the default options are displayed.
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2 Add, modify, and delete elements and layout options, as described in the following sections:

*

“Adding Elements to a Folder View” on page 91

*

“Modifying Elements in a Folder View” on page 91

*

“Deleting Elements in a Folder View” on page 92

*

“Adding Layout Options to a Folder View” on page 92

Adding Elements to a Folder View

1 Click Folder View.
2 Inthe Folder View Definition window, on the right side of the page, click Add.
3 Inthe Sandard Form Elements section, click the element that you want to add to the view.

For information on the types of elements that you can add, see Section 8.5.2, “Folder View
Elements,” on page 95.

Before you can add some of these elementsto your Folder View, you must first add them to the
Folder Form. For information on how to do this, see “Adding Elements to a Folder Form” on

page 89.
4 Specify the appropriate information to configure the element.

5 Click OK.
Modifying Elements in a Folder View
If you are modifying an existing view, you can modify existing elements.

1 Expand Folder View, then click the element that you want to modify.
2 Inthewindow on theright side of the page, click Modify.
3 Make the desired modifications, such as changing the caption or data name, then click OK.
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Deleting Elements in a Folder View
If you are modifying an existing view, you can delete existing elements.

1 Expand Folder View, then click the element that you want to delete.
2 Inthewindow on theright side of the page, click Delete.
3 Click OK.

Adding Layout Options to a Folder View

1 Click Folder View.
2 Inthe Folder View window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 8.6,
“Understanding Layout Options,” on page 95.

4 Specify the appropriate information to configure the layout option.
5 Click OK.

8.2 Modifying an Existing Folder View

In addition to creating a new custom folder view as described in Section 8.1, “ Creating a New
Custom Folder View,” on page 87, you can create a custom folder by modifying an existing folder
view.

1 Inthefolder or workspace where the custom folder view was previously defined, click Folder
> Form/\Miew Designers.

The Form and View Designers page is launched.
2 Expand Folder Views, then click the custom folder view that you want to modify.

orm and View Designers

Form and View definitions for "Marketing’

[F-Home Warkspace i F-Team Workspaces f  F-Marketing

= & Formiview Designers
& Entry Defintions
E| & Falder Yiews
l custom folder (custom_folder)
& Workflowe Processes

Bl @ Warkspace view

3 Continue with Section 8.1.2, “ Adding Elements to the Folder Add/Modify Form,” on page 88.
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8.3 Enabling the Folder View

After you have defined and designed the folder view, you need to enable it to be viewed by those
who will use the folder.

You can enable the folder view to be the default folder view for afolder, or to be an aternate folder
view.

For information on how to do this, see Section 3.1, “Managing Folder Views,” on page 25.

8.4 Populating Elements in the Folder View

After you create and enable afolder view, you need to populate and customize some of the elements
that you included in the view.

For example, if you added a Branding element, you need to create your brand to display in the
folder; if you added a Description element, you need to populate the element with a description of
thefolder; if you added an Attachment element, you need to attach any filesthat you want to display
in the folder, and so forth.

1 Ensurethat the folder view has been created and enabled as the default folder view, as
described in Section 8.1, “Creating a New Custom Folder View,” on page 87 and Section 8.3,
“Enabling the Folder View,” on page 93.

2 Navigate to the folder where you enabled the folder view.
3 Click Folder > Edit Folder in the Action toolbar.

A page with all of form elements that you added to the folder form is displayed. (If you want
these elements to be displayed in the folder, ensure that you have also added them to the folder
view, as described in Section 8.1.3, “Adding Elements to the Folder View,” on page 90.)

4 Populate the elements with the desired information.
For example, create your folder brand, add afolder description, attach any files, and so forth.
5 Click OK.

8.5 Understanding Elements

Elements make up the content of your forms and views. Some elements can be used only once.

When you are adding elements, remember that when you add an element to aform, you need to add
that same element to the view in order for it to be displayed in the folder.

You can add the following elements:

+ Section 8.5.1, “Folder Form Elements,” on page 93
+ Section 8.5.2, “Folder View Elements,” on page 95
8.5.1 Folder Form Elements

Attachments. Enables you to display uploaded files as an attachment.
Attachments include a thumbnail, and detail s about the document, such as file size and author.

Branding: Enables you to brand your folder.
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Checkbox: Adds a check box that can be selected or deselected.
Date: Adds afield that launches a calendar applet when users click insideit.

Dateand Time: Addstwo fields. The first field launches a calendar applet, and the second field
launches a time-sel ection applet when users click inside.

E-Mail AddressList: Addsafield that enables you to specify e-mail addresses.

Description: Adds an HTML text editor that enables you to provide a description of the folder.
File Upload: Enables you to upload files.

Group List: Adds an element that enables users to add groups.

Hidden Field: Addsahidden element. When you design the custom form, you can use this element
to add boilerplate text to every entry that is created. Thistext is“hidden” because it does not appear
on the entry form when users are creating an entry; however, the text does appear on the entry view
after the entry is created.

HTML Editor Text Area: Addsan HTML text editor where you can compose messages, create
links, upload pictures, and more. The information that you create in thisHTML editor is displayed
in your folder.

| con: Enables you to change the folder icon that is displayed in the Navigation panel.
Number: Adds afield that requires users to enter anumber. Alphabetic characters are rejected.
Picture: Adds afield that enables you to upload a picture to display in your folder.

Radio Buttons: Enables you to display options that users can select with radio buttons.

Remote Application: Enablesyou to display certain applicationsthat have been configured by your
Vibe administrator.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on
page 151.

Selectbox: Enables you to display options that users can select.

Team List: Adds afield that enables usersto specify teams.

Text: Adds afield where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds afield that enables you to specify atitle for the workspace.
URL: Add afield that converts any text into a hyperlink.

User List: Addsafield that enablesyou to specify other Vibe users, using type-to-find functionality.
When you specify a user’s name when you modify the workspace, as described in Section 8.4,
“Populating Elementsin the Folder View,” on page 93, Vibe displays the user’s name on the folder
home page, with links to his or her personal workspaces.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendars to
another application through iCal. You should not manually add this element to any form or view.
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For more information about iCal in Vibe, see “ Synchronizing Tasks and Calendars to a Desktop
Application” in the Kablink Vibe OnPrem 3.1 User Guide.

8.5.2 Folder View Elements

Any form element that you create can be added as aview element, if you want it to show up in the
view.

The following elements are specific to views; they cannot be added to aform.

Accessory Panel: Displays the Accessory Panel on the workspace home page. Users can use this
panel to add community or personal accessories, depending on their individual rights.

For moreinformation on Accessories, see “Managing Accessories’ in the Kablink Vibe OnPrem 3.1
User Guide.

Discussion Folder: Displays folder entriesin the Discussion folder view.

Entry Creation Date: Displaysthe date and time that an entry was created.

Entry Creator: Displays the creator of an entry.

Entry Creator and Creation Date: Displays who created the entry and when they created it.

Landing Page L ayout: Adds alanding page creation form that enables you to create landing page
elementsto display in your folder.

You must add the Landing Page Layout layout option in the folder form before you can add it asa
view element.

Title: Adds afield that enables you to specify atitle for the workspace.

8.6 Understanding Layout Options

Layout options can enhance the presentation of your folder forms and views in Kablink Vibe.

When you are adding layout options to a form, remember that you need to add that same layout
optionsto the view in order for it to be displayed in the folder.

You can add the following layout options:
Box: Places abox around the specified elements.
Custom JSP: Enables you to reference a custom JSP from the Vibe directory.

Custom JSPs must be created by Vibe administrators before you can reference them, as described in
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 109.

Divider: Displays ahorizontal line between elements.
Expandable Area: Displays an expandable tree element.
Use this option if your form is exceptionally long.
Fieldset: Adds abox that can contain other elements.
HTML: Adds HTML formatting.
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Landing Page L ayout: (For the View Definition, the Landing Page Layout isin the Elements
section) Adds alanding page creation form that enables you to create |anding page elementsthat you
can populate when you modify your workspace.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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Designing Custom Folder Entry
Forms

Folder Entry formsin Kablink Vibe OnPrem can be customized to suit your precise business needs.
You can create your own custom entry forms and views by using the Vibe Form and View Designers
tool, or you can download existing custom entry forms from the Novell Vibe Resource Library.

*

Section 9.1, “Downloading Existing Custom Forms and Workflows,” on page 97
Section 9.2, “ Creating a Custom Folder Entry Form,” on page 97

*

*

Section 9.3, “Modifying an Existing Entry Form,” on page 104
Section 9.4, “Understanding Elements,” on page 105
* Section 9.5, “Understanding Layout Options,” on page 107

*

9.1 Downloading Existing Custom Forms and
Workflows

The Novell Vibe Resource Library provides a collection of existing Kablink Vibe folder entry forms
and workflows that have been designed to solve specific business problems. You can easily

download the custom forms and workflows, then import them into your Vibe environment. You can
further customize these forms and workflows to suit your individual business needs.

1 Gotothe Novell Vibe Resource Library Web site (http://www.novell.com/products/vibe-
onprem/resource-library/).

Click Forms and Workflows.

Select the custom form or workflow that you want to usein your Vibe environment.

In the Attachment section, click the zip file to download it.

ga h~h W N

Import the file into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Resource Library Deployment
Instructions (http://www.novell.com/communities/node/8359/depl oyment-instructions).

9.2 Creating a Custom Folder Entry Form

Kablink Vibe enables you to create custom folder entry forms. For example, you can create acustom
entry form for an expense report.
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To create a new custom workspace, you use the Form and View Desiner to create a view, then you
create a form with the elements and layout options that you want to display in the view. After the
formisin place, you add the same elements and layout options to the view, then you can add
optional view elements to create the final view.

You must have both aform and aview in order to display all the elementsthat you want in a
workspace. The form and the view must have a common set of elements and layout options, but the
view can have some additional elements that are not in the form.

9.2.1 Creating the Folder Entry Form

1 Navigate to the folder or workspace where you want to create the custom entry form.

If you create the entry form in afolder, the form can be applied only to entriesin that folder. If
you create the entry form in aworkspace, the form can be applied to entriesin any folder in the
workspace.

2 If you are creating the entry form at the folder level, click Folder > Form/View Designersin the
Action toolbar.

or

If you are creating the entry form at the workspace level, click Workspace > Form/View
Designersin the Action toolbar.

The Form and View Designers page is displayed.
3 Click New > Entry Definitions.
The Add aNew Definition form is displayed.
4 Specify the following information in the Add a New Definition section:;
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Caption: Specify aname for the folder entry.

Thisisthe namethat appearsin the Vibeinterface. Users seeit when they create an entry of this
type. (For example, “Expense Report.”)

Name: Specify the internal name for the folder entry.

The name that you enter in thisfield is not visible to users who create this type of entry. (For
example, “expense_report.”)

Family: Select the item type that is closest to the function of the item you are creating. Users
can use the family type when performing filtered searches.

Allowed Comments/Reply Types. Select all of the comments or reply types that you want to
alow on the entry.

When users comment on thistype of entry, they can choose from the options that you specify in
this section.

To select multiple options, hold the Ctrl key while selecting the comment or reply types.
5 Click OK.
6 Continue with Section 9.2.2, “ Adding Elements to the Entry Form Definition,” on page 99.

9.2.2 Adding Elements to the Entry Form Definition

The entry form iswhat users see when they are creating a new entry. This form needs to contain all
of the fields necessary for users to create this type of entry. For example, an Expense Report form
needs to contain the expense code, the purpose for the expense, the cost of the expense, and so forth.

After you add elements and layout options to the entry form, you must then add all of the elements
and layout optionsto the entry view in order for them to be displayed when users view the entry.
(For information on how to add elements to the entry view, see Section 9.2.3, “ Adding Elementsto
the Entry View Definition,” on page 101.)

To add elements to the form:

1 Under the custom entry form that you created, expand Entry Form Definition, then expand
Form.

All of the elements and layout options that are currently applied to your form are displayed.
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2 Add, modify, and delete the desired elements and layout options, as described in the following
sections:

+ “Adding Elementsto a Form” on page 100

+ “Modifying Elementsin a Form” on page 100

+ “Deleting Elementsin aForm” on page 100

*

“Adding Layout Optionsto a Form” on page 101

Based on the maodifications that you make to aform element or option, you might need to make the
same modifications to the corresponding view element or option.

Adding Elements to a Form

1 Click Form.
2 Inthe Form window, on the right side of the page, click Add.
3 Inthe Sandard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 9.4.1, “Entry Form
Elements,” on page 105.

4 Specify the appropriate information to configure the element.
5 Click OK.

Modifying Elements in a Form

1 Expand Form, then click the element that you want to modify.
2 Inthewindow on the right side of the page, click Modify.
3 Make the desired modifications, such as changing the caption or data name, then click OK.

Deleting Elements in a Form

1 Expand Form, then click the element that you want to delete.
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2 Inthewindow on theright side of the page, click Delete.
3 Click OK.

Adding Layout Options to a Form

1 Click Form.
2 Inthe Form window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.5,
“Understanding Layout Options,” on page 107.

4 Specify the appropriate information to configure the element.
5 Click OK.

9.2.3 Adding Elements to the Entry View Definition

The entry view is how the information from your entry form is displayed to users who view your
entry. Every form must have a corresponding view. This view needs to contain all of the fields
necessary for usersto get the information they need when viewing the entry; it is made up of
elements from the form.

Before you can add elements and layout options to the entry view, you must first add those same

elements and layout options to the entry form in order for them to be displayed in your entry. (For
information on how to add features to the entry form, see Section 9.2.2, “Adding Elements to the
Entry Form Definition,” on page 99.)

To add elements to the view:

1 Under the custom entry form that you created, expand Entry View Definition.
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2 Add, modify, and delete the desired elements and layout options, as described in the following
sections:

+ “Adding Elementsto an Entry View Definition” on page 102

+ “Modifying Elementsin an Entry View Definition” on page 102

+ “Deleting Elementsin an Entry View Definition” on page 102

+ “Adding Layout Optionsto an Entry View Definition” on page 103

Adding Elements to an Entry View Definition

1 Click Entry View Definition.
2 Inthe Entry View Definition window, on the right side of the page, click Add.
3 Inthe Sandard Form Elements section, click the element that you want to add.

For information on the types of elements that you can add, see Section 9.4.2, “Entry View
Elements,” on page 107.

4 Specify the appropriate information to configure the element.
5 Click OK.

Modifying Elements in an Entry View Definition

1 Expand Entry View Definition, then click the element that you want to modify.
2 Inthewindow on theright side of the page, click Modify.
3 Make the desired modifications, then click OK.

Deleting Elements in an Entry View Definition

1 Expand Entry View Definition, then click the element that you want to delete.
2 Inthewindow on theright side of the page, click Delete.
3 Click OK.
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Adding Layout Options to an Entry View Definition

1 Click Entry View Definition.
2 Inthe Entry View Definition window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.5,
“Understanding Layout Options,” on page 107.

4 Specify the appropriate information to configure the element.
5 Click OK.

9.2.4 Adding Elements to the Summary View

The summary view is used to display entriesin afolder before the entries are opened.
To add elements to the summary view:

1 Under the custom entry form that you created, expand Summary View.

" O YIEeWwW LIE [

Marketing
Designer >> Expense Report (expense_report)

(2] Title - Title

Description - Descrigtion

Enitry wWarkflowe - Ertry Wiork flos
Attachments - Attachments
Comments - Comments

2 Add, modify, and delete the desired elements and layout options, as described in the following
sections:

+ “Adding Elementsto a Summary View” on page 103

+ “Modifying Elementsin an Summary View Definition” on page 104

+ “Deleting Elementsin an Summary View Definition” on page 104

+ “Adding Layout Optionsto a Summary View” on page 104

Adding Elements to a Summary View

1 Click Summary View.
2 Inthe Summary View window, on the right side of the page, click Add.
3 Inthe Sandard Form Elements section, click the element that you want to add.
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For information on the types of elements that you can add, see Section 9.4.2, “Entry View
Elements,” on page 107.

4 Specify the appropriate information to configure the element.
5 Click OK.

Modifying Elements in an Summary View Definition

1 Expand Summary View, then click the element that you want to modify.
2 Inthewindow on the right side of the page, click Modify.
3 Make the desired modifications, then click OK.

Deleting Elements in an Summary View Definition

1 Expand Summary View, then click the element that you want to delete.
2 Inthewindow on theright side of the page, click Delete.
3 Click OK.

Adding Layout Options to a Summary View

1 Click Summary View.
2 Inthe Summary View window, on the right side of the page, click Add.
3 Inthe Layout Options section, click the layout option that you want to add.

For information on the types of layout options that you can add, see Section 9.5,
“Understanding Layout Options,” on page 107.

4 Specify the appropriate information to configure the element.
5 Click OK.

9.3 Modifying an Existing Entry Form

1 Navigate to the folder or workspace where the custom folder entry was created.

2 If thefolder entry was created at the folder level, click Folder > Form/Miew Designersin the
Action toolbar.

or

If the folder entry was created at the at the workspace level, click Workspace > Form/View
Designersin the Action toolbar.

The Form and View Designers page is displayed.
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3 Expand Entry Definitions, then click the custom entry that you want to modify.
4 Continue with Section 9.2.2, “ Adding Elements to the Entry Form Definition,” on page 99.

9.4 Understanding Elements

Elements make up the content of your forms and views.

When you are adding elements, remember that when you add an element to aform, you need to add
that same element to the view in order for it to be displayed in the custom form.

You can add the following elements:

* Section 9.4.1, “Entry Form Elements,” on page 105
* Section 9.4.2, “Entry View Elements,” on page 107

9.4.1 Entry Form Elements

Cancel Button: Addsthe Cancel button.
Checkbox: Adds a check box that can be selected and desel ected.
Date: Addsafield that launches a calendar applet when users click inside it.

Date and Time: Addstwo fields. Thefirst field launches a calendar applet, and the second field
launches a time-sel ection applet when users click inside.

E-Mail AddressList: Adds afield that enables you to specify e-mail addresses.
Event: Addsfields that enable usersto specify the start time and end time of an event.
File Upload: Adds afield that enables users to browse for and upload files.

Form: This element isfor internal use and is required on the entry form.

Form Buttons; Adds the OK and Cancel buttons.
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Group List: Adds atype-to-find field that enables users to find and select Vibe groups.

Guest User Name: Adds afield where users who arelogged in to the Vibe site as Guest can specify
their name. Thisfield is displayed on the entry form only when the Guest user is viewing the form.

HTML Editor Text Area: Addsan HTML text area where users can compose messages, create
links, upload pictures, and more.

Hidden Field: Addsahidden element. When you design the custom form, you can use this element
to add boilerplate text to every entry that is created. Thistext is“hidden” because it does not appear
on the entry form when users are creating an entry; however, the text does appear on the entry view
after the entry is created.

I con: Enables the workspace owner to choose an icon to represent the workspace.

Number: Adds afield that requires users to enter a number. Alphabetic characters are rejected.
Picture: Adds afield that enables users to browse for and upload pictures.

Places: Adds aworkspace tree that enables users to browse to and select folders.

Radio Buttons: Enables you to display options that users can select with radio buttons.
Remote Application: Enables you to choose a remote application to display.

Remote applications must be created and enabled for use by the Vibe administrator.

Selectbox: Enables you to display options that users can select.

Send E-Mail When Entry is Submitted: Adds an option that enables users to automatically send
an e-mail to other Vibe users, after the entry is submitted.

Show Only When In Workflow Sates: Enables you to hide elements from being displayed on the
entry form unless the entry isin a designated state of aworkflow.

Subscribeto This Entry: Adds an option that enables users to subscribe to the entry.
Survey: Adds options that enable users to create a survey.

Team List: Adds afield that enables usersto specify teams.

Text: Adds afield where users can enter text.

Text Area: Adds an expandable field where users can enter text.

Title: Adds afield where users can enter atitle for the entry.

URL: Add afield that converts any text into a hyperlink.

User List: Adds afield that enables users to use the type-to-find functionality to specify other Vibe
users.

User List Selectbox: Addsalist of users. Thislist istaken from the user e ement that is defined at
thefolder level.

Users External to Vibe: Vibe uses this option internally when synchronizing tasks and calendarsto
another application by using iCal. You should not manually add this element to any form or view.
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For more information about iCal in Vibe, see “ Synchronizing Tasks and Calendars to a Desktop
Application” in the Kablink Vibe OnPrem 3.1 User Guide.

9.4.2 Entry View Elements

Any form element that you create can be added as aview element, if you want it to appear in the
view.

The following elements are specific to views; they cannot be added to aform.
Attachments. Displays all attachments,
Comments: Displays all comments.

Comments and Attachments Tabs: Displays the Comments and Attachments tabs. Also, where
applicable, it displays the Entry History and File Versions tabs.

Description: Displays the entry description.

Entry Creation Date: (Not available with a Summary View) Displays the date that the entry was
created.

Entry Creator: (Not available with a Summary View) Displays who created the entry.

Entry Creator and Creation Date: (Not available with a Summary View) Displays who created
the entry and when they created it.

Entry Workflow: Displays the workflow process, the state of the workflow process, and any
actions to be performed on the workflow.

Remote Application: (Not available with a Summary View) Enables you to add custom
applications that are running on a separate server.

For more information on remote applications, see Chapter 12, “Managing Remote Applications,” on
page 151.

Replies: All repliesto an entry are listed here. You can move this section to another location in the
entry view by moving this element.

Show Only When In Workflow States: Enables you to hide elements from being displayed on the
entry view unlessthe entry isin a designated state of aworkflow.

Title: Displays thetitle of the entry.

9.5 Understanding Layout Options

Layout options can enhance the presentation of your forms and views.

When you are adding layout options, remember that when you add layout options to aform, you
need to add the same layout options to the view in order for it to be displayed in the custom form.

You can add the following layout options:
Box: Places abox around the specified elements.

Custom JSP: Enables you to reference a custom JSP from the Vibe directory.
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Custom JSPs must be created by Vibe administrators before you can reference them, as described in
Chapter 10, “Using Custom JSP Files to Enhance Your Vibe Pages,” on page 109.

Divider: Displays ahorizontal line between elements.

Expandable Area: Displays an expandable tree element.

Use this option if your form is exceptionally long.

Fieldset: Adds abox that can contain other elements.

HTML: AddsHTML formatting.

Three Column Table: Enables you to add elements within a three-column table.

Two Column Table: Enables you to add elements within a two-column table.
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Using Custom JSP Files to
Enhance Your Vibe Pages

Kablink Vibe OnPrem supports the use of custom JavaServer Pages (JSPs) that can help you modify
the behavior of certain areasin your Vibe site. For example, your Vibe administrator might enable a
custom JSP file that enhances the functionality of Vibe landing pages by enabling usersto
participate in asurvey directly from aworkspace landing page.

Before you can leverage the functionality of custom JSP files, your Vibe administrator must first
make the files available. Your Vibe administrator will inform you about the names of the files and
what they can be used for.

Some areas of Vibe, such aslanding pages, enable you to add custom JSP files by default. Other
areas, such as folder and workspace forms and views, first require you to do some additional steps,
as described in the following sections:

+ Section 10.1, “Applying JSP Filesto a Landing Page,” on page 109
+ Section 10.2, “Enabling Vibe Forms and Views to Reference JSP Files,” on page 109

10.1 Applying JSP Files to a Landing Page

Landing pages can enhance the presentation of your workspaces and folders and increase the
accessihility of the information they contain. For more information about landing pages, see
Chapter 6, “ Creating and Managing Landing Pages,” on page 49.

By default, JSP files can be applied to your Kablink Vibe landing page. For information on how to
reference a JSP file from alanding page, see “ Adding a Custom JSP” on page 64.

10.2 Enabling Vibe Forms and Views to
Reference JSP Files

+ Section 10.2.1, “Applying JSP Filesto a Folder Entry Form and View,” on page 109
+ Section 10.2.2, “Applying JSP Filesto a Folder or Workspace View,” on page 110

10.2.1 Applying JSP Files to a Folder Entry Form and View

Folder entry forms are used to add folder entriesto all types of Kablink Vibe folders. Folder entry
views are used to display folder entriesin all types of Vibe folders. You can create your own folder
entry forms and views, or modify existing forms and views. For more information, see Chapter 9,
“Designing Custom Folder Entry Forms,” on page 97.

To enable afolder entry form and view to reference a custom JSP file:

1 Create anew custom folder entry form and view, as described in Section 8.1, “Creating a New
Custom Folder View,” on page 87.

or
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Modify an existing folder entry form and view, as described in Section 9.3, “Modifying an
Existing Entry Form,” on page 104.

Only Vibe administrators have the ability to modify default folder entry forms.

2 Add aJSP layout option and element to the folder entry form, as described in Section 8.1.2,
“Adding Elements to the Folder Add/Modify Form,” on page 88.

o5 ) Boaty sk — 8

E|--- Eritry Form Definition Custom JSP

EI% Form

; Title - Tile Caption

Guest User Mame - Please enter your name and e-mail address {optional)

Description - Description

Attachment(s) - Attachment(s) Dgtaihiame 0
Subzcribe to Thiz Entry - Subscribe to This Entry

Send E-Mail When Entry is Subimitted - Send E-Mail When Entry is Submitted

Form Buttons Custorm Forrm JSP

E]--- Summary Wiew

3 Specify the following information:
Caption: Specify aname for the custom JSP.
Data Name: Specify an internal name for the custom JSP.
Custom Form JSP: Specify the filename of the custom JSP file.

You must obtain this filename from your Vibe administrator. Only your Vibe administrator can
make JSP files available to be used in the Vibe site.

4 Click OK.

10.2.2 Applying JSP Files to a Folder or Workspace View

Vibe enables you to create custom folder and workspace views. Folder and workspace views define
what is displayed on the home page of your folder or workspace. When you create custom folder or
workspace views, you can display optiona features such as remote applications, attachments, and
you can also reference JSP files. For more information, see Chapter 8, “ Creating Custom Folder
Views,” on page 87, and Chapter 7, “ Creating Custom Workspace Views,” on page 77.

To enable afolder or workspace view to reference a custom JSP file:
1 Create anew custom folder or workspace view, as described in Section 7.1, “Creating a New
Custom Workspace View,” on page 77.

or

Modify an existing folder or workspace view, as described in Section 7.2, “Modifying an
Existing Workspace View,” on page 82.

Only Vibe administrators have the ability to modify default folder and workspace views.
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2 Add aJSP layout option and element to the folder or workspace view, as described in
Section 8.1.3, “Adding Elements to the Folder View,” on page 90 or Section 7.1.3, “Adding
Elements to the Workspace View,” on page 80, depending on whether you are working with a
folder or workspace view.

Designer >> Team Workspace (_team_workspace)

E| Wiarkspace AddModity Form

A Custom JSP

Title - Title
Description - Description Caption

Landing Page Layout - Landing Page Layout

E Branding - Branding

. Data Mame
lzan - lzon o

f Attachment(=) - Attachment(s)
E]--- Wiorkspace view

Custom Form JSP

3 Specify the following information:
Caption: Specify aname for the custom JSP.
Data Name: Specify an internal name of the custom JSP.
Custom Form JSP: Specify the filename of the custom JSP file.

You must obtain this filename from your Vibe administrator. Only your Vibe administrator can
make JSP files available to be used in the Vibe site.

4 Click OK.
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Creating and Managing Workflows

Kablink Vibe OnPrem enables you to create custom workflows to streamline important business
processes. Vibe Administrators can create workflows and implement them across the entire site, and
individual folder and workspace owners can create workflows to be used in their respective folders
and workspaces.

After you have created aworkflow, you can perform the management functionsthat are described in
this section. You can enable workflows to automatically start when certain types of entries are
created in the folder, when users comment on or reply to an entry, or you can configure them to be
manually started by users who view the entry.

Examples of workflows include approving documents, ordering supplies, hiring new employees,
requesting paid time off, and getting expense reimbursements.

+ Section 11.1, “Creating a Simple Workflow,” on page 113

+ Section 11.2, “Creating an Advanced Workflow,” on page 120

+ Section 11.3, “Visualy Representing a Workflow,” on page 137

+ Section 11.4, “Adding Access Controls to a Workflow,” on page 138

* Section 11.5, “Downloading Existing Custom Forms and Workflows,” on page 145

+ Section 11.6, “Workflows Included with Vibe,” on page 145

+ Section 11.7, “Enabling Workflows,” on page 146

+ Section 11.8, “Testing A Workflow,” on page 148

+ Section 11.9, “Importing and Exporting a Workflow,” on page 148

11.1 Creating a Simple Workflow

If you have a straightforward business process that you think might benefit from a workflow, you
can create a simple workflow to help automate that process, and you don’t need in-depth workflow
training to do it.

For example, you might want to create a workflow that automates the review process of articles for

the company magazine. To create a simple workflow such as this, complete the following sections:
+ Section 11.1.1, “Creating the Workflow Definition,” on page 113

Section 11.1.2, “ Adding Workflow States,” on page 114

Section 11.1.3, “Adding Workflow Start and End States,” on page 115

Section 11.1.4, “Adding Manual Transitions,” on page 116

Section 11.1.5, “ Sending E-Mail Natifications,” on page 118

Section 11.1.6, “Enabling Your Workflow for Use,” on page 120

*

*

*

*

*

11.1.1 Creating the Workflow Definition

1 Navigate to the workspace or folder where you want to create the workflow.
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You can create workflows at the workspace level or at the folder level. If you create aworkflow
at the workspace level, that workflow can be applied to all sub-folders and sub-workspaces. If
you create aworkflow at the folder level, that workflow can be applied only to that folder, and
to the folder’s sub-folders.

2 If you are creating the workflow at the folder level, click Folder > Form/View Designersin the
Action toolbar.

or

If you are creating the workflow at the workspace level, click Workspace > Form/\View
Designersin the Action toolbar.

The Form and View Designers page is displayed.

3 Inthe Form and View Designers page, click New > Workflow Processes.
The Add aNew Definition form is displayed.

4 Specify the following information:
Caption: Specify aname for the workflow process.

Thisis the name that appearsin the Vibe interface. Users see it when they use this workflow.
(For example, “Article Production.”)

Name: Specify the internal name for the workflow process.

The name that you enter in thisfield is not visible to users who use this workflow. (For
example, “article_production.”)

5 Click OK.
6 Continue with Section 11.1.2, “ Adding Workflow States,” on page 114.

11.1.2 Adding Workflow States

Workflow states are the phases that a workflow goes through as it compl etes the business process.

For example, the Article Production workflow contains five states. Article Composition, Peer
Review, Edit, Manager Approval, Publish.

1 Inthe Designer page, expand the workflow definition that you created in Section 11.1.1,
“Creating the Workflow Definition,” on page 113.

Marketing
Designer >> Article Production (article_production)

Waorkflow Process

2 Click Workflow Process.

3 Click Add.

4 Click Sate.

5 Specify the following information:
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Caption: Specify aname for the workflow state.

Thisis the name that appearsin the Vibe interface. Users see it when they use this workflow.
(For example, “ Article Composition.”)

Name: Specify the internal name for the workflow state.

The name that you enter in thisfield is an internal-use database name. Names for elementsin a
definition must be unique. The first character must be an alphabetic character (a-z, A-Z). For
the rest, you can use a phanumeric characters (a-z, A-Z, 0-9), hyphens (-), and underscores ().

Description: Describe the function of the state.
6 Click OK.
7 Repeat Step 2 through Step 6 to add additional workflow states.

The new states are added to the workflow and appear in the Workflow Preview section at the
bottom part of the window.

For more information on the Workflow Preview section, see Section 11.3, “Visually
Representing a Workflow,” on page 137.

Workflow Preview
Article Production (article_production)

Save Layout

.Anicle Composition

. Feer Review
. Edit

. mManager Approval

. Fublish

8 Continue with Section 11.2.3, “Adding Workflow Start and End States,” on page 122 for
information on how you can define start and end states for your workflow.

11.1.3 Adding Workflow Start and End States

Vibe enables you to add a Start and End state to your workflow. This isimportant, because without
an End state, aworkflow does not officially stop unless you manually stop it. Adding an End state to
aworkflow automatically stops the workflow when it reaches the final state.

1 Click Workflow Process.
2 Inthe Workflow process window, click Modify.
3 Specify the following information:
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Initial Sate: Select the Start state of the workflow process.
End Sate: Select the End (final) state of the workflow process.
You can select multiple End states by holding the Ctrl key while clicking additional states.

Background Actions Will Run in the Context Of: Select either Entry Owner or Folder
Owner.

4 Click OK.

In the Workflow Preview section, the Start state is marked with yellow, and the End stateis
marked with red.

For more information on the Workflow Preview section, see Section 11.3, “Visually
Representing a Workflow,” on page 137.

Workflow Preview
Article Production (article_production)

Save Layout

OAnicIe Composition

. Feer Review
. Edit

. mManager Approval

. Puhlish

5 Continue with Section 11.1.4, “Adding Manual Transitions,” on page 116 for information on
how you can create transitions that move an entry from one workflow state to the next.

11.1.4 Adding Manual Transitions

After you have defined the workflow states, you need to create transitions that move an entry from
one state to the next. The easiest kind of transitions to implement are manual transitions.

Manual transitions provide a drop-down list in the entry that allows the user to choose when to
transition the entry. The workflow creator decides which workflow states the user can select in the
drop-down list.

For example, from the “ Article Composition” state, the workflow creator might allow the user to
transition the entry to either the “ Peer Review” or the “Edit” state.

To create manual transitions from one workflow state to the next workflow state:

1 Expand Workflow Process, then expand the workflow state where you want to transition the
entry from.
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For this example, expand the “ Article Composition” state.

orm and View Designers

Marketing
Designer => Article Production (article_production)

E|--- Article Production (article_production)

State - Peer Reviewy

- (] State - Edi

g [E - Manager Approval
- Publish

Click Transitions, then click Add in the Transitions box in the right section of the Designer
page.
Click Manual Transition.

For information regarding the other transition types avail able, see Section 11.2.4, “Adding
Transitions,” on page 123.

In the To Sate select box, select the next state in the workflow.

Thisisthe state that users will be allowed to transition the entry to.

Click OK.

Repeat Step 2 through Step 5 if you want to alow users to select from multiple states.
Repeat this procedure for all other statesin the workflow.

In the Workflow Preview section, you see a diagram representing all of your workflow states
(circles) and transitions (arrows).

For more information on the Workflow Preview section, see Section 11.3, “ Visually
Representing a Workflow,” on page 137.
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Workflow Preview
Article Production (article_production)

Save Layout
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Edit
Manager Approval
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7 Continue with Section 11.1.5, “ Sending E-Mail Notifications,” on page 118.

11.1.5 Sending E-Mail Notifications

Now that you have added your workflow states and specified how the entry will transition through
those states, you need to set up notifications that inform Vibe users when they need to take action on
the entry as it movesinto a state corresponding with their area of expertise.

For example, Julio composes an article for the company magazine. After he composesthe article, he
transitions the entry to the next workflow state, Peer Review. Anne, Julio’s co-worker, then receives
an e-mail message notifying her that an article is ready for her to review. After Anne reviews the
article, she transitionsit to the next workflow state, Edit, and so forth.

1 Expand the workflow definition, then click the workflow state where you want the notification
to be sent.

For example, click Peer Review.

Click Add.

Click On Entry.

In the On Entry box, click OK.

Click On Entry. (Thisislocated underneath the workflow state where you just created it.)

In the On Entry box, you can select from many options. These are actions that you can choose
to perform when the entry enters this workflow state, such as moving the entry to another
location, copying the entry, or sending notifications. For this basic workflow example, simply
select to send e-mail notifications.

a b~ W N

For information about all of the options that you can choose to perform when an entry enters a
workflow state, see Section 11.2.6, “ Adding On-Entry or On-Exit Events,” on page 129.

6 Click Add > Notifications.
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7 Inthe Notifications box, specify the following information:

Entry Creator: Select thisoption if you want to send a notification to the user who created the
entry.

Team: Select thisoption if you want to send a notification to the entire team.
Users: Specify individual usersto whom you want to send a notification.
Groups: Specify groups to whom you want to send a notification.

Additional E-Mail Addressesto Notify: Specify an e-mail address where you want a
notification to be sent.

Select an Entry Type: Use the drop-down list to select the type of entry that most closely
represents the type of entry that is going through the workflow.

Text to be Put in the Notification Subject Line: Specify the text that you want to appear in
the subject line of the natification that is sent.

For example, peer Review Needed.

You can use certain HTML constructs to provide specific information about the entry that is
transitioning through the workflow. For example, you can populate the Notification Subject
Line with the entry title and who last modified the entry: workflow notification for
{{vibe:title}} from {{vibe:modifiedBy}}.

For more information about all the HTML constructs you can use, see Appendix B, “Using
HTML Markup in Vibe OnPrem,” on page 179.

Append the Entry Title: (Optional) Select this option if you want the entry title to appear
after the text in the subject line.

Text to be Put in the Notification Body: Specify text that you want to appear in the main
body of the e-mail natification. You can also select Append the Entry Body if you want the
main body of the entry to display with the e-mail notification message.

Any text formatting that you use in thisfield needs to be donein the HTML format. Following
are some examples of HTML formatting:

* <i></i>foritalics

*+ <b></b> for bold

* <br> for abreak (return/enter)
* <p></p> for anew paragraph

<a href="www.example.com”></a> for linksto URLS

You can use certain HTML constructs to provide specific information about the entry that is
transitioning through the workflow. For example, you can popul ate the Notification Body with
the name of the user who last modified the entry: This entry was last modified by
{{vibe:modifiedBy}}.

For more information about all the HTML constructs you can use, see Appendix B, “Using
HTML Markup in Vibe OnPrem,” on page 179.

Append the Entry Description: (Optional) Select this option if you want the main body of the
entry to display with the e-mail notification message.

8 Click OK.
9 Repeat this process for every workflow state that needs an e-mail notification message.
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11.1.6 Enabling Your Workflow for Use

Now that you have created your workflow, you need to enable it. For information on how to do this,
see Section 11.7, “Enabling Workflows,” on page 146.

11.2 Creating an Advanced Workflow

This section expands the workflow design presented in Section 11.1, “ Creating a Simple Workflow,”
on page 113.

For example, you might want to create a workflow that automates the expense reporting process for
your department.

Figure 11-1 Advanced Workflow Example

Submit Expense Report .
Meeds Attention

Finance Department
Report Processed

. Statistics Department

. Records Department

To create this and other advanced workflows, complete the following sections:

+ Section 11.2.1, “Creating the Workflow Definition,” on page 120

+ Section 11.2.2, “ Adding Workflow States,” on page 121

* Section 11.2.3, “Adding Workflow Start and End States,” on page 122
+ Section 11.2.4, “Adding Transitions,” on page 123

+ Section 11.2.5, “ Setting Up Transition Types,” on page 125

+ Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 129

+ Section 11.2.7, “ Setting Up On-Entry and On-Exit Events,” on page 130
+ Section 11.2.8, “Adding a Parallel Workflow Thread,” on page 132

+ Section 11.2.9, “Chaining Workflows,” on page 133

+ Section 11.2.10, “Adding a Question to a Workflow,” on page 133

+ Section 11.2.11, “Enabling Your Workflow for Use,” on page 137

11.2.1 Creating the Workflow Definition

1 Navigate to the workspace or folder where you want to create the workflow.
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You can create workflows at the workspace level or at the folder level. If you create aworkflow
at the workspace level, that workflow can be applied to any folder or workspace included in the
workspace. If you create a workflow at the folder level, that workflow can be applied only to
that folder, and to the folder’s sub-folders.

2 If you are creating the workflow at the folder level, click Folder > Form/View Designersin the
Action toolbar.

or

If you are creating the workflow at the workspace level, click Workspace > Form/\View
Designersin the Action toolbar.

The Form and View Designers page is displayed.

3 Inthe Form and View Designers page, click New > Workflow Processes.
The Add aNew Definition form is displayed.

4 Specify the following information:
Caption: Specify aname for the workflow process.

Thisis the name that appearsin the Vibe interface. Users see it when they use this workflow.
(For example, “ Expense Report Workflow.”)

Name: Specify the internal name for the workflow process.

The name that you enter in thisfield is not visible to users who use this workflow. (For
example, “expense _report_ workflow.”)

5 Click OK.

6 After you define aworkflow, you need to add states to your workflow. For information on how
to do this, continue with Section 11.2.2, “ Adding Workflow States,” on page 121.

11.2.2 Adding Workflow States

Workflow states are the phases that a workflow goes through as it compl etes the business process.

For example, the Expense Report workflow contains six states: Submit Expense Report, Finance
Department, Needs Attention, Report Processed, Statistics Department, and Records Department.

1 Inthe Designer page, expand the workflow definition that you created in Section 11.2.1,
“Creating the Workflow Definition,” on page 120.

Marketing
Designer >> Expense Report Workflow (expense_report_workflow)

2 Click Workflow Process.
3 Click Add.
4 Click Sate.
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5 Specify the following information:
Caption: Specify aname for the workflow state.

Thisis the name that appearsin the Vibe interface. Users see it when they use this workflow.
(For example, “ Article Composition.”)

You can use a phanumeric characters (a-z, A-Z, 0-9), dashes (-), underscores (_), and spaces.
Name: Specify the internal name for the workflow state.

The name that you enter in thisfield is an internal-use database name. Names for elementsin a
definition must be unique. The first character must be an alphabetic character (a-z, A-Z). For
the rest, you can use al phanumeric characters (a-z, A-Z, 0-9), hyphens (-), and underscores ().

Description: Describe the function of the state.
6 Click OK.
7 Repeat Step 2 through Step 6 to add additional workflow states.

The new states are added to the workflow and appear in the Workflow Preview section located
in the bottom part of the window.

For more information on the Workflow Preview section, see Section 11.3, “ Visually
Representing a Workflow,” on page 137.

. Submit Expense Repart
. Meads Attention
. Finance Department

. Report Processed
. Statistics Department

. Records Department

8 After you have added states to your workflow, you need to define the Start and End states. For
information on how to do this, see Section 11.2.3, “ Adding Workflow Start and End States,” on
page 122.

11.2.3 Adding Workflow Start and End States

Vibe enables you to add Start and End states to your workflow. Thisisimportant, because without
an End state, aworkflow does not officially stop unless you manually stop it. Adding an End state to
aworkflow automatically stops the workflow when it reaches the final state.

1 Click Workflow Process.
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2 Inthe Workflow process window, click Modify.
3 Specify the following information:
Initial State: Select the Start state of the workflow process.
End Sate: Select the End (final) state of the workflow process.
You can select multiple End states by holding the Ctrl key while clicking additional states.

Background Actions Will Run in the Context Of: Select either Entry Owner or Folder
Owner.

4 Click OK.

In the Workflow Preview section, Start states are marked with yellow, and End states are
marked with red.

For more information on the Workflow Preview section, see Section 11.3, “ Visually
Representing a Workflow,” on page 137.

O Suhmit Expense Repart
. Meeds Attention
. Finance Department

. Feport Processed
. Statistics Department

. Recards Department

5 Continue with Section 11.2.4, “Adding Transitions,” on page 123 for information on how to
create transitions that move an entry from one state to the next.

11.2.4 Adding Transitions

After you have defined the workflow states, you need to create transitions that move an entry from
one workflow state to the next.

1 Expand Workflow Process, then expand the workflow state that you want to transition the entry
from.

For this example, expand the “ Submit Expense Report” state.
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Marketing
Designer >> Expense Report Workflow (expense_report_workflow)

E|--- Expenze Report Workflow (expense_report _warkflow)

Tranzitions
State - Statistics Department
| State - Records Department
| State - Finance Department
| State - Report Processed
E] State - Needs Attertion

2 Click Transitions, then click Add in the Transitions box in the right section of the Designer
page.
3 Click thetype of transition that you want to add.

Custom Transition: Usethistransition if you want to integrate an external process with a Vibe
workflow. To do this, consult with your Vibe administrator.

For example, you might want to synchronize a Vibe workflow with an external workflow. You
can write some custom Java code and use a custom transition to accomplish this.

Immediate Transition: The entry isimmediately transitioned.

Manual Transition: Provides adrop-down list in the entry that allows the user to choose when
to transition the entry. The workflow creator decides which workflow states the user can select
in the drop-down list.

Transition After Time Elapsed: The entry is transitioned to the next workflow state after a
specified amount of time.

Transition on Comment or Reply: The entry istransitioned to the next workflow state after a
user makes acomment or areply on the entry.

Transition on Entry Data Values: The entry istransitioned to a new state based on the value
that a user specifies for acustom element in the entry.

For example:

+ |f you want to assign an entry to a specific state based on a value the user selects, you
define a custom element with multiple values from which a user can make a selection
(from adrop-down list on the form). Map each of these values to specific states in the
initial workflow state by using the Transition on Entry Data Values option. Thisoption is
useful for assigning help ticketsin a help desk, assigning entries to the appropriate review
contact, and so on.

+ |f you want to transition an entry at a specific time, you can transition the entry based on a
custom date element.

Transition on Modify: The entry istransitioned to a new state when it is modified.
This can be useful for review purposes.

Transition on Response: Allows you to transition an entry to a new state based on a response
to aquestion in the entry. Map each possible answer to aworkflow question to one of these
transitions by using the Data name for each Wor kflow response.

For specific instructions on how to do this, see Section 11.2.10, “Adding a Question to a
Workflow,” on page 133.
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Transition on a Variable: You can make decisions based on the value of avariable that you
set. For example, you could have aprocessthat sends e-mail notifications when it enters a state.
The process re-enters that same state later in the process, but you do not want to send the
notifications more than once. Set up that first state so that it sends notifications only if the “sent
notifications” variable is not true.

Wait for Parallel Thread(s) to End: Allowsyou to transition an entry to a new state when
one or more specified parallel workflow threads end.

4 Specify setup options.

After you select atransition type in Step 3, you must set up the transition. Each transition type
requires you to specify different setup options.

For specific information regarding the information that you need to specify for the individual
fields, see “ Setting Up Transition Types’ on page 125.

5 Click OK.
6 Repeat Step 1 through Step 5 for all other statesin the workflow.

In the Workflow Preview section, you see a diagram representing all of your workflow states
(circles) and transitions (arrows).

For more information on the Workflow Preview section, see Section 11.3, “Visually
Representing a Workflow,” on page 137.

Submit Expense Report .
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7 After you have set up how entries transition from one workflow state to another in your
workflow, you can set up events to occur when the entry enters or exits particular workflow
states. For information on how to do this, aswell as the kinds of entry and exit events that you
can set up, see Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 129.

11.2.5 Setting Up Transition Types

When you choose a specific type of transition, you might need to provide specific information
regarding the type of transition that you selected.

Following are the types of transitions that you can choose from, and information describing the
fields that you must complete in order to set up each type of transition:

+ “Custom Transition” on page 126
+ “Immediate Transition” on page 126
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+ “Manual Transition” on page 126

+ “Transition After Time Elapsed” on page 126

+ “Transition on Comment or Reply” on page 127
+ “Transition on Entry Data Values’ on page 127

+ “Transition on Modify” on page 127

+ “Transition on Response” on page 127

+ “Transition on a Variable” on page 128

+ “Wait for Paralel Thread(s) to End” on page 129

Custom Transition

After you begin creating the Custom Transition as described in Section 11.2.4, “Adding
Transitions,” on page 123, you see the following options:

Condition Class Name: Specify the Java filename where your Vibe administrator created the
custom transition.

Consult with your Vibe administrator to get the name of thisfile.

To State: Select the state where you want to transition the entry.

Immediate Transition

After you begin creating the Immediate Transition as described in Section 11.2.4, “Adding
Transitions,” on page 123, you see the following options:

To Sate: Select the state where you want to immediately transition the entry.

Manual Transition

After you begin creating the Manual Transition as described in Section 11.2.4, “ Adding
Transitions,” on page 123, you see the following options:

To State: Select the state where you want to allow users to transition the entry.

After you create the transition, repeat Step 2 on page 124 through Step 5 on page 125 if you want to
allow users to select from multiple states.

You can set access controls on the manual transition to allow only certain users to transition the
entry. If you do not set any access controls, the default isto allow all users who have Write access to
the entry to transition the entry. For more information about how to set access controls on the
manual transition, see Section 11.4.3, “ Setting Access Controls on a Manual Transition,” on

page 143.

Transition After Time Elapsed

After you begin creating the Transition After Time Elapsed transition as described in Section 11.2.4,
“Adding Transitions,” on page 123, you see the following options:

Numbers entered in the following fields must be whole values. Decimal points and fractions are not
valid.

Days: Specify how many daysto wait before the transition.
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Hours: Specify how many hoursto wait before the transition.

Minutes: Specify how many minutes to wait before the transition.

To Sate: Select the state where you want to transition the entry after the elapsed time that you
specified.

Transition on Comment or Reply

After you begin creating the Transition on Comment or Reply transition as described in
Section 11.2.4, “Adding Transitions,” on page 123, you see the following options:

To State: Select the state where you want to transition the entry after a user comments on or replies
to the entry.

Transition on Entry Data Values

After you begin creating the Transition on Entry Data Values transition as described in
Section 11.2.4, “Adding Transitions,” on page 123, you see the following options:

Match Entry Data Values: Select Match Any if only one condition must be met for the entry to
transition. Select Match All if all conditions must be met before the entry transitions.

To State: Select the state where you want to transition the entry.

Transition on Modify

After you begin creating the Transition on Modify transition as described in Section 11.2.4, “ Adding
Transitions,” on page 123, you see the following options:

To State: Select the state where you want to transition the entry when the entry is modified.

When you are working with a File entry, modifications made to the file also cause the workflow to
be transitioned. Modifications to a file include setting the status of the file, incrementing the major
version, editing the file note, reverting to a previous version, and deleting the file. For more
information about working with File entries, see “Working with Filesin a Folder Entry” in the
Kablink Vibe OnPrem 3.1 User Guide

Transition on Response

After you begin creating the Transition on Response transition as described in Section 11.2.4,
“Adding Transitions,” on page 123, you see the following options:

Workflow Question: Specify the Data Name for the workflow question that you have previously
defined.

For information on how to create a workflow question, see “Creating a Workflow Question” on
page 134.

Wor kflow Response: Specify the Data Name for the workflow response that you have previously
defined.

For information on how to create a workflow response, see “ Creating Answers to a Workflow
Question” on page 135.
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To Sate: Select the state where you want to transition the entry after a user responds to the
workflow question.

The Transition Occurs When:

+ As Soon As One Person Answers With This Response: Transitions the entry immediately
after one person responds to the workflow question with the value that is in the Workflow
Response field in the Transition on Response dialog box.

+ AsSoon AsA Majority Have Answered With This Response: Transitions the entry
immediately after amajority of people respond to the workflow question with the value that is
in the Workflow Response field in the Transition on Response dialog box.

+ After Everyone Has Responded and All Have Answered With This Response: Transitions
the entry after all responders have responded to the workflow question and all people respond
with the value that isin the Workflow Response field in the Transition on Response dialog box.

+ After Everyone Has Responded and Somebody Answered With This Response:

Transitions the entry after all responders have responded to the workflow question and at |east
one person responds with the value that is in the Workflow Response field in the Transition on
Response dial og box.

+ After Everyone Has Responded and Not All Have Answered With This Response:

Transitions the entry after all responders have responded to the workflow question and at |east
one person responds with avalue that is not in the Workflow Response field in the Transition on
Response dialog box.

+ After Everyone Has Responded and a Majority Answered With This Response:

Transitions the entry after al responders have responded to the workflow question and the
majority of people respond with the value that isin the Workflow Response field in the
Transition on Response dialog box.

For more information about how to designate specific users to respond to the question, see
“Designating Specific Users to Respond to a Workflow Question” on page 135
Transition on a Variable

After you begin creating the Transition on a Variable transition as described in Section 11.2.4,
“Adding Transitions,” on page 123, you see the following options:

Variable Name: Specify the name of the workflow variable that you want to be read to activate the
transition.

You must have aready created aworkflow variable. You create aworkflow variable as an On Entry
or On Exit event, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on
page 129.

Variable Value: Specify the value of the workflow variable that you want to be read to activate the
transition.

You must have already created aworkflow variable. You create aworkflow variable as an On Entry
or On Exit event, as described in Section 11.2.6, “ Adding On-Entry or On-Exit Events,” on
page 129.

To State: Select the state where you want to transition the entry.
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Wait for Parallel Thread(s) to End

After you begin creating the Wait for Parallel Thread(s) to End transition as described in
Section 11.2.4, “ Adding Transitions,” on page 123, you see the following options:

Parallel Thread Name: Select the parallel thread that you want to wait for.

Transition to Sate: Select the state where you want to transition the entry after all selected threads
have ended.

11.2.6 Adding On-Entry or On-Exit Events

You can take action when a process enters or exits aworkflow state. For example, when an entry
enters (or exits) aworkflow state, you can send a notification, begin or end aparallel process, set a
variable, and more.

1 Navigate to and click the workflow state where you want to set up an event to occur when the
entry enters or exits the state.

2 Click Add.

3 Click On Entry or On Exit, depending on whether you want the event to occur when the entry
enters or exits the state.

4 Inthe On Entry (or On Exit) box, click OK.

5 Click On Entry or On Exit, depending on whether you are adding an On Entry or On Exit event.
(Thisislocated underneath the workflow state where you just created it.)

6 Click Add.
7 Click the type of event that you want to add.

Copy Entry: Allows you to copy an entry to anew location in Vibe when it enters or exits a
specific state.

Custom Action: Use the custom action if you want to integrate an external process (usually
contained within a JAR file) with a Vibe workflow. To do this, consult with your Vibe
administrator.

For more information about how Vibe administrators can enable JAR files to be used as custom
workflow actions, see “ Enabling Custom JAR Filesto Be Used on Your Vibe Site” in the
Kablink Vibe OnPrem 3.1 Administration Guide.

Move Entry: Allows you to move an entry to anew location in Vibe when it enters or exitsa
specific state.

Notifications: Allows you to notify specific users or groups about an entry when it enters or
exits the state.

Remote Application: Remote applications communicate with a third-party online application,
and send information from that third-party application back into Vibe. You can enable aremote
application to start when entries enter or exit aworkflow state.

Remote applications need to be set up and configured by your Vibe administrator before you
can add them.

Sart aParallel Workflow Thread: Allows you to start aparalel workflow when an entry
enters or exits a specific state. Parallel workflows are useful if two or more processes need to
occur simultaneously. Only when the paralel thread is finished can the main workflow thread
proceed.
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Before you can start a parallel workflow thread, you first need to createit. For information on
how to create a parallel workflow thread, see Section 11.2.8, “ Adding a Parallel Workflow
Thread,” on page 132.

Sart a Workflow Process: Vibe enables you to chain workflows together. When you are
creating aworkflow (or modifying an existing workflow), you can start an existing workflow
process on the workflow you are creating (or modifying). This can speed up the workflow
creation process by helping you make use of existing workflows.

Starting an existing workflow process is not the same as starting a parallel workflow thread.
Unlike a parallel workflow thread, when you chain workflows together by starting an existing
workflow process, thereis no way to share variables or states between the two workflows; in
other words, thereis no physical connection between the two workflows.

Sop a Workflow Thread: Allows you to stop aparallel workflow when an entry enters or
exits a specific state.

Workflow Variable: Defines avariable to be used when transitioning a workflow.

Thisworkflow variable is referenced with the Transition On a Variable transition, as described
in Section 11.2.4, “Adding Transitions,” on page 123.

Set up the event you selected in Step 7. Each event type requires you to specify different setup
options.

For information on what to specify for the individual fields, see Section 11.2.7, “ Setting Up
On-Entry and On-Exit Events,” on page 130.

Click OK.

Repeat this procedure for all other states in the workflow where you want to set up on-entry or
on-exit events.

Set up access controls on the workflow. For information on how to do this, see Section 11.4,
“Adding Access Controls to a Workflow,” on page 138.

11.2.7 Setting Up On-Entry and On-Exit Events

After you add an event to aworkflow, you need to provide information to set up the event.

*

*

*

“Copy Entry” on page 130

“Custom Action” on page 131

“Move Entry” on page 131

“Notifications’ on page 131

“Remote Applications’ on page 132

“Start a Parallel Workflow Thread” on page 132
“Start a Workflow Process’ on page 132

“Stop a Workflow Thread” on page 132
“Workflow Variable’ on page 132

Copy Entry

Select the Destination Folder: Select the folder where you want to copy the entry to.

Selected Folder: Displays the destination folder that you selected.
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Custom Action
Action Class Name: Specify the name of the custom action that your Vibe administrator has set up.
Work with your Vibe administrator for information on what you should put in thisfield.

For more information about how Vibe administrators can enable JAR files to be used as custom
workflow actions, see “Enabling Custom JAR Filesto Be Used on Your Vibe Site” in the Kablink
Vibe OnPrem 3.1 Administration Guide.

Move Entry
Select the Destination Folder: Select the folder where you want to move the entry to.

Selected Folder: Displays the destination folder that you selected.

Notifications

Entry Creator: Select this option if you want to send a notification to the user who created the
entry.

Team: Select thisoption if you want to send a notification to the entire team.
Users: Specify individual usersto whom you want to send a notification.
Groups: Specify groups to whom you want to send a notification.

Select an Entry Type: Use the drop-down list to select the type of entry that most closely
represents the type of entry that is going through the workflow.

Text to be Put in the Notification Subject Line: Specify the text that you want to appear in the
subject line of the notification that is sent.

For example, peer Review Needed.

Append the Entry Title: (Optional) Select this option if you want the entry title to appear after the
text in the subject line.

Text to be Put in the Notification Body: Specify text that you want to appear in the main body of
the e-mail notification. You can also select Append the Entry Body if you want the main body of the
entry to display with the e-mail notification message.

Any text formatting that you use in this field needs to be donein the HTML format. Following are
some examples of HTML formatting:

* <i></i>foritalics

* <b></b> for bold

+ <br> for abreak (return/enter)
* <p></p> for anew paragraph

<a href="www.example.com”></a> for linksto URLS

Append the Entry Body: (Optional) Select this option if you want the main body of the entry to
display with the e-mail notification message.
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Remote Applications
Remote Application: From the drop-down list, select the remote application.

Remote applications need to be set up and enabled by your Vibe administrator before you can use
them. For more information about remote applications, see Chapter 12, “Managing Remote
Applications,” on page 151.

Variable Name: Specify the name of the variable to contain the results that are returned by the
remote application.

Execute Action in the Context Of: Select who you want the remote application to be in relation to:
Active User, Entry Owner, or Folder Owner.

Start a Parallel Workflow Thread
Parallel Thread Name: Select the parallel workflow thread that you want to start.
You must have already created the parallel workflow thread in order for it to be displayed in thislist.

For information on how to create a parallel workflow thread, see Section 11.2.8, “ Adding a Parallel
Workflow Thread,” on page 132.

Start a Workflow Process

Wor kflow Process: From the drop-down list, select the workflow process that you want to start.

Stop a Workflow Thread
Parallel Thread Name: Select the workflow thread that you want to stop.

Workflow Variable
Variable Value: Specify the name of the workflow variable.

Variable Name: Specify the value of the workflow variable. Thisisthe namethat is referenced
internally.

11.2.8 Adding a Parallel Workflow Thread

Vibe workflows support parallel workflow threads, which enable you to start a second workflow
inside of an existing workflow. Parallel workflows are useful if two or more processes need to occur
simultaneously. The main workflow is dependent on the parallel workflow thread; only when the
parallel thread is finished can the main workflow thread proceed.

To create a parallel workflow thread:

1 Click Workflow Process.
2 Click Add > Parallel Workflow Thread.
3 Specify the following information:
Caption: Specify aname for the parallel workflow thread.

Thisis the name that appearsin the Vibe interface, that users see when they use this workflow
thread.
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Data Name: Specify theinternal name for the parallel workflow thread.
The name that you enter in thisfield is not visible to users who use this workflow thread.
Sart Sate: Select the first state in the parallel workflow thread.
End Sate: Select the last state in the parallel workflow thread.
4 Click OK.
The parallel workflow thread is created.

For information on how to start and stop a parallel workflow thread after you have created it, see
Section 11.2.6, “Adding On-Entry or On-Exit Events,” on page 129.

11.2.9 Chaining Workflows

Vibe enables you to chain workflows together by starting a workflow process inside of aworkflow
that you are creating (or modifying). This can speed up the workflow creation process by helping
you make use of existing workflows.

Starting an existing workflow process is not the same as starting a parallel workflow thread. Unlike
aparallel workflow thread, when you chain workflows together by starting an existing workflow
process, there is no way to share variables or states between the two workflows; in other words,
thereis no physical connection between the two workflows.

You chain workflows by adding an On Entry or On Exit option to the workflow state where you
want to add the existing workflow process. Use the On Entry or On Exit option to add the existing
workflow process, as described in Section 11.2.6, “Adding On-Entry or On-Exit Events,” on

page 129.

11.2.10 Adding a Question to a Workflow

Workflow guestions can enhance the ease and usability of workflows. For example, imagine a Time-
Off Reguest workflow where a manager can respond to a request by simply selecting Yes or No in
the workflow.

In the following example, if the manager selects Yes, the workflow is transferred to the next state of
the workflow, HR Approval. If the manager selects No, the request is denied and the workflow is
ended.
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Figure 11-2 Workflow Question Layout

ey Time-Off Reguest

Manager Fewiew

. Dienied by Manager

. HF Review
. Denied by HR

. Approved by HR

. Tirmne-0ff Approved

+ “Creating a Workflow Question” on page 134

+ “Creating Answers to a Workflow Question” on page 135

+ “Designating Specific Usersto Respond to a Workflow Question” on page 135
+ “Creating Transitions’ on page 136

+ “Setting Access Controls on a Workflow Question” on page 137

Creating a Workflow Question

1 Click the workflow state where you want to add the workflow question.

A workflow guestion can be specific to asingle state (each state can have only one associated
guestion), or you can define aglobal question, which you can then associate with any number
of states. Global questions are useful when multiple states require the same question and
answer set.

2 Click Add > Workflow Question.

3 Specify the following information:
Question Text: Specify the question that you want to appear in the workflow.
For example, Approve time-off request?
Data Name: Specify theinternal name for the workflow question.

This name must be unique because it is the name that you use to refer to the workflow question
in future steps. For example, approve timeoff request.

4 Click OK.
5 Continue with “ Creating Answers to a Workflow Question” on page 135.
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Creating Answers to a Workflow Question

1 Click Workflow Question.
Thisisthe question that you created in “ Creating a Workflow Question” on page 134.

# O YIEeWwW LIE i

Marketing
Designer >> Time Off Request (time_off_request)

State - Mew Time Off Reguest

State - Manager Reviews

State - Denie
[-[E] State - HR Review

State - Denied by HR

E State - Approved by HR
State - Time Off Approved

2 Click Add > Workflow Response.
3 Specify the following information:
Response Text: Specify asingle response option.
For example, ves.
Data Name: Specify theinternal name for the workflow response.
For example, ves.
4 Click OK.
5 Repeat Step 1 through Step 4 to create multiple answers to the same workflow question.
Users using this workflow can choose from the answers that you create.

You can designate specific users are responders to the workflow question, as described in
“Designating Specific Users to Respond to a Workflow Question” on page 135.

Designating Specific Users to Respond to a Workflow Question

When you designate specific users as responders to a workflow question, you can configure the
workflow to transition only after al responders have answered the workflow question, or only after
all responders have answered the workflow question correctly. For more information, see
“Transition on Response” on page 127.

1 Click Workflow Question.
Thisisthe question that you created in “ Creating a Workflow Question” on page 134.
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Marketing
Designer >> Time Off Request (time_off_request)

E|--- Tine Off Reguest (time_off_regueast)
E| Wiarkflowy Process
State - Mew Time Off Request
E| State - Manager Revigw

Transzitionz

- Dienied by Manager
- HR Rewiesy

- Denied by HR

- Approved by HR

- Time Off Approved

2 Click Add > Responders.
The Responders dialog box is displayed.

3 Inthe provided form, specify which users or groups of users you want to specify as responders
to the workflow question:

Folder Default Access. Select this option to specify al users who have access to the folder as
responders.

Entry Creator: Select this option to specify the user who created the entry as a responder.
Team: Select this option to specify the team as responders.

Users: Specify individual usersto whom you want to specify as responders.

Groups: Specify groups to whom you want to specify as resonders.

Select an Entry Type: Select the type of entry that most closely represents the type of entry
that is going through the workflow.

Select Elementswithin the Entry: Enables you to select elements that are contained in the
entry. Users associated with that element are granted access.

For example, if you select Task Entry in the Select an Entry Type drop-down list, the options
that you can select in the Select Elements within the Entry are Assigned to, Assigned to Groups,
Assigned to Teams.

4 Click OK.

Creating Transitions

Now that you have created the workflow question and workflow answers, you need to create
transitions that correspond to the answers that you created. This kind of transition is called
“Transition on Response.”

For information on how to create a“ Transition on Response” transition, see Section 11.2.4, “Adding
Transitions,” on page 123.
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Setting Access Controls on a Workflow Question

If you want to add access controls to this workflow question, you must use the Transition Out of
This State access control setting. For more information, see Section 11.4, “Adding Access Controls
to a Workflow,” on page 138.

11.2.11 Enabling Your Workflow for Use

Now that you have created your workflow, you need to enableit. For information on how to do this,
see Section 11.7, “Enabling Workflows,” on page 146.

11.3 Visually Representing a Workflow

Kablink Vibe enables you to view avisual representation of your workflow, making the creation
process easier by alowing you to envision the workflow in every step of its development.

Asyou create your workflow in the Designer section, the changes you make are automatically added
to the Workflow Preview section below.

Figure 11-3 Wobrkflow Preview Section

Workflow Preview
Expense Report Workflow (expense_report_workflow)

Save Layout

Suhmit Expense Report .
Meeds Aftention

Finance Department

Report Processed

. . Records Department
Statistics Department

You can modify the workflow layout in the Workflow Preview section. You must save the layout
after you have modified it.

+ Section 11.3.1, “Modifying a Workflow Layout,” on page 138
+ Section 11.3.2, “Saving a Workflow Layout,” on page 138
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11.3.1 Modifying a Workflow Layout

You can easily modify the visual representation of aworkflow. Modifying the workflow layout can
make it easier to understand how aworkflow process works because it can enable you to better
visualize the process.

1 Inthe Workflow Preview section, click aworkflow state and drag the state to the desired
|ocation.

Transition arrows automatically adjust to the new locations of the workflow states.

11.3.2 Saving a Workflow Layout

By default, every time you make a change in the Designer section when you create aworkflow, any
changes that you previously made in the Workflow Preview section are reverted to the state when
you last saved.

To save your layout in the Workflow Preview section:

1 Click Save Layout after you have modified your workflow layout.

Now, when you make changes in the Designer section, the changes that you previously made to
your workflow layout in the Workflow Preview section are retained.

11.4 Adding Access Controls to a Workflow

Kablink Vibe enables you to set access controls on workflows that you create. You can set access
controls on an entire workflow, or on the individual states of aworkflow.

+ Section 11.4.1, “ Setting Access Controls on an Entire Workflow,” on page 138
+ Section 11.4.2, “ Setting Access Controls on Individual States of a Workflow,” on page 141
+ Section 11.4.3, “ Setting Access Controls on a Manual Transition,” on page 143

11.4.1 Setting Access Controls on an Entire Workflow

1 Inthe Designer page, expand the workflow definition that you created in Section 11.2.1,
“Creating the Workflow Definition,” on page 120.

0 v B I

Marketing
Designer >> Expense Report Workflow (expense_report_workflow)

E--- Expenze Report Workilow (expense_report_workilow)

2 Click Workflow Process.
3 Click Add > Access controls.
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4 Click OK.
5 Expand Workflow Process, then click Access controls.

Marketing
Designer >> Time Off Request (time_off_request)

E|"- Time Off Reguest (time_off_reguest)
EI Wiorkflowy Process

w1 [E] State - New Time Off Request

State - Manager Review

State - Denied by Manager

State - HR: Review

State - Denied by HR

State - Approved by HR

State - Time Off Approved

T

[

6 Click Add.
7 Click the access control setting that you want to add.

Delete Access: Enables you to grant specific users rights to delete entries as they transition
through the workflow process.

M odify Access. Enables you to grant specific users rights to modify entries as they transition
through the workflow process.

M aodify Specified Fields: Enables you to grant rights to individual users or groups that allow
the specified users or groups to modify specific fields within an entry as the entry transitions
through the workflow.

Read Access: Enables you to grant specific users rights to read entries as they transition
through the workflow process.

Transition Into This Sate: Enables you to grant specific users rights to transition entriesinto
any state in the workflow.

Transition Out of This State: Enables you to grant specific users rights to transition entries
out of any state in the workflow.

Thisisthe access control setting that determines who can see aworkflow question. If you are
adding aworkflow question to your workflow or to an individua state, as described in

Section 11.2.10, “ Adding a Question to a Workflow,” on page 133, and you want to add access
controls to determine who sees the question, you must use this access control setting.

8 Define the access control setting that you added in Step 7 by specifying the following
information in the provided form:
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Modify Access
[C] Folder Default Access
[l Entry Creator

[C] Team

Users and Groups
Users

Feople
Groups

Find Groups

Select an Entry Type
—select an entry type— |z|

—— e e
| oKk N Cancel ]

Folder Default Access. Select this option to grant accessto all users who have access to the
folder.

Entry Creator: Select this option to grant access to the user who created the entry.
Team: Select this option to grant access to the team.

Users: Specify individual usersto whom you want to grant access.

Groups. Specify groups to whom you want to grant access.

Select an Entry Type: Select the type of entry that most closely represents the type of entry
that is going through the workflow.

Select Elementswithin the Entry: Select the fields that are contained within the selected
entry type that you want to allow specific users or groups to modify.

Access control rights can be granted only for the User List, Group List, and List elements. By
default, only calendar entry types and task entry types contain these elements. For Calendars,
thisisthe Attendee, Attendee Groups, and Attendee Teams fields. For tasks, thisis the Assigned
to, Assigned to Groups, and Assigned to Teams fields.

For information about how to add these elements to existing entry types, or how to create your
own custom entry types where you can add these elements, see Chapter 9, “Designing Custom
Folder Entry Forms,” on page 97.

9 Click OK.
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11.4.2 Setting Access Controls on Individual States of a
Workflow

1 Inthe Designer page, expand the workflow definition that you created in Section 11.2.1,
“Creating the Workflow Definition,” on page 120.

2 Expand Workflow Process, then click the state where you want to add the access controls.

0 a L) l

Marketing
Designer >> Time Off Request (time_off_request)

- [2] State - Mew Time Off Request
- [2] Etate - Manager Review!

E State - Denied by Manager
5[] State - HR Review

- (€] State - Denied by HR

=] State - Approved by HR

] State - Time Off Approved

3 Click Add > Access controls.

4 Click OK.

5 Expand the state where you just added the access controls, then click Access controls.
6 Click Add.

7 Click the access control setting that you want to add.

Delete Access: Enables you to grant specific usersrights to del ete entries when they arein this
workflow state.

M odify Access. Enables you to grant specific users rights to modify entries when they arein
thisworkflow state.

M odify Specified Fields: Enables you to grant specific users rights to modify specific fields
within an entry as they transition through the workflow.

Read Access: Enables you to grant specific users rights to read entries when they arein this
workflow state.

Transition Into This Sate: Enables you to grant specific usersrights to transition entriesinto
this state.

This setting is relevant only when a manual transition is defined involving this state.

Transition Out of This State: Enables you to grant specific users rights to transition entries
out of this state.

This setting is relevant only when a manua transition is defined involving this state.
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Close ¥

Modify Access
[C] Folder Default Access
[l Entry Creator

[C] Team

Users and Groups
Users

Feople
Groups

Find Groups

Select an Entry Type
—select an entry type— |z|

] B e -
[ oK N Cancel ]
et R el

8 Define the access control setting that you added in Step 7 by specifying the following
information in the provided form:

Folder Default Access. Select this option to grant access to users who have access to the
folder.

Entry Creator: Select this option to grant access to the user who created the entry.
Team: Select this option to grant access to the team.

Users: Specify individual usersto whom you want to grant access.

Groups: Specify groups to whom you want to grant access.

Select an Entry Type: Select the type of entry that most closely represents the type of entry
that is going through the workflow.

Select Elementswithin the Entry: Select the fields that are contained within the selected
entry type that you want to allow specific users or groups to modify.

Access control rights can be granted only for the User List, Group List, and List elements. By
default, only calendar entry types and task entry types contain these elements. For Calendars,
thisisthe Attendee, Attendee Groups, and Attendee Teams fields. For tasks, thisis the Assigned
to, Assigned to Groups, and Assigned to Teams fields.

For information about how to add these elements to existing entry types, or how to create your
own custom entry types where you can add these elements, see Chapter 9, “Designing Custom
Folder Entry Forms,” on page 97.

9 Click OK.
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11.4.3 Setting Access Controls on a Manual Transition

1 Inthe Designer page, expand the workflow definition that you created in Section 11.2.1,
“Creating the Workflow Definition,” on page 120.

2 Expand Workflow Process, expand the state that contains the manual transition where you want
to set the access controls, expand Transitions, then click Manual Transition.

Form and View Designers

Marketing
Designer >> Article Production (article_production)

E|--- Article Production (article_production)
=[] Workflow Process

|_:_| State - Article Composition

| Transitions

3 Click Add > Manual Transition Access Controls.
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Manual Transition Access Controls
[C] Folder Default Access
] Entry Creator

[ Team

Users and Groups
Users

)

People
Groups

i1

Find Groups

Select an Entry Type
—select an entry type— |Z|

4 Inthe provided form, specify which users or groups of users who you want to grant access to
transition the entry:

Folder Default Access. Select this option to grant access to users who have access to the
folder.

Entry Creator: Select this option to grant access to the user who created the entry.
Team: Select this option to grant access to the team.

Users: Specify individual usersto whom you want to grant access.

Groups. Specify groups to whom you want to grant access.

Select an Entry Type: Select the type of entry that most closely represents the type of entry
that is going through the workflow.

Select Elementswithin the Entry: Select the fields that are contained within the selected
entry type that you want to allow specific users or groups to modify.

Access control rights can be granted only for the User List, Group List, and List elements. By
default, only calendar entry types and task entry types contain these elements. For Calendars,
thisisthe Attendee, Attendee Groups, and Attendee Teams fields. For tasks, thisis the Assigned
to, Assigned to Groups, and Assigned to Teams fields.
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For information about how to add these elements to existing entry types, or how to create your
own custom entry types where you can add these elements, see Chapter 9, “Designing Custom
Folder Entry Forms,” on page 97.

5 Click OK.

11.5 Downloading Existing Custom Forms and
Workflows

The Novell Vibe Resource Library provides a collection of existing Vibe folder entry forms and
workflows that have been designed to solve specific business problems. You can easily download
the custom forms and workflows, then import them into your Vibe environment. You can further
customize these forms and workflows to suit your individual business needs.

1 Navigate to the Novell Vibe Resource Library Web site (http://www.novell.com/products/
teaming/resource-library/).

2 Inthe Forms and Workflows tab, select the custom form or workflow that you want to usein
your Vibe environment.

3 Inthe Attachment section, click the zip file to download it.
4 Import thefile into your Vibe environment and deploy it for use.

For information on how to do this, follow the Novell Vibe Resource Library Deployment
Instructions (http://www.novell.com/communities/node/8359/depl oyment-instructions).

11.6 Workflows Included with Vibe

Kablink Vibe includes three predefined workflows. One is available for you to enable and use; the
others are used within Vibe.

* Section 11.6.1, “Available Workflows,” on page 145
+ Section 11.6.2, “Internal Workflows,” on page 146

11.6.1 Available Workflows

Vibe currently includes the Publish workflow, which is functional as soon as you enableit, as
described in Section 11.7, “Enabling Workflows,” on page 146.

You can use the Publish workflow in the following ways:

Publish Entriesto a Landing Page: You can use the Publish workflow to publish entriesto a
landing page, without manually modifying the contents of the landing page.

For more information, see Section 6.7, “ Automatically Displaying the Newest Folder Entries on
Your Landing Page,” on page 69.

Keep Entries Private: You can use the Publish workflow to keep entries private until you are ready
to publish them for other Vibe usersto read.

For example, you can associate the Publish workflow with a certain entry type in afolder (see
Section 11.7.1, “Enabling Workflows to Start When an Entry Is Created,” on page 147 for more
information). When you create an entry in the folder, the entry is created as Private. When you are
ready for other Vibe usersto view the entry, you can change the workflow status to Publish.
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To transition the workflow status of an entry from Private to Publish:

1 Opentheentry, and in the Transition to field, select Publish in the drop-down list.
2 Click OK.

To make the workflow status of the entry Private again:

1 Open the entry where you want to change the workflow status.

2 Inthe Entry toolbar, click Workflow > Sop Workflow: Publish Workflow, then click OK when
you are asked if you really want to stop the workflow.

3 Inthe Entry toolbar, click Workflow > Sart Workflow: Publish Workflow, then click OK when
you are asked if you really want to start the workflow.

The workflow status of the entry is now Private.

11.6.2 Internal Workflows

Vibe includes two workflows that are used internally.

+ “Task Workflow” on page 146
+ “Calendar Workflow” on page 146

Task Workflow

Vibe uses the Task workflow internally to allow all users who are assigned to a particular task to
make modifications to the task, if they are not members of the workspace where the task resides.

This workflow should not be manually added to any workspace or folder.

Calendar Workflow

Vibe uses the Calendar workflow internally to allow all users who are attendees in an event to make
modifications to the calendar event, if they are not members of the workspace where the event
resides.

This workflow should not be manually added to any workspace or folder.

11.7 Enabling Workflows

After aworkflow is created, you can enable the workflow to automatically start when certain types
of entries are created in the folder, or when users comment on or reply to entries. Or, you can enable
users to manually start workflows when they view the entry.

Before you can enable aworkflow, the workflow must first be created. For information on how to
create a workflow, see either Section 11.1, “Creating a Simple Workflow,” on page 113 or

Section 11.2, “ Creating an Advanced Workflow,” on page 120, depending on the type of workflow
that you want to create.
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You can enable workflows only in folders for which you have appropriate rights. When you enable a
workflow in afolder, it is automatically enabled on all sub-folders and sub-workspaces, and can be
applied to al entries that are created in that folder and its sub-folders.

+ Section 11.7.1, “Enabling Workflows to Start When an Entry |Is Created,” on page 147

* Section 11.7.2, “Enabling Workflows to Start When Users Comment on or Reply to an Entry,”
on page 147

¢ Section 11.7.3, “ Allowing Users to Manually Start Workflows,” on page 148

11.7.1 Enabling Workflows to Start When an Entry Is Created

You can enable aworkflow to automatically start on all entries that are created in a specific folder,
whenever an entry is created. Thisis called “associating workflows with entries.”
1 Navigate to the folder where you want to enable the workflow.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Workflows Associations section, in the Entry Types section, click the drop-down list next
to the entry type that you want to associate the workflow with, then select the desired
workflow.

To add workflows to this drop-down list, you need to create them. After workflows have been
created at thisfolder level, or at a higher workspace level, they appear in thislist. For
information on how to create workflows, see either Section 11.1, “Creating a Simple
Workflow,” on page 113 or Section 11.2, “Creating an Advanced Workflow,” on page 120,
depending on the type of workflow that you want to create.

4 Click Apply > Close.
Now, when thistype of entry is created in thisfolder, Vibe automatically starts the workflow by
placing the entry in theinitia state of the workflow process that you specified.

When you enable a folder to support multiple entry types, you can associate workflows to the
specific types of entries. For example, if you have afolder that supports both file entries and
calendar entries, you can have one kind of workflow start when you create a file entry, and another
kind of workflow start when you create a Calendar entry. For information on how to enable multiple
entry typesin asingle folder, see Section 3.2.1, “Enabling Alternate Folder Entry Types,” on

page 26.

11.7.2 Enabling Workflows to Start When Users Comment on or
Reply to an Entry

You can enable aworkflow to automatically start when users comment on or reply to an entry. This
is called “ associating workflows with comments or replies.”

1 Navigate to the folder where you want to enable the workflow.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Workflows Associations section, in the Comment or Reply Types section, click the drop-
down list next to the comment or reply type that you want to associate the workflow with, then
select the desired workflow.
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To add workflows to this drop-down list, you need to create them. After workflows have been
created at thisfolder level, or at a higher workspace level, they appear in thislist. For
information on how to create workflows, see either Section 11.1, “Creating a Simple
Workflow,” on page 113 or Section 11.2, “Creating an Advanced Workflow,” on page 120,
depending on the type of workflow that you want to create.

4 Click Apply > Close.

Now, when this type of comment or reply is made to an entry in this folder, Vibe automatically
starts the workflow by placing the entry in theinitia state of the workflow process that you
specified.

11.7.3 Allowing Users to Manually Start Workflows

You can allow usersto decide if they want to start aworkflow on an entry, and if they do, at what
point they want to start the workflow. Also, you can give users the option to choose among multiple
workflows for each entry.
1 Navigate to the folder where you want to enable users to start the workflows.
2 Click Folder > Configure in the Action toolbar.
The Configure Default Settings page is displayed.

3 Inthe Allowed Workflows section, select the workflows that you want to allow users to choose
from.

The Local Definitions section in the Allowed Wor kflows section displays al of the workflows
that you have created locally. The other workflows listed in the Allowed Wor kflows section
were either created by your Vibe administrator, by another user at a higher level in the
workspace tree, or are included with the Vibe product.

4 Click Apply > Close.

Now, when users create entries in this folder, they can start and stop workflows as they desire.
For information on how to start and stop a workflow, see “Using Workflows” in the Kablink
Vibe OnPrem 3.1 User Guide.

11.8 Testing A Workflow

To test aworkflow, simply create the workflow in a testing workspace and ensure that it works
according to your specifications. When the workspace is ready to be deployed in a production
environment, export the workflow, then import it into the production workspace where you want to

deploy it.
For information on how to import and export aworkflow, see Section 11.9, “Importing and
Exporting a Workflow,” on page 148.

11.9 Importing and Exporting a Workflow

Kablink Vibe enables you to import and export workflows into and out of Vibe.

+ Section 11.9.1, “Importing a Workflow,” on page 149
+ Section 11.9.2, “Exporting a Workflow,” on page 149
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11.9.1 Importing a Workflow

1 Navigate to the workspace where you want to import the workflow.
2 Click Workspace > Form/View Designersin the Action tool bar.
3 Click Import.
The Import Definitions page is displayed.
4 Click Browse.
5 Browse for and select the workflow that you want to import.
6 Click OK > Close.

11.9.2 Exporting a Workflow

1 Navigate to the workspace where you created the workflow.
2 Click Workspace > Form/View Designers.
3 Click Export.
The Export Definitions page is launched.
4 Expand Workflow Processes, then select the workflow that you want to export.
5 Click OK.
6 Select the location where you want to save the workflow, then saveit.
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Managing Remote Applications

Remote applications communicate with athird-party, online application, and send information from
the third-party application back into Kablink Vibe OnPrem.

For example, your Vibe administrator could create a remote application for Twitter that displays all
of your Twitter entriesin Vibe.

Remote applications are vastly customizable, and are set up by your Vibe administrator. Talk with
your Vibe administrator if you have a request for a new remote application.

This section describes how to set up remote applications after they have already been created and
enabled by your Vibe administrator.

+ Section 12.1, “Adding Remote Applications to Views and Forms,” on page 151

+ Section 12.2, “ Setting Up a Remote Application,” on page 152

+ Section 12.3, “ Setting Up Multiple Remote Applications on a Single Page,” on page 154

+ Section 12.4, “Managing Access Controls for Remote Applications,” on page 155

12.1 Adding Remote Applications to Views and
Forms

Kablink Vibe enables you to add a Remote Application element to afolder or workspace view or a
custom form. The Remote Application element is a drop-down list that enables users of the view or
form to select from alist of remote applications. Thisis useful if the current view or form does not
allow you to select aremote application to run; it is also useful if you want to run multiple remote
applicationsin asingle view or form. (For specific information on configuring aview or form to run
multiple remote applications, see Section 12.3, “ Setting Up Multiple Remote Applications on a
Single Page,” on page 154.)

Unless you are the Vibe administrator, you can perform the following procedure only on custom
views and forms for which you have appropriate rights. You can create custom views and forms for
workspaces, folders, or entries, as described in Chapter 7, “ Creating Custom Workspace Views,” on
page 77, Chapter 8, “Creating Custom Folder Views,” on page 87, and Chapter 9, “Designing
Custom Folder Entry Forms,” on page 97.

To add a Remote Application element to aview or form:

1 Navigate to the workspace or folder where you want to add the Remote A pplication element.

If you want to add the Remote Application element to aform, navigate to the workspace or
folder where the form was created.

2 Click Workspace > Form/View Designersif the form was created at the workspace level.
or
Click Folder > Form/View Designersif the form was created at the folder level.
The Form and View Designers page is displayed.
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3 Click the entry definition, folder view, or workspace view where you want to add the Remote
Application element.

4 Add the Remote Application element to the desired folder view, workspace view, or entry
definition, as described in the following sections:

Folder View: Section 8.1.2, “Adding Elements to the Folder Add/Modify Form,” on page 88.

Workspace View: Section 7.1.2, “Adding Elements to the Workspace Add/Modify Form,” on
page 78.

Entry Definition (Form): Section 9.2.2, “ Adding Elements to the Entry Form Definition,” on
page 99.

12.2 Setting Up a Remote Application

+ Section 12.2.1, “ Setting Up a Remote Application in a Workspace,” on page 152
+ Section 12.2.2, “ Setting Up a Remote Application as an Accessory,” on page 152

12.2.1 Setting Up a Remote Application in a Workspace

1 Navigate to the workspace or folder where you want to display the remote application.
2 Click Workspace > Edit Workspace, or Folder > Edit Folder.

3 Inthe Remote Application section, click the drop-down list and select the remote application
that you want to enable.

4 Click OK.
The remote application is displayed at the top of the folder or workspace.

12.2.2 Setting Up a Remote Application as an Accessory

Kablink Vibe allows you to set up remote applications as accessories. You might want to do thisif
you want to view more than one remote application on asingle Vibe page.
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This section describes how to create an accessory that references a remote application.

1 Navigate to the page where you want to create the Remote Application accessory.

2 Locate the Accessory Panel, then click Accessory Panel.

Accessory Panel » =
Add an Accessony
Show Hidden Borders and Controls
Set the accessory panel's tile
Set Default Layout for Personal Global Accessories

Set Default Layout for Community Accessories

3 Click Add an Accessory.

Accessory Scope
i@ Personal Accessory for This Page Only

) Personal Accessary for all Workspaces and Folders 0
) Community Accessory for This Page (7]

Accessory Type

= Search Results

) Workspace Tree

(™) Formatted Text (HTML Editor)
™ Embedded Web Page (iframe)
(™ Buddy List

™ Team Members

= Photo Gallery

™ Blog Summary

= Guestbook

i Task Summary

(™) Wiki Home Page

= Calendar Summary

i@ Remote Application

o Y conce

4 Select the scope of the accessory you want to create, then select Remote Application.

5 Click OK.

Accessory Setup

Accessory Setup
Acoessory Scope: Personal Accessory for This Page Only

Remote Application
Title

Display Style
©® Border
©) No border

Remote Application
Vibe OnPrem Connector E|

ooy JX cose I veee 3
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6 Specify atitle for the accessory, then use the Remote Application drop-down menu to select the
remote application that you want to add.

7 Click Apply > Close.
The new accessory is displayed.

12.3 Setting Up Multiple Remote Applications on
a Single Page
You can use either of the following methods to set up multiple remote applications on asingle
Workspace or Folder.

¢ Section 12.3.1, “Launching a Remote Application as an Accessory,” on page 154

+ Section 12.3.2, “Creating a New Workspace or Folder View That Supports Multiple Remote
Applications,” on page 154

12.3.1 Launching a Remote Application as an Accessory

If you want to view more than one remote application on asingle Kablink Vibe page, you can set up
one remote application in your workspace, and then you can view subsequent remote applications as
accessories.

For more information on viewing remote applications as accessories, see Section 12.2.2, “ Setting
Up a Remote Application as an Accessory,” on page 152.

12.3.2 Creating a New Workspace or Folder View That
Supports Multiple Remote Applications

If you don't want your remote application to be displayed as an accessory, but you still want to
enable multiple remote applications on a single page, you can accomplish this by creating a new
view for the workspace or folder where you want the remote applications to be displayed, and then
configuring the workspace or folder to support the new view.

+ “Creating the New View” on page 154

+ “Configuring the Workspace or Folder to Support the New View” on page 155

+ “Using the New View to Enable a Remote Application” on page 155

Creating the New View
1 Inthe Workspace or Folder where you want to enable additional remote applications, click
Workspace > Form/View Designers or Folder > Form/View Designers.
The Form and View Designers page is launched.

2 Click New > Folder Views or Workspace Views, depending on whether you are working in a
workspace or folder.

Provide a caption and a name for the new definition.

Select the type of workspace for which you want to create the new definition.
Click OK.

Click the Workspace Add/Modify Form link.

o 01~ W
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7 Inthe box on theright side of the page, click Add.
8 Inthe Form Elements section, click Remote Application.
9 Provide acaption and a name for the new remote application field that you’ re creating.

Thetext that you enter in the Caption field is what the remote application field is called in the
workspace or folder form.

10 Click OK.
11 Click Closeto exit the Form and View Designer.

Configuring the Workspace or Folder to Support the New View
1 Navigate to the workspace or folder where you want to implement the new definition that you
created in “ Creating the New View” on page 154.
2 Click Workspace > Configure or Folder > Configure.

3 Inthe Default View section, select the new definition that you created in “ Creating the New
View” on page 154.

4 Click Apply > Close.

Using the New View to Enable a Remote Application

Now that you have created the new definition and configured the workspace or folder to support it,
you need to enable the additional remote application.

To enable the additional remote application, see Section 12.2, “ Setting Up a Remote Application,”
on page 152.

12.4 Managing Access Controls for Remote
Applications

Because not all remote applications can be completely trusted, it is often a good ideato limit the
privileges of the remote application. Because Kablink Vibe administrators are responsible for

creating and enabling the remote application for the Vibe site, they are also responsible for setting up
access controls on the remote application.

Before you modify the access control settings of remote applications for a specific workspace or
folder, you should consult with your Vibe administrator to ensure that what you plan to do is safe.

When an application is restricted to a specific role, the application can use Web services to perform
only those tasks that are allowed for that role. For example, the Participant role can create new
entries, modify entries that the user created, add comments to entries, and so on. Participants cannot
perform system administration tasks and cannot modify other users' entries.

To limit the remote application to privileges assigned to a specific role:

1 Navigate to the folder or workspace where you want to set the access control settings on the
remote application.
2 Click Workspace > Access Control or Folder > Access Control.

3 Onthe Configure Access Control page, click Add an Application.
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Add an Application

4 Inthe Add an Application field, use type-to-find functionality to specify and select the
application that you want to add.

5 Closethe Add an Application panel by clicking the X in the upper right corner.

6 Inthe access control table, select the check box that islocated in the row of the remote
application that you just added, and the column of the role that you want to assign to the
application.

Add an Application = Application Title Application Name Warkspace Crestor  Participart  Tesm Member

Hella Warld hellowarld O |

7 Click Save Changes > Close.

The application that you added is now restricted to those operations allowed for the role that you
selected. For example, if you assigned the Participant role to the remote application, then the
inheritance of workspace and folder access controls meansthat it is very likely that most workspaces
and foldersinherit this setting. Assuming that all placesinherited this setting, the most powerful role
the remote application can assume within the installation is that of a Participant.

If you are not sure what access control settings to assign to a particular remote application, consult
with your Vibe administrator.

If your Vibe administrator has enabled multiple applications for your site, some of these applications
might be grouped together in an Application Group. Application Groups are similar to groups that
contain usernames. Application groups contain the names of registered applications. After your Vibe
administrator defines application groups, you as aworkspace and folder owner can assign access-
control roles to groups of applications instead of assigning rolesto one application at atime.
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Managing Your Data Quota

Data quotas can be enabled by your Kablink Vibe OnPrem administrator in order to limit the amount
of datathat is stored on the Vibe site. For information on how the Vibe administrator can enable data
guotas, see “Managing Disk Space Usage with Data Quotas’ in the Kablink Vibe OnPrem 3.1
Administration Guide.

If data quotas have been enabled on your Vibe site, you need to understand what counts toward your
data quotas, the different kinds of data quotas that exist, and how you can view the current data
usage so you can know when you are approaching the allotted data quota. If you meet your allotted
guota, Vibe enables you to purge files and attachments that you have previously deleted.

+ Section 13.1, “Understanding Data Quotas,” on page 157

+ Section 13.2, “Viewing Your Data Quota,” on page 158

+ Section 13.3, “ Setting a Data Quota for Workspaces and Folders,” on page 160

+ Section 13.4, “Adding Files and Attachments to the Vibe Site When You Are Over Your
Quota,” on page 161

+ Section 13.5, “E-Mailing Files and Attachments to the Vibe Site When You Are Over Your
Quota,” on page 161

+ Section 13.6, “Adding Files Through WebDAV When You Are Restricted by a Data Quota,” on
page 161

+ Section 13.7, “Working with File Versions When You Are Restricted by a Data Quota,” on
page 161

+ Section 13.8, “Making Disk Space Available by Purging Deleted Items,” on page 162

13.1 Understanding Data Quotas

Only files and attachments count toward your data quota. Workspaces, folders, and entries that do
not contain files and attachments do not count toward your data quota. Files and attachments must
be deleted and purged in order to make more disk space available.

The Kablink Vibe OnPrem administrator can enable two kinds of data quotas:

¢ User data quotas
+ Workspace and folder data quotas

The administrator can enable one of these quotas, or both of them.

+ Section 13.1.1, “Understanding User Data Quotas,” on page 157
+ Section 13.1.2, “Understanding Workspace and Folder Data Quotas,” on page 158

13.1.1 Understanding User Data Quotas

User data quotas limit the amount of dataindividual users can add to the Vibe site. Any files and
attachments that you add to the Vibe site counts toward your data quota, regardless of the folders or
workspaces where you add them.
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13.1.2 Understanding Workspace and Folder Data Quotas

Workspace and folder quotas limit the amount of data that can be stored in individual workspaces
and folders.

Sub-workspaces and sub-folders that have a data quota are subject to their own data quotaaswell as
any data quotas that exist on parent folders and workspaces. For example, consider aworkspace that
has a data quota of 50 MB. The workspace contains two sub-workspaces: Workspace A and
Workspace B. Users cannot upload datathat isin excess of 50 MB into either of these sub-
workspaces. Furthermore, users cannot upload data into both of these sub-workspacesthat isin
excess of 50 MB (for example, users cannot upload data that is in excess of 30 MB into both sub-
workspace, because the amount of combined data for both sub-workspacesis greater than 50 MB).

13.2 Viewing Your Data Quota

Data quotas might or might not be in use on your Vibe site. If you are unable to view your data
guotas as described in this section, your Vibe administrator has not yet restricted the amount of data
that can be added to the Vibe site.

If you have exceeded your allotted data quota, you should purge items that you have previously
deleted, as discussed in Section 13.8, “Making Disk Space Available by Purging Deleted Items,” on
page 162.

+ Section 13.2.1, “Viewing Your User Data Quota,” on page 158
+ Section 13.2.2, “Viewing Your Workspace or Folder Data Quota,” on page 159

13.2.1 Viewing Your User Data Quota

If your administrator has set a user data quota and if you are an active contributor to your Kablink
Vibe site, you might want to periodically view your current data quota to ensure that you are not
approaching the user limit.

To view your current data quota and how much you are currently using:

1 Navigate to the home page of your personal workspace.
2 Click the Profile link, located next to your name.
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3 Your data quotais displayed in the upper right corner of the Profile page, along with the
amount you are currently using.

13.2.2 Viewing Your Workspace or Folder Data Quota

The Vibe administrator can set a data quotaon your workspaces and folders, or the administrator can
allow you to set your own data quotas on your own workspaces and folders.

You must be an administrator for the workspace or folder in order to view data quotas.
To view your current workspace or folder quota:

1 Navigate to the workspace or folder where you want to view the quota.

2 Click Workspace > Manage Workspace Quota if you want to view the quota for a workspace.
or
Click Folder > Manage Folder Quota if you are managing the quota for afolder.
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The following data quota information is displayed for the workspace or folder:

+ Disk Space Used By This Workspace/Folder: The amount of disk space the workspace
or folder is currently using. This does not include disk space that is being used by sub-
workspaces and sub-folders.

+ Disk Space Used By This Workspace/Folder and All of 1ts Children: The amount of
disk space that is being used by the workspace or folder and all of its sub-workspaces and
sub-folders.

+ Current Quota: The current data quota that exists on the workspace or folder.

+ Lowest Quota on Parent Workspaces or Folders: The lowest quota that exists on any
workspace or folder that ishigher in the folder hierarchy than the workspace or folder that
you are currently viewing.

Sub-workspaces and sub-folders that have a data quota are subject to their own data quota
aswell as any data quotas that exist on parent folders and workspaces. For more
information, see Section 13.1.2, “Understanding Workspace and Folder Data Quotas,” on
page 158.

+ Changethe Quota: Enables you to change the data quota for the workspace or folder.

13.3 Setting a Data Quota for Workspaces and
Folders

The Vibe administrator can allow you to set your own data quotas for your workspaces and folders.
If you cannot set a data quota as described in this section, your administrator has not allowed this

capability.

If workspace and folder administrators have set data quotas at higher-level workspaces, your
workspaces and folders are subject to any quotas that are set on the higher-level workspaces. For
example, suppose you are the administrator of ateam workspace called “Online Marketing”. This
team workspace is a sub-workspace to aworkspace called “Marketing” . If the workspace
administrator for the Marketing workspace has set a data quota of 100 MB, usersin your workspace
and in other sub-workspaces to the Marketing workspace cannot upload more than 100 MB of
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collective data to the sub-workspaces, regardless of what is set as the data quota for the sub-
workspaces. For more information, see Section 13.1.2, “Understanding Workspace and Folder Data
Quotas,” on page 158.

To set adata quota for workspaces and folders:

1 Navigate to the workspace or folder where you want to view the quota.

2 Click Workspace > Manage Workspace Quota if you are managing the quota for aworkspace.
or
Click Folder > Manage Folder Quota if you are managing the quota for afolder.

3 Inthe Change the Quota field, specify the new data quota for the workspace or folder, then
click OK.

13.4 Adding Files and Attachments to the Vibe
Site When You Are Over Your Quota

If you have exceeded your data quota but you still need to add files and attachments to the Kablink
Vibe site, you need to decrease your disk usage by purging files and attachments that you have
previously deleted.

For information on how to purge deleted items, see Section 13.8, “Making Disk Space Available by
Purging Deleted Items,” on page 162.

13.5 E-Mailing Files and Attachments to the Vibe
Site When You Are Over Your Quota

Kablink Vibe enables you to add files and entry attachments to the Vibe site viae-mail, as described
in “Adding Entries to a Folder ViaE-Mail” in the Kablink Vibe OnPrem 3.1 User Guide. However,
if you have met your data quota, you are unable to e-mail entriesto Vibeif they include attachments.

If you have exceeded your allotted data quota, you should purge the items that you have previously
deleted, as discussed in Section 13.8, “Making Disk Space Available by Purging Deleted Items,” on
page 162.

13.6 Adding Files Through WebDAV When You
Are Restricted by a Data Quota

When you add files to the Kablink Vibe site through WebDAV, the files still count against your data
guota, just asif you had added the files through the regular Vibe interface.

13.7 Working with File Versions When You Are
Restricted by a Data Quota

Kablink Vibe enables you to create multiple versions of the samefile, as described in “Using
Version Control with Files’ in the Kablink Vibe OnPrem 3.1 User Guide.
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When you edit adocument in Vibe, Vibe creates a new version of thefile. This new version counts
against the data quota of the user who edited the file; it does not count against the quota of the user
who originaly posted the file. File versions also count against the data quota of individual
workspaces and folders.

You can manage your data quota by deleting previous versions of afile that you no longer need. For
information about how to delete prevsiousfile versions, see“ Deleting Existing Versionsof aFil€’ in
the Kablink Vibe OnPrem 3.1 User Guide.

IMPORTANT: When you use OpenOffice to edit adocument in Vibe, a new version of the
document is created each time you click Save. Because each version of a document counts agai nst
your data quota, you should save the document only onceif you are using OpenOffice as an editor.

When you use Microsoft Office, Vibe creates only one version when you save the document.
Clicking Save multiple times does not create multiple versions, as is the case when you edit
documents with OpenOffice.

13.8 Making Disk Space Available by Purging
Deleted Items

Files and attachments that have been deleted but not yet purged still count toward your data quota.
Workspaces, folders, and entries that do not contain files and attachments do not count toward your
data quota. If you have reached your allotted data quota, you need to purge deleted files and
attachments.

You can purge any item that you have rights to delete.

NOTE: Purged items cannot be recovered. When you purge items from the Vibe site, remember the
following:

+ Purging an entry also purges all attached files, comments, and replies.

+ Purging afolder also purges al entries and sub-folders that are associated with that folder.

+ Purging aworkspace also purges all folders, sub-folders, and entries that are associated with
that workspace.

1 Navigate to the folder or workspace where the deleted item that you now want to purge
previoudly resided.

For example, if you want to purge afile entry that wasin your personal Filesfolder, navigate to
the Files folder in your personal workspace.

If you want to see everything that has been deleted in the Vibe site, navigate to the highest level
workspace. (By default thisis the Home Workspace directory.)

2 Click the Trashicon lﬂi, located in the Navigation panel.

The Trash page displays all workspaces, folders, and entries that have been deleted in or below
the current workspace or folder.

3 Select the file entry or any other type of entry that contains an attachment that you want to
purge.

4 Click Purge> OK.
Theitem is purged from the Vibe site.
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Restoring Deleted Items

Kablink Vibe OnPrem enables you to undel ete aworkspace, folder, or entry that you previously
deleted, restoring it to its previous location. When you undel ete an entry, all associated attachments,
comments, and replies are also undel eted.

You cannot undelete an item that has been purged.

+ Section 14.1, “Rights Associated with Undeletion,” on page 163

Section 14.2, “Undeleting Workspaces, Folders, and Entries,” on page 163
Section 14.3, “Undeleting Mirrored Files,” on page 164

Section 14.4, “Undeleting Items That Contain Workflows,” on page 164
Section 14.5, “Locating Deleted Items,” on page 164

14.1 Rights Associated with Undeletion

Asagenerd rule, if you have rightsto delete an item in Kablink Vibe, you also have rights to
undelete that item.

*

*

*

*

Remember the following when undel eting:

+ You can undelete an item that another user deleted, if you have appropriate rights.

+ If you have rights to undelete an entry, but do not have rights to undelete the folder that
contains the entry, you cannot undelete the entry.

+ If you have rights to undelete a folder, but do not have rights to undel ete the workspace that
contains the folder, you cannot undel ete the fol der.

+ When you undelete afolder, the contents of the folder are not automatically undeleted. You
need to undel ete the contents of the folder separately.

+ When you undelete an entry in adel eted fol der, the folder is automatically undeleted. However,
if you do not have rights to undel ete the folder, you cannot undel ete the entry.

14.2 Undeleting Workspaces, Folders, and
Entries

If you have the appropriate rights, you can undelete any workspace, folder, or entry and restore it to
its previous location.

1 Navigate to the folder or workspace where the deleted workspace, folder, or entry previously
resided.

For example, if you want to restore aBlog folder that was in your personal workspace, navigate
to your personal workspace.

If you want to see everything that has been deleted in the Kablink Vibe site, navigate to the
highest level workspace. (By default thisis the Home Workspace directory.)

2 Click the Trashicon lﬂi, located in the Navigation panel.
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The Trash page displays all workspaces, folders, and entries that have been deleted in or below
the current workspace or folder.

3 Select the workspace, folder, or entry that you want to undelete.
4 Click Restore.
The workspace, folder, or entry is restored to its previous location.

14.3 Undeleting Mirrored Files

Undeleting files that have been deleted through amirrored folder is not supported in Kablink Vibe.
Files that are deleted through a mirrored folder cannot be recovered.

14.4 Undeleting Items That Contain Workflows

When you undel ete a workspace or folder where aworkflow has been created, the workflow is aso
restored with the workspace or folder.

When you undelete afolder entry where aworkflow has been enabled, the entry isrestored with the
workflow still enabled. The entry isin the same workflow state as it was when it was deleted.

14.5 Locating Deleted Items

If you cannot find an item in your Kablink Vibe site that you know was there previoudly, it has
probably been deleted.

To locate the deleted item, you can do either of the following:

+ Perform asearch for the deleted item, as described in “ Searching for Deleted Items” in the
Kablink Vibe OnPrem 3.1 User Guide.

+ Navigateto the folder or workspace where the item previously resided, and click the Trash icon
IE' located in the Navigation panel, as described in Section 14.2, “Undel eting Workspaces,
Folders, and Entries,” on page 163.
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Using Vibe on Your Mobile Phone

Mobile access to the Kablink Vibe OnPrem site can be deactivated by your Vibe administrator. If
you are unable to access the Vibe mobile interface as described in this section, consult your Vibe
administrator.

¢ Section 15.1, “ Supported Mobile Devices,” on page 165
Section 15.2, “Browser Requirements,” on page 165
Section 15.3, “Getting Started,” on page 165
Section 15.4, “ Supported Features,” on page 167
Section 15.5, “Features that Are Not Supported in the Vibe Mobile Interface,” on page 174
Section 15.6, “ Security Considerations,” on page 174
Section 15.7, “ Troubleshooting Your Maobile Device,” on page 174

*

*

*

*

*

*

15.1 Supported Mobile Devices

The Kablink Vibe mobile interface is supported on the following mobile devices:

+ iPhone
+ BlackBerry
+ Any other mobile device that provides an HTTP/HTML-based interface

Ensure that your device's browser meets the requirements that are discussed in Section 15.2,
“Browser Requirements,” on page 165.

For tablet devices such as the iPad, the default interface is the same as when you access Vibe from
your workstation.

15.2 Browser Requirements

To use Kablink Vibe from a mobile device, your device's browser must support:

+ HTML 4
+ JavaScript

15.3 Getting Started

Use the following information to help you access Kablink Vibe from your mobile device, and learn
basic navigation:

+ Section 15.3.1, “ Accessing the Vibe Mobile Interface,” on page 165
+ Section 15.3.2, “Navigating to the Home Page of the Maobile Interface,” on page 166

15.3.1 Accessing the Vibe Mobile Interface

1 Onyour mobile device, launch a Web browser such as Mozilla Firefox or Internet Explorer.
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2 Specify the URL of your corporation’s Vibe site.
For example, http://host : port.

Vibe automatically detects that you are using a mobile device, and directs you to the Vibe
mobile interface.

If Vibe displays the regular Vibe interface instead of the mobile interface, add /mobile to the
end of the Vibe URL, asdiscussed in “Your Browser Does Not Automatically Direct You to the
Mobile Interface” in “ Troubleshooting” in the Kablink Vibe OnPrem 3.1 User Guide.

Novell.
\

N Copyright Novad, Inc, 2000-2010. All ights reserved

3 Specify your username and password, then select Sign In.
The mobile home pageis displayed.
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15.3.2 Navigating to the Home Page of the Mobile Interface

Regardless of where you are in the Vibe mobile interface, you can easily navigate to the home page.

1 Select Home in the Navigation toolbar at the top of the mobile interface.
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The home page is displayed.
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15.4 Supported Features

+ Section 15.4.1, “Searching the Mobile Interface,” on page 167

+ Section 15.4.2, “Viewing Your Teams,” on page 169

+ Section 15.4.3, “Viewing Your Favorite Places,” on page 169

+ Section 15.4.4, “Viewing Your Recent Places,” on page 169

+ Section 15.4.5, “Viewing File Entries and Attachments,” on page 169

¢ Section 15.4.6, “Viewing YouTube Videos,” on page 169

+ Section 15.4.7, “Viewing What's New,” on page 170

+ Section 15.4.8, “Viewing What's Unread,” on page 171

+ Section 15.4.9, “Viewing the Workspace Tree,” on page 171

+ Section 15.4.10, “Deleting a Folder Entry,” on page 171

+ Section 15.4.11, “ Calling Vibe Users with One Click (iPhone Only),” on page 172
+ Section 15.4.12, “Sending E-Mail,” on page 172

+ Section 15.4.13, “Following People and Places of Interest,” on page 172

+ Section 15.4.14, “Transitioning Entries from One Workflow State to Ancther,” on page 173
+ Section 15.4.15, “Using Folders,” on page 173

15.4.1 Searching the Mobile Interface

The Kablink Vibe mobile interface enables you to search for people, places, entries, and
attachments.
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Advanced Search is not supported in the mobile interface. However, you can save an advanced
search when you access Vibe from your workstation, then use it on your mobile device.

+ “Performing aBasic Search” on page 168
+ “Using a Saved Search” on page 168

Performing a Basic Search
To perform abasic search in the Vibe mobile interface:

1 Select Search in the Navigation toolbar at the top of the mobile interface.
The Search drop-down menu is displayed.

| SEARCH

© Search The Whole Site
() Search This Workspace

[ J
(:E) (: Cancel )

2 Inthe drop-down list, select the category for which you want to search.
You can search for People, Places, or All.

3 Select whether you want to search the entire Vibe site, or only the workspace that you currently
arein.

4 Specify the words or phrases that you want to search for, then select OK.
The Search Results page is displayed.

Using a Saved Search

Vibe enables you to perform saved searches that you have previously created and saved when
accessing the Vibe site from your workstation.

TIP: Even though the Vibe mobile interface does not have an Advanced search, you can create and
save an Advanced search when you access the Vibe site from your workstation. You can then use the
saved search on your mobile device.

For information on how to create a saved search, see “ Saving and Reusing Searches’ in the Kablink
Vibe OnPrem 3.1 User Guide.

For information on how to save an Advanced Search when accessing the Vibe site from your
workstation, see “Using Advanced Search” in the Kablink Vibe OnPrem 3.1 User Guide.

To access and use a saved search from the Vibe mobile interface:

1 Select Search in the Navigation toolbar at the top of the mobile interface.
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2 Inthe Saved Searches section, select the saved search that you want to run.
The Search Results page displays the results for your saved search.

15.4.2 Viewing Your Teams

You can quickly view al the teams of which you are a member.

1 Onthe home page, select My Teams.

15.4.3 Viewing Your Favorite Places

You can quickly view your favorite places.
1 Onthe home page, select My Favorites.
To add or delete favorites, you must access the Vibe site from your workstation. For more

information, see “Managing Your Favorite Places’ in the Kablink Vibe OnPrem 3.1 User Guide.

15.4.4 Viewing Your Recent Places

The Vibe mobile interface enables you to quickly view workspaces and folders that you have visited
since you last logged in to the current Vibe session.

1 Select Actions > Recent Places.

15.4.5 Viewing File Entries and Attachments

The Vibe mobile interface enables you to view file entries as well as documents that have been
attached to entries.

1 Navigate to and select the entry that contains the document that you want to view.
2 Inthe Attachments section, select View next to the document that you want to view.

TIP: If your mobile deviceis capable of viewing the filein its native format, you can simply click
thefilelink to view thefile.

For example, when you use an iPhone, you can click thefilelink to view Microsoft Word files, PDF
files, and Microsoft Excel files.

15.4.6 Viewing YouTube Videos

The Vibe mobile interface enables you to view YouTube videos that are posted in your Vibe site.
However, you cannot use a mobile device to view YouTube videos that are posted in the Branding
section of workspaces or folders; the video must be posted within afolder entry or in the Description
section of the folder or workspace.

Your BlackBerry or other mobile device might not be properly set up to view YouTube videos. If
you are having difficulty viewing YouTube videos from your mobile device, follow the instructions
in“You Are Unable to View YouTube Videos from Your Mobile Device’ in the Kablink Vibe
OnPrem 3.1 User Guide.
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To view a YouTube video from the Vibe mobile interface:

1 Navigate to and select the entry that contains the YouTube video that you want to view.
2 Click the YouTube icon .
You are directed to the mobile YouTube site to view the video.

To post YouTube videos, you must access the Vibe site from your workstation. For more
information, see “Displaying YouTube Videosin aFolder Entry” in the Kablink Vibe OnPrem 3.1
User Guide.

15.4.7 Viewing What's New

The Vibe mobile interface enables you to see new entries that have been added to the Vibe site.

+ “Viewing What's New in Your Teams” on page 170

+ “Viewing What's New in Your Followed Places’ on page 170

+ “Viewing What's New in Your Favorite Places’ on page 170

+ “Viewing What's New Across the Entire Site” on page 170

+ “Viewing the Newest Micro-Blog Entries of People You're Following” on page 170
+ “Viewing What's New in aFolder” on page 170

+ “Viewing What's New in a Workspace” on page 171

Viewing What's New in Your Teams

1 From the What's New drop-down list on the home page, select My Teams.

Viewing What's New in Your Followed Places

1 From the What's New drop-down list on the home page, select All Followed.

Viewing What's New in Your Favorite Places

1 From the What's New drop-down list on the home page, select Favorites.

Viewing What's New Across the Entire Site

1 From the What's New drop-down list on the home page, select Ste Wide.

Viewing the Newest Micro-Blog Entries of People You're Following

1 From the What's New drop-down list on the home page, select Micro-Blogs.

Viewing What's New in a Folder

1 Navigate to the folder where you want to see new items.
2 Select Actions > New in This Folder.
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Viewing What's New in a Workspace

1 Navigate to the workspace where you want to see new items.
2 Select Actions > New in This Workspace.

15.4.8 Viewing What’'s Unread

The Vibe mobile interface enables you to see new entries that have been added to the Vibe site.

+ “Viewing What's Unread in a Folder” on page 171
+ “Viewing What's Unread in a Workspace” on page 171
+ “Viewing What's Unread across the Entire Site” on page 171

Viewing What's Unread in a Folder
1 Navigate to the folder where you want to see new items.
2 Select Actions > Unread in This Folder.
Viewing What's Unread in a Workspace
1 Navigate to the workspace where you want to see new items.
2 Select Actions > Unread in This Workspace.

Viewing What's Unread across the Entire Site

1 Navigate to your home page, then click Actions > Unread Ste Wide.

15.4.9 Viewing the Workspace Tree

The Vibe mobile interface enables you to view the Workspace tree, so you can see the hierarchy of
where you currently are and quickly navigate to a different workspace or folder.

1 Select the Treeicon .
The Workspace treeis displayed.

NAVIGATION

Home Workspace
Personal Workspaces

Anita Olivos (aolivos)

r ™y

Close

15.4.10 Deleting a Folder Entry

The Vibe mobile interface enables you to delete folder entries.

1 Navigate to and select the entry that you want to delete.
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2 Click Delete.
If you do not have rights to delete the entry, this option is not displayed.
3 Click OK when asked if you really want to delete the entry.

15.4.11 Calling Vibe Users with One Click (iPhone Only)

When you use Vibe from your iPhone, you can call other Vibe users with just one click.

1 Navigate to the persona workspace of the user whom you want to call.

You can navigate to a user’s personal workspace by selecting the user’s linked name that
appears next to any entry that user has posted. Or, you can search for the user as described in
Section 15.4.1, “ Searching the Mobile Interface,” on page 167.

2 Select the user’s linked phone number.
A call ismade to the user.

15.4.12 Sending E-Mail

The Vibe mobile interface enables you to quickly send e-mail to other Vibe users.

1 Navigate to the persona workspace of the user to whom you want to send an e-mail.

You can navigate to a user’s personal workspace by selecting the user’s linked name that
appears next to any entry that user has posted. Or, you can search for the user as described in
Section 15.4.1, “ Searching the Mobile Interface,” on page 167.

IEI Actions

= Julio Chavez
™ 1) ichavez@greenergy.com
B jchavez{@greenergy.com

801-555-0100

Project Management Workspace

Blog

Calendar
2 Select the user’s linked e-mail address.

15.4.13 Following People and Places of Interest

The Vibe mobile interface enables you to follow places or people. You can easily see activity
generated in the specific place that you are following, or by the specific person that you are
following.

+ “Configuring Vibe to Follow Workspaces, Folders, and People’ on page 173
+ “Viewing Your Followed Workspaces, Folders, and People of Interest” on page 173
+ “Unfollowing Workspaces, Folders, or People” on page 173

172 Kablink Vibe OnPrem 3.1 Advanced User Guide



Configuring Vibe to Follow Workspaces, Folders, and People
1 Navigate to the workspace or folder that you want to follow. If you want to follow a person,
navigate to the user’s personal workspace.

2 Select Actions > Follow this Folder, Follow this Workspace, or Follow this Person, depending
on what you want to follow.

Viewing Your Followed Workspaces, Folders, and People of Interest

If you are currently following aworkspace, folder, or person, Vibe enables you to easily see activity
generated in the specific place that you are following, or by the specific person that you are
following.

1 Navigate to the home page of the Vibe mobile interface.

For information on how to do this, see Section 15.3.2, “ Navigating to the Home Page of the
Mobile Interface,” on page 166.

2 Inthe What's New drop-down list, select All Followed.
Vibelistsal of the new entriesthat have been posted to the folders and workspaces that you are

following, and lists the entries that have been contributed by the people you are following.
Unfollowing Workspaces, Folders, or People

If you are currently following someone or some place in Vibe, you can unfollow that person or place
in the Vibe mobile interface.

1 Navigate to the workspace or folder that you want to stop following. If you want to stop
following a Vibe user, navigate to that user’s personal workspace.

2 Select Actions > Sop Following this Workspace, Sop Following this Folder, or Sop Following
this Person, depending on what you want to stop following.

15.4.14 Transitioning Entries from One Workflow State to
Another
The Vibe mobile interface enables you to transition entries from one workflow state to another.

For information on how to create aworkflow, see Chapter 11, “ Creating and Managing Workflows,”
on page 113.

To transition entries to another workflow state in the Vibe mobile interface:

1 Navigate to and select the entry that you want to transition to a new workflow state.
2 Inthe Workflow section, select the new workflow state in the drop-down list, then select OK.

15.4.15 Using Folders

The Vibe mobile interface enables you to use most types of Vibe folders. However, not all folder
types support the full functionality that is available when accessing the Vibe site from your
workstation. For more information, see Section 15.5, “Features that Are Not Supported in the Vibe
Mobile Interface,” on page 174.
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15.5 Features that Are Not Supported in the Vibe
Mobile Interface

The following Kablink Vibe features are not supported when you access Vibe from the mobile
interface. If you want to use any of these features, you must access Vibe from your workstation:
¢ “Using Advanced Search” in the Kablink Vibe OnPrem 3.1 User Guide
+ “Viewing and Revisiting Recent Entries’ in the Kablink Vibe OnPrem 3.1 User Guide

+ “Adding aFavorite Place” and “Editing Your Favorite Places’ in the Kablink Vibe OnPrem 3.1
User Guide

+ “Creating a New Folder” in the Kablink Vibe OnPrem 3.1 User Guide
+ “Working with Surveys Folders’ in the Kablink Vibe OnPrem 3.1 User Guide

You can use the Vibe mobile interface to view Surveys folders and see the titles of the
individual surveysthat the folders contain, but you cannot view the survey itself or participate
init.
+ “Viewing Your Tasksin aFull Interactive View” in the Kablink Vibe OnPrem 3.1 User Guide
+ Chapter 5, “Branding a Folder or Workspace,” on page 47

You cannot use the Vibe mobile interface to brand aworkspace or folder, or view branding that
has already been created on aworkspace or folder.

+ “Editing Files” in the Kablink Vibe OnPrem 3.1 User Guide
+ “Attaching Filesto a Folder Entry” in the Kablink Vibe OnPrem 3.1 User Guide

15.6 Security Considerations

When you access Kablink Vibe from your mobile device, you enjoy the same security as when you
access Vibe from your workstation. Security features include:

¢ Secure accessviaSSL.

+ All previously established access control settings are preserved in the mobile interface.

However, you cannot set new access control settings in the mobile interface. For information
on how to set new access control settings when you access the Vibe site from your workstation,
see Chapter 4, “Controlling Access,” on page 37.

15.7 Troubleshooting Your Mobile Device

If you encounter difficulties when accessing Kablink Vibe from your mobile device, see
“Troubleshooting Your Mobile Device” in the Kablink Vibe OnPrem 3.1 User Guide.
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What's New in Vibe 3x

In Kablink Vibe OnPrem 3x you' |l find new features, afresh user interface, and significant updates.
Thefollowing list is an overview of the new featuresin Vibe for advanced users.

¢ Section A.1, “HTML Markup Language (v3.1),” on page 175

+ Section A.2, “Workflow Enhancements (v3.1),” on page 175

+ Section A.3, “Landing Page Enhancements (v3.1),” on page 175

+ Section A.4, “Workspace and Folder Data Quotas (v3.1),” on page 176
+ Section A.5, “Custom Digest Natifications (v3.1),” on page 176

+ Section A.6, “Capture E-Mail You Send from the Vibe Sitein One Location (v3.1),” on
page 176

+ Section A.7, “Mobile Enhancements (v3.1),” on page 176
+ Section A.8, “Improved Folder and Workspace Branding (v3),” on page 177
+ Section A.9, “Entry-Level Access Controls (v3),” on page 177

A.1 HTML Markup Language (v3.1)

Novell Vibe 3.1 enablesyou to add HTML markup into any HTML editor, such asin the Description
section of entries, folders, and workspaces. For more information, see Appendix B, “Using HTML
Markup in Vibe OnPrem,” on page 179.

A.2 Workflow Enhancements (v3.1)

Novell Vibe 3.1 provides new workflow capabilities. These capabilities include:
+ Control which users can manually transition workflows
For more information, see Section 11.4.3, “ Setting A ccess Controls on aManual Transition,”
on page 143.
+ Transition the workflow after users have responded

For more information, see “ Designating Specific Users to Respond to a Workflow Question”
on page 135.

+ Specify e-mail addresses for workflow notifications
For more information, see Section 11.1.5, “ Sending E-Mail Notifications,” on page 118.

A.3 Landing Page Enhancements (v3.1)

+ Section A.3.1, “Reordering Content on a Landing Page,” on page 176
+ Section A.3.2, “Adding HTML Content to a Landing Page,” on page 176
+ Section A.3.3, “Adding Extensions to a Landing Page,” on page 176
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A.3.1 Reordering Content on a Landing Page

Novell Vibe 3.1 enables you to reorder content on your landing page. For more information, see
Section 6.5, “Reordering the Content of Your Landing Page,” on page 68.

A.3.2 Adding HTML Content to a Landing Page

Novell Vibe 3.1 enables you to add an HTML editor to your landing page. For moreinformation, see
Section 6.2.2, “ Adding Content to Your Landing Page,” on page 53.

A.3.3 Adding Extensions to a Landing Page

Novell Vibe 3.1 enables you to add extensions to your landing page. For more information, see
Section 6.2.2, “ Adding Content to Your Landing Page,” on page 53.

A.4 Workspace and Folder Data Quotas (v3.1)

If your Vibe administrator has enabled this functionality, you can set data quotas on workspaces and
foldersthat you are manage. For more information, see Section 13.3, “ Setting a Data Quota for
Workspaces and Folders,” on page 160.

A.5 Custom Digest Notifications (v3.1)

Novell Vibe 3.1 enables you to set custom digest notifications on your folders, rather than accepting
the default digest notification that is set up by your Vibe administrator.

For more information, see Section 3.5, “Configuring Folders to Send E-Mail Notifications to Other
Users,” on page 31.

A.6 Capture E-Mail You Send from the Vibe Site
in One Location (v3.1)

Like apersona e-mail Outbox for the Vibe site, you can configure afolder or any e-mail address to
receive all e-mail messages that you personally send from the Vibe site.

For more information, see Section 3.4, “ Setting Up a Folder or External E-Mail Address to Receive
All Sent E-Mail Messages,” on page 30.

A.7 Mobile Enhancements (v3.1)

Novell Vibe 3.1 enables you to delete folder entries from the mobile interface. For more
information, see Section 15.4.10, “Deleting a Folder Entry,” on page 171.

You can also add users, groups, and teams to calendar and task entries that you create from the
mobile interface.
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A.8 Improved Folder and Workspace Branding
(v3)
Adding a personal brand to your workspace or folder is easier than ever before with Kablink Vibe 3.

For information about how you can quickly create a personal brand, see Chapter 5, “Branding a
Folder or Workspace,” on page 47.

A.9 Entry-Level Access Controls (v3)

You can now set access controls on individual entries that differ from those set on the parent fol der.
For more information, see Section 4.2.2, “ Controlling Access to Entries,” on page 44.
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Using HTML Markup in Vibe

OnPrem

Vibe OnPrem enables you to add HTML markup into the following locations of the Vibe interface:

+ Any HTML editor, such asin the Description section of entries, folders, and workspaces.

For more information, see “Modifying the Description Section of an Entry”, “Modifying a
Folder”, and “Modifying a Workspace” in the Kablink Vibe OnPrem 3.1 User Guide.

+ The Subject Line and Notification Body of workflow notification messages.

For more information, see Step 7 in Section 11.1.5, “Sending E-Mail Notifications,” on

page 118.

You can add the following HTML markup items:

Markup Text

Function

{{vibe:title}}

{{vibe:user}}

{{vibe:user|[name}}

{{vibe:createdBy}}

{{vibe:createdBy|name}}

{{vibe:createdOn}}
{{vibe:modifiedBy}}

{{vibe:modifiedBy|name}}

{{vibe:modifiedOn}}

{{vibe:data | dataName}}

Outputs the title of the entry, folder, or workspace.

Outputs the name of the user who is viewing the entry, folder, or
workspace.

Outputs the user ID of the user who is currently viewing the entry, folder,
or workspace.

Outputs the name of the user who created the entry, folder, or workspace.

Outputs the user ID of the user who created the entry, folder, or
workspace.

Outputs the date the entry, folder, or workspace was created.

Outputs the name of the user who last modified the entry, folder, or
workspace.

Outputs the user ID of the user who last modified the entry, folder, or
workspace.

Outputs the date the entry, folder, or workspace was last modified.

Outputs the value of the specified data item. Data items are elements that
have been added to the form or view definition by using the Form and
View Designer. Replace dataName with the data name of the element
that you want to show.

For a list of elements, see Section 9.4, “Understanding Elements,” on
page 105.

For more information about how to use the Form and View Designer to
create custom forms and views, see Chapter 7, “Creating Custom
Workspace Views,” on page 77, Chapter 8, “Creating Custom Folder
Views,” on page 87, and Chapter 9, “Designing Custom Folder Entry
Forms,” on page 97.
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Markup Text Function

{{vibe:permalink | link}} Outputs a permalink to the current entry, folder, or workspace. Replace
1link with the permalink of the entry, folder, or workspace.

This markup option is most useful when used in the Subject line of a
workflow notification e-mail. For example, the Subject line might read, A
workflow changed occurred in entry. The user can then click
entry in the Subject line of the notification to be taken directly to the entry.

To get the permalink URL of a Vibe page, simply navigate to the page that
you want to link to, click Permalink in the footer toolbar, then copy the
permalink URL from the Permalink field.

{{vibe:image | imageName | Outputs the image that you specify. Replace imageName with the
alt=... | height=... | width=... | filename of the image that you want to display. Images must be attached
border=0 or 1}} to the entry, folder, or workspace.

For information on how to attach entries, see “Attaching Files to a Folder
Entry”, “Modifying a Folder”, and “Modifying a Workspace” in the Kablink
Vibe OnPrem 3.1 User Guide.

If you want to specify a custom size, you can add the alt, height, and width
arguments. These arguments are not required.

{{vibe:file | flename | title Outputs a link to a file. File must be attached to the entry, folder, or
workspace.

For information on how to attach entries, see “Attaching Files to a Folder
Entry”, “Modifying a Folder”, and “Modifying a Workspace” in the Kablink
Vibe OnPrem 3.1 User Guide.

For example, {{vibe:file | tree.jpg | tree}} outputs the word tree as a link to
the tree.jpg file.

[[entry title]] Creates a link to the entry that you specify. You must specify the exact
name of the entry.

For more information about creating links in Vibe, see “Linking to a Folder
or Folder Entry” in the Kablink Vibe OnPrem 3.1 User Guide.
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